Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 01-18-2005, 12:55 PM
BupBup BupBup is offline
Registered User
Location: USA
 
Join Date: Dec 2004
Posts: 18
Mein Auto: Bike
X3 - some problems in cold weather

This morning, the screen for my Nav system was black. It was 8 degrees here this morning. Anyone else have a problem with cold weather and the nav screen?

Two days after delivery, my steering wheel heater stopped working. and one of my speakers sounds like it is blown out (through no fault of my own).

I have a two week-old X3 3.0., with 1,050 miles
Reply With Quote
Ads by Google
  #2  
Old 01-18-2005, 01:06 PM
Desertnate's Avatar
Desertnate Desertnate is offline
Spelling Impaired
Location: St Louis
 
Join Date: Mar 2002
Posts: 5,598
Mein Auto: '10 Mazda3 HB
Quote:
Originally Posted by BupBup
This morning, the screen for my Nav system was black. It was 8 degrees here this morning. Anyone else have a problem with cold weather and the nav screen?

Two days after delivery, my steering wheel heater stopped working. and one of my speakers sounds like it is blown out (through no fault of my own).

I have a two week-old X3 3.0., with 1,050 miles
After things warmed up did the Nav screen come back. It isn't uncommon for displays like that to have problems in the extreme cold. Even the pixels on my radio have a hard time working in temps like you described.

Can't help with the steering wheel.
Reply With Quote
  #3  
Old 01-18-2005, 02:50 PM
b-y's Avatar
b-y b-y is offline
Officially Welcomed to the 'Fest
Location: Northern California
 
Join Date: Sep 2004
Posts: 3,737
Mein Auto: 328xiT & M roadster
Cold nav help

Spotted this on another board:
Quote:
"IF" your DVD Navigation display remains black and inoprative at low ambient temps (colder than 37*F) but then functions after all the electronic units have warmed up , and your X3 was made between 6/13/04 and 12/15/04 = ask your service dept. to look up B84 239 04 dated 12/20/04
Reply With Quote
  #4  
Old 01-19-2005, 04:54 AM
exthree exthree is offline
Registered User
Location: N.E. Pennsylvania
 
Join Date: Jan 2005
Posts: 78
Mein Auto: 2008 X3.0si, 2006 330xi
Quote:
Originally Posted by BupBup
This morning, the screen for my Nav system was black. It was 8 degrees here this morning. Anyone else have a problem with cold weather and the nav screen?

Two days after delivery, my steering wheel heater stopped working. and one of my speakers sounds like it is blown out (through no fault of my own).

I have a two week-old X3 3.0., with 1,050 miles

My screen only opened about 35% in near-zero weather. I called my dealer for advice aout this. Other than that it's running great in this climate.
Reply With Quote
  #5  
Old 01-19-2005, 10:14 AM
BupBup BupBup is offline
Registered User
Location: USA
 
Join Date: Dec 2004
Posts: 18
Mein Auto: Bike
I know, I know, it's a little ridiculous and I expect no sympathy. However, I did pay for the thing and it should work properly.

Quote:
Originally Posted by ff
Steering wheel heater??
Reply With Quote
  #6  
Old 01-19-2005, 10:15 AM
BupBup BupBup is offline
Registered User
Location: USA
 
Join Date: Dec 2004
Posts: 18
Mein Auto: Bike
Quote:
Originally Posted by b-y
Spotted this on another board:
That's helpful, thanks
Reply With Quote
  #7  
Old 01-19-2005, 10:25 AM
iChick iChick is offline
Hi Tech GI Jane
Location: California
 
Join Date: Nov 2004
Posts: 79
Mein Auto: 2005 X3 3.0i
Quote:
Originally Posted by BupBup
I know, I know, it's a little ridiculous and I expect no sympathy. However, I did pay for the thing and it should work properly.
I'm not laughing. I'm envious. My hubby thought it was a wussy option, and I caved and didn't order it.
Reply With Quote
  #8  
Old 01-19-2005, 10:57 AM
BupBup BupBup is offline
Registered User
Location: USA
 
Join Date: Dec 2004
Posts: 18
Mein Auto: Bike
Worth it when it worked

Quote:
Originally Posted by ff
I definitely agree. It's just that the thought of such extravagant things in our automobiles seems so...so...pompous. The days of the E30 M3 are gone.
It is such a great option to have on a cold day. No gloves, leather steering wheel and toasty-warm fingers. And cheap at $130, relative to all of the other options. I'd recommend it if it hadn't broken.
Reply With Quote
  #9  
Old 01-20-2005, 08:13 PM
x3man's Avatar
x3man x3man is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Sep 2004
Posts: 378
Mein Auto: M3/X3
Quote:
Originally Posted by BupBup
It is such a great option to have on a cold day. No gloves, leather steering wheel and toasty-warm fingers. And cheap at $130, relative to all of the other options. I'd recommend it if it hadn't broken.
Certainly a bit decadent but worthy on cold morning drives without gloves.
Reply With Quote
  #10  
Old 02-02-2005, 12:36 PM
maximus2773 maximus2773 is offline
Registered User
Location: new england
 
Join Date: Oct 2004
Posts: 1
Mein Auto: 325I
RE: Cold Weather Problems

I got in my x3 last night in 5 degree temps. A loud exhaust sound, high rev'ing transmission, and what seemed like either the hill descent control was on or the brakes were grabbing.

It did this the whole way home, the thing would not accelerate on the highway. At stop signs and lights it was idling at about 1.5 RPM, and shaking like it was going to stall.

I got home successfully, turned it off, and back on, and it sounded fine.

This morning i let it warm up for a while, and it has been fine all day.

I am also feeling every bump up through the steering column, it is getting worse.

Anyone else having these issues?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another X3 Review (long) mkh X5 E53 (1999 - 2006) 0 12-13-2003 04:10 PM
Coupe windows in COLD weather bol 3 Series / 4 Series 4 03-17-2002 06:29 AM
330Ci Cold weather package and other silly questions: Baptizer 3 Series / 4 Series 43 02-21-2002 12:12 PM
Problems with new 7-series SchwartzBlack General BMW 3 01-14-2002 07:13 PM
My E30 doesn't like the cold weather! DrBimmer General BMW 6 01-03-2002 05:53 PM


All times are GMT -7. The time now is 02:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms