ticking on cold start? - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-08-2005, 12:35 AM
dejavoo81 dejavoo81 is offline
Registered User
Location: seattle
 
Join Date: Dec 2004
Posts: 42
Mein Auto: 2001 x5 3.O sport
ticking on cold start?

I took it into the dealership and they replaced the spring on the tensioner with a hydraulic system. all this work and its still making a ticking sound on cold start for about 20 seconds. you guys know what this is?

has anyone had the problem of the steering wheel not returning to its set position after turning on the car? lemme know boys.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bimmer Ownership Phases... (Very very long) FSelekler General BMW Questions 31 02-08-2006 03:36 PM
S54 Cold Start Reprogramming JonM E36/7 Z3 (1996-2002) 26 10-03-2004 05:24 AM
Too often near red line a problem? kkalan 3 Series & 4 Series 12 08-04-2004 07:26 PM
why won't my car start? globemaster3 General BMW Questions 4 11-29-2003 09:25 PM
Rough Idle on cold start zcasavant 1M & M2 8 05-29-2003 05:40 PM


All times are GMT -7. The time now is 12:51 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.