Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-12-2005, 01:23 AM
machmeter's Avatar
machmeter machmeter is offline
Adolescent On-Call
Location: San Francisco
 
Join Date: Aug 2002
Posts: 3,263
Mein Auto: 330i
Dealer is truly mysterious...

I took my car in for service: rough idle/service engine light, really bad AM reception, some other stuff. The AM problem was that ever time I went under anything more than a leaf the radio went LOUD with static. Seemed to be tied to the NAV.

Service advisor calls to say: 1) one ignition coil is bad - they'll replace all 6 (known issue), 2) AM static is due to my aftermarket amps - they won't touch it! I argue that I took it to Service before the amps were installed to complain about the bad AM. But no luck. They won't do anything about it.

So I get my car back and guess what? The idle is fine - no surprise. And... the AM reception is now perfect!!! WTF!??? I'm in shock! Service is SO screwy! I really wonder what they did. Reset the radio?

Just had to share...
__________________
Reply With Quote
Advertisement
  #2  
Old 03-12-2005, 10:54 AM
Daver Daver is offline
Shake well
Location: Folsom, CA
 
Join Date: May 2002
Posts: 398
Mein Auto: 2003 325iT
I wonder if the bad ignition coil was throwing off electrical noise that was interfering with your radio
__________________

daver -- 2003 325iT
Reply With Quote
  #3  
Old 03-12-2005, 12:22 PM
machmeter's Avatar
machmeter machmeter is offline
Adolescent On-Call
Location: San Francisco
 
Join Date: Aug 2002
Posts: 3,263
Mein Auto: 330i
Quote:
Originally Posted by Daver
I wonder if the bad ignition coil was throwing off electrical noise that was interfering with your radio
I haven't thought about that! The noise was really tied to the NAV, though, cuz every time the map changed positions the noise changed tone, and switching from map mode to any other mode also made the noise change tone. I suppose the bad coil could have sent some RF interference that affected the NAV or the AM receiver.
__________________
Reply With Quote
  #4  
Old 03-12-2005, 12:31 PM
JetBlack330i JetBlack330i is offline
Banned
Location: Austin, TX
 
Join Date: Feb 2002
Posts: 5,341
Mein Auto: 2001 330i Sport
Quote:
Originally Posted by machmeter
I took my car in for service: rough idle/service engine light, really bad AM reception, some other stuff. The AM problem was that ever time I went under anything more than a leaf the radio went LOUD with static. Seemed to be tied to the NAV.

Service advisor calls to say: 1) one ignition coil is bad - they'll replace all 6 (known issue), 2) AM static is due to my aftermarket amps - they won't touch it! I argue that I took it to Service before the amps were installed to complain about the bad AM. But no luck. They won't do anything about it.

So I get my car back and guess what? The idle is fine - no surprise. And... the AM reception is now perfect!!! WTF!??? I'm in shock! Service is SO screwy! I really wonder what they did. Reset the radio?

Just had to share...
The AM is a known problem that, I suspect, BMW doesn't want to divulge. They may very well have done something secretly.
Search here for posts by a certain Known Plaintiff or something Plaintiff.
ATY???
Reply With Quote
  #5  
Old 03-12-2005, 12:40 PM
machmeter's Avatar
machmeter machmeter is offline
Adolescent On-Call
Location: San Francisco
 
Join Date: Aug 2002
Posts: 3,263
Mein Auto: 330i
Quote:
Originally Posted by JetBlack330i
The AM is a known problem that, I suspect, BMW doesn't want to divulge. They may very well have done something secretly.
Search here for posts by a certain Known Plaintiff or something Plaintiff.
ATY???
I thought about that - saw the posts some time ago - and also wondered if they perhaps did something and "forgot" to tell me. They certainly poked at the radio cuz all my presets / settings were different.

SA was a squirrely but friendly man - they teach them that squirrely stuff, don't they?
__________________
Reply With Quote
  #6  
Old 03-12-2005, 12:41 PM
JetBlack330i JetBlack330i is offline
Banned
Location: Austin, TX
 
Join Date: Feb 2002
Posts: 5,341
Mein Auto: 2001 330i Sport
There you have it. They replaced your radio unit.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does your dealer offer BMW loaners and car washes? Chipster General BMW 59 01-09-2007 03:06 PM
Willing to do a Dealer to Dealer trade? m330 Ask-A-Dealer 6 07-13-2003 11:05 PM
Ready to buy ED - need a good dealer mystic Ask-A-Dealer 14 10-31-2002 05:59 AM
Getting good price at dealer? shanesoft Ask-A-Dealer 3 10-28-2002 01:25 AM
Temporary Fix For Nav Volume by Dealer rwebbe 3 Series / 4 Series 1 06-29-2002 09:34 AM


All times are GMT -7. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms