Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-26-2005, 01:48 PM
jamie bayley jamie bayley is offline
Registered User
Location: scotland
 
Join Date: Mar 2005
Posts: 1
Mein Auto: BMW 318i E30
Smile M40 BMW 318i problem

Hello,
I have this problem any help welcome.
When driving ,occasionally the engine will not accelerate, (it runs perfectly at idle only). Switching the ignition switch off and then on immediately fixes the problem. The engine is also slow to start,hot or cold
I have replaced the Fuel pump relays,
the distributor cap,the rotor arm and thought I had the problem beat ,but its back!
Also the fault is immediately cured by simply pulling and resetting the fuel pump fuse.
The fuel pump was replaced 6 months ago.
Could it be the pressure regulator or filter?
thanks :
Reply With Quote
Ads by Google
  #2  
Old 04-08-2005, 06:23 PM
SWISS's Avatar
SWISS SWISS is offline
On Top
Location: Certified Okie
 
Join Date: Apr 2005
Posts: 8,803
Send a message via AIM to SWISS Send a message via Yahoo to SWISS
Mein Auto: E30 S52 / S52 M roady
Talking

Quote:
Originally Posted by jamie bayley
Hello,
I have this problem any help welcome.
When driving ,occasionally the engine will not accelerate, (it runs perfectly at idle only). Switching the ignition switch off and then on immediately fixes the problem. The engine is also slow to start,hot or cold
I have replaced the Fuel pump relays,
the distributor cap,the rotor arm and thought I had the problem beat ,but its back!
Also the fault is immediately cured by simply pulling and resetting the fuel pump fuse.
The fuel pump was replaced 6 months ago.
Could it be the pressure regulator or filter?
thanks :
try your t.p.s sounds like it(throttle position sensor or mass air flow sens.)then agian
its missing two cylinders! try a 325i im sure that will fix your accelleration prob
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Top BMW dealers in the country Mathew General BMW 37 07-06-2009 06:58 PM
1998 M3 = 540i = 740i = 20K rumratt General BMW 36 01-12-2007 06:26 PM
Go w/Lemon Law or continue to wait? pylt Dealer Feedback / Vehicle Problems 5 11-17-2004 07:54 AM
Bangle gone jeff330i General BMW 15 02-13-2004 08:48 PM
BMW Model Year 2004 Changes (BMW NA) WAM General BMW 1 08-06-2003 11:13 AM


All times are GMT -7. The time now is 02:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms