Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-11-2005, 08:15 PM
jamilks jamilks is offline
Registered User
Location: Laupahoehoe, Big Island, Hawaii
 
Join Date: Apr 2005
Posts: 2
Mein Auto: '89 325iS
89 325iS radio noises

My factory radio started making a strange rhythmic "pop,pop" noise after the car sat for a year while I got it together to do an engine transplant out of another 325iS I got for parts. If I sturn on the radio and leave it just "on" without any volume, no noise, and then later try it, the noise may or may not be gone.sometimes it is an ascending squeal then other times I;m lucky and there'e no noise for the whole time the car is running but this is becoming more and rare. I changed the amp with the one off the scrap car, no difference, got another radio off ebay, no difference....Any ideas out there? It is the cool model radio with the infrared adjuster slot under the screen, I realize I could get a Pioneer or Kenwood on sale locally for under $200 and be basically satisfied with the sound performance, but it wouldn't have the same orange lights as the other dash instruments etc..Anyone else experience this? Thanks!
Reply With Quote
Advertisement
  #2  
Old 04-15-2005, 07:57 PM
BimmerBoy73 BimmerBoy73 is offline
Registered User
Location: Sacramento
 
Join Date: Apr 2005
Posts: 10
Mein Auto: '89 325is
Quote:
Originally Posted by jamilks
My factory radio started making a strange rhythmic "pop,pop" noise after the car sat for a year while I got it together to do an engine transplant out of another 325iS I got for parts. If I sturn on the radio and leave it just "on" without any volume, no noise, and then later try it, the noise may or may not be gone.sometimes it is an ascending squeal then other times I;m lucky and there'e no noise for the whole time the car is running but this is becoming more and rare. I changed the amp with the one off the scrap car, no difference, got another radio off ebay, no difference....Any ideas out there? It is the cool model radio with the infrared adjuster slot under the screen, I realize I could get a Pioneer or Kenwood on sale locally for under $200 and be basically satisfied with the sound performance, but it wouldn't have the same orange lights as the other dash instruments etc..Anyone else experience this? Thanks!
Clean and re-surface ground strap on alt. Also pull head unit out keep it wired but seperate from any chassis ground and start car. If that that doesnt work pull ant. out from back of head unit. By the way Nakamichi has a head unit low-pro and red like bmw e30 dash lighting.
Reply With Quote
  #3  
Old 04-29-2005, 12:27 AM
jamilks jamilks is offline
Registered User
Location: Laupahoehoe, Big Island, Hawaii
 
Join Date: Apr 2005
Posts: 2
Mein Auto: '89 325iS
heartbeat?

Thanks for the reply! From the lack of responses, I have to assume not many others have heard this noise (these noises...as it does vary sometimes...)
One thing I lacked to mention was the fact that it also makes these sounds with the engine OFF??? I did try the things you mentioned but no change. Reading the Chilton's manual's wiring diagram of the radio/amp circuit, they mention "unloaders". What do they do?
Maybe I just bite teh bullet and get a Nakamichi like you say....Anyway, thanks for the comeback! Aloha!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tons of 89' 325is parts!! trbo2go Classifieds 2 12-24-2004 04:53 PM
1999 E46 (328i sedan) and the radio will not work...keeps blowing fuses. abalto Car Navigation, Audio & Electronics 3 08-16-2004 05:54 AM
1999 E46 (328i sedan) and the radio will not work...keeps blowing fuses. abalto 3 Series / 4 Series 0 07-21-2004 08:31 PM
Check out this sweet 89 E30 325is Sean General BMW 5 12-23-2002 10:43 PM
XM and Sirius Satellite Radio??? Upcoming gadgets for your ride BayDetailz General BMW 0 01-24-2002 10:48 AM


All times are GMT -7. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms