Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (https://www.bimmerfest.com/forums/index.php)
-   E60 / E61 (2004 - 2010) (https://www.bimmerfest.com/forums/forumdisplay.php?f=104)
-   -   2008 528i Project (https://www.bimmerfest.com/forums/showthread.php?t=1342299)

bagman52 08-12-2019 07:52 PM

2008 528i Project
 
5 Attachment(s)
Just purchased this car with 206K miles. Paint, body and interior are very nice. Suspension is a little floaty but rides better than decent. Engine leaking oil from valve covers, oii housing and maybe oil pan. Engine did have what think it the N52 valve noise when I started after it had been sitting for month but have not heard it since. The big issue with the car is the transmission is acting up. If you baby it and make the shifts happen between 2 and 3k rpm it seems to do well but if you leave in drive and just drive normally it will kick into limp mode and throw transmission malfunction message. I really like this car and the condition of the body and interior makes me willing to invest to make it drivable for another 100K. I am attaching the report from Carly app but no faults for transmission. The battery is a 3 year old Orielly EXT49 and it did test as good at Oreillys.

Is it possible the N52 could go another 100K making investing in the transmission worth while?

Thinking I need to decide direction on transmission before tacking leaks on the motor.

Thanks in advance for any and all feedback.

tttomttt 08-13-2019 03:44 AM

View the recent post by HighMileClub. Addressed this very issue especially if you are handy. Search is always your friend before you post.

bagman52 08-13-2019 04:44 AM

Thanks for the feedback tttomtt. Any thoughts on the codes in the attached report?

bagman52 08-14-2019 03:30 AM

Anyone have any feedback on items in the diag report? Again, appreciate the feedback.

Fault Code: 006E83
Fault Explanation: :PT-CAN: Signal ST IND FLTR message in STAT RDC (ID 0x31C) invalid (transmitter RDC) Please feel free to FC hide (Bosch software error) / PT-CAN: Signal ST IND FLTR message in STAT RDC; ID invalid 0x31C; RDC transmitter --- (DSC: Tire Pressure Control: interface)

Fault Code: 009CBF
Fault Explanation: :Caution: electronics at the right headlight (SMC)
reports errors / Battery deep discharge Fault Code: 009CC5
Fault Explanation: :RLS: NoResponse

Fault Code: 00A536
Fault Explanation: :Error SatAntenna Open Circuit. Fault Code: 00A530
Fault Explanation: :Error Power Supply Fault.

Fault Code: 00DE50
Fault Explanation: :Ring break diagnosis was performed (Error ring
diagnosis)
Fault Code: 00A9AC
Fault Explanation: :Overvoltage on the control unit measured (Error Battey Voltage Fault).

tttomttt 08-14-2019 04:59 AM

I would start with a check of the battery as it could be underperforming when under a load and this leads to some modules acting up. It would be a good place to start.

bagman52 08-14-2019 12:57 PM

Voltage at the terminals with radio, lights and A/C on max was 13.78 to 13.86. Can I rule out battery?

scottalexander 08-14-2019 07:51 PM

The vehicle has 200,000 miles on it now think about how often the transmission gear oil has been changed. Maybe once? Maybe never?

There is an old mechanics adage. Do the obvious first, do the easiest second, do the least expensive third.

Change the gear oil and see how black it is.

Drive it for a short time.

Change it again.

If the transmission is acting better, your on the right track.

If the transmission shifting didn't get better, at 200,000 miles:

- Pull out the mechatronic and replace the bridge seal and sleeve seals (easy and inexpensive). You might as well do it, because there's a good probability at 200k it needs it anyway.

If the transmission is acting better, your on the right track.

plus1111 08-15-2019 07:48 PM

I agree with scottalexander. A slightly weak battery will make an e60 do all sorts of weird things. I also agree about changing transmission fluid. Get a manual and be sure you have the right tools and test gear. Fluid change is all done under the car. The draining is obvious, big drain plug in the bottom of the pan. Filling is dune thru a smaller plug up on the side of the case. Be sure you can open the fill plug before draining, sometimes they don't want to open. Our cars are xdrive so I remove the front drive shaft to access the fill port. Yours will be easier. Use the right fluid. It will be dark when it comes out, new fluid is almost clear. DOn't worry unless it is black or stinks like it's burnt. You have to pump fluid in. Expect 6 Liters.
Get a good manual, it helps. I bought the Bentley and it has paid for itself. You will also find a ton of YouTube demonstrations.
I did the valve body on one of ours. I replaced the square rubber seal, the mechatronic electrical connector seal and also the little tubular ones between the valve body and the case. I also replaced the solenoids since I was in there. The car drives like new now.
Thectsc.com is a great source for parts and fluid, by the way. I have also found fluid on amazon from Ravenol that meets the spec.
These transmissions are built tough, a lot tougher than most, but they do get weird if not maintained.


All times are GMT -7. The time now is 11:49 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.