Bimmerfest - BMW Forums - Search Results



Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 9 of 9
Search took 0.00 seconds.
Search: Posts Made By: ArgentoCarNut
Forum: X5 E70 (2007 - 2013) 07-29-2019, 06:38 AM
Replies: 13
Views: 787
Posted By ArgentoCarNut
No CEL at all. The Indy was skeptical at first...

No CEL at all. The Indy was skeptical at first when I dropped it off, then he told me that there were codes stored in the ECU memory, but not enough to trigger a check engine light.


Sent from...
Forum: X5 E70 (2007 - 2013) 07-29-2019, 05:35 AM
Replies: 13
Views: 787
Posted By ArgentoCarNut
Wrapping this up. The cost to replace was $280...

Wrapping this up. The cost to replace was $280 and got it done in one day. Again running like a champ.

Only way I’d be happier would be if this hadn’t happened at all.

Cheers!


Sent...
Forum: X5 E70 (2007 - 2013) 07-22-2019, 05:15 PM
Replies: 13
Views: 787
Posted By ArgentoCarNut
Forgot to ask: anyone here has DIY this? ...

Forgot to ask: anyone here has DIY this? Difficulty level?


Sent from my iPhone using Tapatalk
Forum: X5 E70 (2007 - 2013) 07-22-2019, 03:41 PM
Replies: 13
Views: 787
Posted By ArgentoCarNut
I dropped it off this morning and just got a call...

I dropped it off this morning and just got a call from the mechanic. He said it will need a new high-pressure fuel pump.

Does anyone here know how much I should pay labor for this? The part is...
Forum: X5 E70 (2007 - 2013) 07-18-2019, 03:59 PM
Replies: 13
Views: 787
Posted By ArgentoCarNut
Update on this: Many things got in the way, and...

Update on this:
Many things got in the way, and my wife kept driving to the car until last week without any issues.

Family flew out on vacation on Monday, and I drove the car that day. I could...
Forum: X5 E70 (2007 - 2013) 06-24-2019, 05:08 PM
Replies: 13
Views: 787
Posted By ArgentoCarNut
Wierd “bog down” under hard acceleration

Fingers crossed. Will work me in on wednesday.


Sent from my iPhone using Tapatalk
Forum: X5 E70 (2007 - 2013) 06-24-2019, 05:08 PM
Replies: 13
Views: 787
Posted By ArgentoCarNut
Very likely diagnostic - I drove it a few minutes...

Very likely diagnostic - I drove it a few minutes ago and more stuttering...

Thanks for the input.


Sent from my iPhone using Tapatalk
Forum: X5 E70 (2007 - 2013) 06-24-2019, 08:50 AM
Replies: 13
Views: 787
Posted By ArgentoCarNut
Update: This morning my wife felt a stutter when...

Update: This morning my wife felt a stutter when coming out of the garage and going uphill. Then again after stopping at the entrance of out subdivision. Got normal after that... still no CEL.
...
Forum: X5 E70 (2007 - 2013) 06-22-2019, 04:44 PM
Replies: 13
Views: 787
Posted By ArgentoCarNut
Wierd “bog down” under hard acceleration

Hi folks,

Today I experienced a weird symptom that I had not felt before, and did not repeat itself, but I feel may be connected to another event.

E70 35i 120k miles 2011

Background: In...
Showing results 1 to 9 of 9

Forum Jump

All times are GMT -7. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.