Bimmerfest - BMW Forums - Search Results



Go Back   Bimmerfest - BMW Forums > Search Forums

Showing results 1 to 3 of 3
Search took 0.01 seconds.
Search: Posts Made By: harveytchao
Forum: X5 E70 (2007 - 2013) 09-04-2019, 07:07 AM
Replies: 21
Views: 809
Posted By harveytchao
Issues with push button start

FWIW:

It just MIGHT- I say again MIGHT be signs of a failing starter. Don't recall seeing what engine this is, but my wife's '07 X5 3.0si started to act as if the battery was weak/starting to...
Forum: X3 E83 (2004 - 2010) 03-27-2019, 05:05 AM
Replies: 46
Views: 2,158
Posted By harveytchao
RE: Lost Parts Source Recently needed a...

RE: Lost Parts Source

Recently needed a iDrive replacement switch assembly and looked around the usual above mentioned sources and found a " new to me" source on-line called "eEuroparts apparently...
Forum: E39 (1997 - 2003) 04-29-2014, 06:15 PM
Replies: 14
Views: 24,852
Posted By harveytchao
Update to old thread

FWIW - - -Update to info from QSilver7: My '00 E39 has a build date of 11/99 and has BOTH the round under hood port and the under dash trapazoid port behind a small "flap" door under the dash...
Showing results 1 to 3 of 3

Forum Jump

All times are GMT -7. The time now is 07:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.