Bimmerfest - BMW Forums - View Single Post - Issues with push button start
View Single Post
  #14  
Old 08-28-2019, 07:04 PM
FredoinSF FredoinSF is offline
Officially Welcomed to the 'Fest
Location: Reno NV & Healdsburg CA
 
Join Date: Nov 2009
Posts: 6,654
Mein Auto: 4 BMWs, 1 Mini, 1 Vespa
Quote:
Originally Posted by Milt Mademan View Post
Well the car started fine this morning and I took it to Autozone to get the battery tested. The battery is good and I then drove to work and turned the car off and on all day with no issue. After driving 25-30 miles home for the day, upon arriving in my driveway, I turned the car off and tried to turn it back on and it acted like it wanted to start but didn't. After letting it sit for 30 minutes, the car fired right up.....I have no idea what the issue is!!
You never answered the question asking how old the battery was in post 3 - unless I missed it. At this point, going to assume it is the original battery or replacement greater than five years in which case DUDE!!! BUY A NEW BATTERY!!!!!!!!!!!!!!

These cars are known to exhibit funky behavior when the battery is in the process of failing yet you're going to trust the flunkies at AutoZone and their BS battery test to diagnose your formerly $70k plus German engineered pride and joy?
Don't be a cheap a$$ and try to save twenty bucks, make sure it's the right battery for the car. Some 'new' batteries may have been sitting for months, charge it up or drive the car 100 miles to make sure it gets charged.

Could be something else going on but until battery state is known, this thread is a waste of time for all involved.
__________________



Reply With Quote