Bimmerfest - BMW Forums - View Single Post - 2014 528i Bad Engine Vibration when Cold - Engine Mounts?
View Single Post
  #15  
Old 05-16-2019, 09:49 AM
bmrboy2008's Avatar
bmrboy2008 bmrboy2008 is offline
Officially Welcomed to the 'Fest
Location: Glendora, California
 
Join Date: May 2008
Posts: 1,906
Mein Auto: 2014 535i M Sport
Sorry to resurrect this old thread. However, I have an intermittent mild vibration in the front end of my car and a strange grinding sound emanating from my right front wheel. My indy says that both could be caused by bad engine mounts, and he wants to start there. He quoted me approximately $800 for the two mounts which seems reasonable to me based on what I have read. He also agreed to replace my rear differential bushing for $700 for a total of approximately $1,500 for both jobs. My fear is that after the mounts are replaced the grinding sound will still be there. I have two questions on which I hope some of you can advise.

1. Is replacing the engine mounts a relatively straight forward process, although it does take at least 4-5 hours of labor, or is it something more complex that a specially trained BMW technician needs to perform.
2. Any ideas on what the grinding sound might relate to? It can only be heard after the car reaches operating temperature, always when idling at a stop, then after driving to about 35-40 mph when it stops. Very annoying.

Any thoughts or recommendations would be appreciated.
__________________
2014 535i M-Sport, Jet Black, Black Dakota Leather, Premium Package, Lighting Package, Multi-Contour Seats, M-Sport Suspension, Navigation, Harmon Kardon Stereo, 3M Tint

Last edited by bmrboy2008; 05-16-2019 at 01:14 PM.
Reply With Quote