Help , please , no AC - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-08-2019, 05:24 PM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
Help , please , no AC

I took my 2007 Z4 coupe out of hibernation today and found the AC is not working . Fan is running but no LED showing when pressing the snow flake button or window button . I checked AC fuses 22 and 29 in the cab and found them to be good . I found the under the hood fuse panel but find no labels for the fuses . Cannot get the under hood fuse box cover all the way off with out some more violence . Poorly located . Any ideas what the next step should be ?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-08-2019, 10:49 PM
Rob2m Rob2m is offline
Registered User
Location: uk
 
Join Date: Dec 2017
Posts: 35
Mein Auto: Z4
Move to the UK, you will only miss it 2 days a year then!

Sorry cant help.
__________________
"Today’s ride will remind me forever how good it is to be a motorcyclist, how good it is to be alive and how much we need to live life, rather than watch it pass us by." Green VFR.

Last edited by Rob2m; 04-09-2019 at 11:02 PM.
Reply With Quote
  #3  
Old 04-08-2019, 11:57 PM
papitosabe's Avatar
papitosabe papitosabe is offline
WalkTheWalk
Location: Houston
 
Join Date: Apr 2007
Posts: 328
Mein Auto: 06 Z4 Coupe
Was the battery dead or did you remove the battery? It may be in what's called "transport mode." You can get it out of that mode at dealership for like which will probably charge you $100 plus for 5 mins of work. Or get the software on ebay I believe but iirc you need a windows 7 or vista pc.. I think it's called DIS something. Or check craigslist for a bmw tech that will program it. A guy quoted me $45 just the other day...might be able to talk down for $25.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 04-09-2019, 02:33 AM
Doug Huffman's Avatar
Doug Huffman Doug Huffman is online now
Nuclear engineer
Location: Washington Island, Wisconsin, thru Death's Door
 
Join Date: Apr 2015
Posts: 11,612
Mein Auto: CPO2012 X5 35d M57(E70)
Here's an IHKA schematic wiring diagram, but the HVAC system is so far from voltage supply that fuses aren't even part of the system shown. At the top of the page are link URL to higher menus.

https://www.newtis.info/tisv2/a/en/e...ontrol/ltqwXom
__________________
Scepticism and Animal Faith (1923)
Scepticism is the chastity of the intellect, and it is shameful to surrender it too soon or to the first comer: there is nobility in preserving it coolly and proudly through long youth, until at last, in the ripeness of instinct and discretion, it can be safely exchanged for fidelity and happiness.
(The Works of George Santayana p. 65)

Eschew eristical argumentation. I am responsible for what I write, not for your understanding of it.
Reply With Quote
  #5  
Old 04-09-2019, 05:20 AM
wifesauto wifesauto is offline
Officially Welcomed to the 'Fest
Location: nj
 
Join Date: Jan 2012
Posts: 555
Mein Auto: sloporsche
some systems will not let the compressor run if it is low on refrigerant
Reply With Quote
  #6  
Old 04-09-2019, 06:05 AM
Doug Huffman's Avatar
Doug Huffman Doug Huffman is online now
Nuclear engineer
Location: Washington Island, Wisconsin, thru Death's Door
 
Join Date: Apr 2015
Posts: 11,612
Mein Auto: CPO2012 X5 35d M57(E70)
Quote:
Originally Posted by wifesauto View Post
some systems will not let the compressor run if it is low on refrigerant
Pressure Sensor via Junction Box
The refrigerant pressure input signal is a direct junction box input signal and is relayed to the IHKA via the K-CAN. The IHKA requests actuation of the auxiliary blower by the DME (ECM) depending on the refrigerant pressure.
The IHKA determines the relevant A/C compressor load torque on the basis of the input signals from the pressure sensor and the compressor speed. The DME (ECM) control units are notified of the load torques by the IHKA and used by the DME (ECM) as input variables for actuating the electric fan. [Notice: Blower =!= fan]


A/C Compressor Control
The IHKA is the master for controlling the A/C compressor. Pressing the AC button on the air conditioning system operating unit switches the air conditioning system to the ready state.The IHKA transmits a speed increase request to the DME (ECM).
Depending on the temperature and the nominal-value setting, the IHKA sends a cooling power request to the DME (ECM) If the DME (ECM) is ready and in a position to provide a torque of > 20 Nm, the DME (ECM) issues a release for a load connection of up to 30 Nm. This release is also monitored by the junction box. The IHKA issues a command to the junction box to couple the connection. The junction box returns the coupling status to the DME (ECM)
The compressor output is controlled by the IHKA control unit by means of an infinitely variable control valve. The IHKA control command is converted into infinitely variable proportional powering of the control valve in the junction box.
The control is designed as "sliding evaporator control".
The evaporator temperature is controlled to a value of between 2°C and 8°C depending on the cooling power request. The temperature sensor signal in the evaporator is used as a feedback signal to the IHKA control unit. The coolant request is limited by the potential evaporating power of the evaporator.
The evaporator is prevented from icing up by controlling the compressor output (appropriate reduction).
In order to reduce CO2 emission, avoid unstable conditions when the engine is idling and for full load acceleration the DME can activate a compressor shut-off via the junction box. If appropriate parameters are present, the solenoid coupling of the compressor is opened.
__________________
Scepticism and Animal Faith (1923)
Scepticism is the chastity of the intellect, and it is shameful to surrender it too soon or to the first comer: there is nobility in preserving it coolly and proudly through long youth, until at last, in the ripeness of instinct and discretion, it can be safely exchanged for fidelity and happiness.
(The Works of George Santayana p. 65)

Eschew eristical argumentation. I am responsible for what I write, not for your understanding of it.

Last edited by Doug Huffman; 04-09-2019 at 06:07 AM.
Reply With Quote
  #7  
Old 04-09-2019, 06:13 AM
wifesauto wifesauto is offline
Officially Welcomed to the 'Fest
Location: nj
 
Join Date: Jan 2012
Posts: 555
Mein Auto: sloporsche
mechanics short version......check fuses/put gauges on system ............mechanics were needed cuz engineers couldn't get it right the first time
Reply With Quote
  #8  
Old 04-09-2019, 06:35 AM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
Thank you ,

Thanks for the responses . I am overwhelmed with life's complications right now , but when I can get back to it , I will check the under hood fuses more thoroughly . Car did have a Battery Tender in place all winter . If it is more complicated than fuses , it is off too the heartless dealer with my SS check in hand .
Reply With Quote
  #9  
Old 04-09-2019, 06:44 AM
wifesauto wifesauto is offline
Officially Welcomed to the 'Fest
Location: nj
 
Join Date: Jan 2012
Posts: 555
Mein Auto: sloporsche
a local shop should be able to re-charge if that is the issue and look for leaks
Reply With Quote
  #10  
Old 04-09-2019, 06:55 AM
ShakyDog's Avatar
ShakyDog ShakyDog is offline
Officially Welcomed to the 'Fest
Location: Missouri
 
Join Date: Sep 2011
Posts: 176
Mein Auto: Z4 3.0i
Does everything else work? Does the rear defroster? If not then I would bet your car went into Transport Mode.

Steve
Reply With Quote
  #11  
Old 04-09-2019, 07:39 AM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
The rear defroster is not working . Transport Mode must have been triggered . Leave it to BMW to over complicate everything . Thanks ,
Reply With Quote
  #12  
Old 04-09-2019, 08:16 AM
Doug Huffman's Avatar
Doug Huffman Doug Huffman is online now
Nuclear engineer
Location: Washington Island, Wisconsin, thru Death's Door
 
Join Date: Apr 2015
Posts: 11,612
Mein Auto: CPO2012 X5 35d M57(E70)
Heated rear window may be supplied by 30 Amp fuse F20 in power distribution box A41 behind passenger's dashboard. It may be controlled by relay K13 in A41, in turn powered by 5 Amp fuse F25 in A41 and controlled by IHKA A11a.

https://www.newtis.info/tisv2/a/en/e...window/pQoLcTp
__________________
Scepticism and Animal Faith (1923)
Scepticism is the chastity of the intellect, and it is shameful to surrender it too soon or to the first comer: there is nobility in preserving it coolly and proudly through long youth, until at last, in the ripeness of instinct and discretion, it can be safely exchanged for fidelity and happiness.
(The Works of George Santayana p. 65)

Eschew eristical argumentation. I am responsible for what I write, not for your understanding of it.
Reply With Quote
  #13  
Old 04-10-2019, 10:20 AM
janole janole is offline
Registered User
Location: sonoma ca
 
Join Date: Mar 2018
Posts: 31
Mein Auto: 2007 z4 3.0si
Transportation mode for sure this has happened to me before and the exact same things didn't work, unplug battery, wait at least 30 mins with the trunk lid open, re-connect and it should be good to go. When ever you do anything to the battery, tender, charge it, change it, always wait 20 mins after you open any door or trunk lid so the system can go into sleep mode before you plug or un-plug anything into the electrical system
Reply With Quote
  #14  
Old 04-10-2019, 12:30 PM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
I will give it a try . Thanks ,
Reply With Quote
  #15  
Old 04-16-2019, 04:22 PM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
I tried the thirty minutes with the battery disconnected and still no AC .
Reply With Quote
  #16  
Old 04-17-2019, 08:42 AM
ShakyDog's Avatar
ShakyDog ShakyDog is offline
Officially Welcomed to the 'Fest
Location: Missouri
 
Join Date: Sep 2011
Posts: 176
Mein Auto: Z4 3.0i
It is a setting that must be changed with a programmer (or taken to the dealer to reset). I have never heard of the battery disconnect removing it, I do know that is what causes the issue.

Steve
Reply With Quote
  #17  
Old 04-17-2019, 09:13 AM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
Thank You ShakyDog , The BMW seems to be designed around supporting dealerships , not customer support . Full of unneeded , unwanted quirky electronics .
Reply With Quote
  #18  
Old 04-17-2019, 09:56 AM
papitosabe's Avatar
papitosabe papitosabe is offline
WalkTheWalk
Location: Houston
 
Join Date: Apr 2007
Posts: 328
Mein Auto: 06 Z4 Coupe
Great write up if you can get someone off CL with the sw.. doubt they would need instruction, but mention you know it takes a couple of minutes.. https://www.bimmerforums.com/forum/s...)-novice-level
Reply With Quote
  #19  
Old 04-17-2019, 02:55 PM
janole janole is offline
Registered User
Location: sonoma ca
 
Join Date: Mar 2018
Posts: 31
Mein Auto: 2007 z4 3.0si
To offer more details in my case, because it did actually work, but I have no idea why.

The battery had run low to a point where it would not turn over the car, radio and lights still worked, just the clicking sound of starter, so I put a trickle charger on it for about 6 hours, and it started right up, went out for a 30 min drive and noticed I had no AC, no radio, maybe other things, I didn't check. Parked the car and started to worry. Next morning went out to try it again, car was absolutely dead, no nothing, no dash lights, nothing, but I get out of the car and there is a sound like something is running in the back (fuel pump?). Weird So I pulled the battery out of the car and put it on a real 20a charger overnight, re-installed it. Started up, and everything works, Alternator is charging at 13.7-13.9 and I have not had an issue since, that was month and half ago.
Reply With Quote
  #20  
Old 04-17-2019, 04:51 PM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
I had a Battery Tender on the stored vehicle all winter and the battery turned the engine over easily . I do not know what triggered the "shipping mode". Car was stored under the same conditions the winter before with no problems .
Reply With Quote
  #21  
Old 04-19-2019, 11:05 PM
Andyz4 Andyz4 is offline
Officially Welcomed to the 'Fest
Location: Orlando, FL
 
Join Date: Mar 2018
Posts: 172
Mein Auto: 2006 Z4 3.0si
Milton, does your HVAC blower operate at a very slow speed (only)? If so, you are likely in transport mode. Along with no ac you will also have no radiator fan when you switch on the ac. If you dont have software dealership can clear it for the cost of diagnostic. If blower is working at all speeds, you are likely just low on freon.
__________________
[SIGPIC]
Reply With Quote
  #22  
Old 04-20-2019, 09:22 PM
milton6x milton6x is offline
Registered User
Location: Franklin , Wisconsin
 
Join Date: Jun 2017
Posts: 39
Mein Auto: 2007 Z4si coupe
solved

All the symptoms match . I will be bringing it to a dealer when time allows . Thank You ,
Reply With Quote
  #23  
Old 05-07-2019, 10:12 AM
lmacmil lmacmil is offline
Officially Welcomed to the 'Fest
Location: South Bend, IN
 
Join Date: Apr 2015
Posts: 128
Mein Auto: 2006 BMW Z4 3.0si
Quote:
Originally Posted by wifesauto View Post
a local shop should be able to re-charge if that is the issue and look for leaks
There are at least 2 videos on YouTube showing a DIY recharge for the Z4. Looks pretty straightforward. Going to try it myself when it's consistently above 70. My AC quit last summer but never bothered to recharge it since the car spends 90% of its time with the top down.
__________________
2006 3.0 Si
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My AC is stuttering and not consistent. ACproblemshalp 7 Series - F01 / F02 (2009 - 2015) 4 09-01-2018 06:31 PM
E90 AC not working after water pump replacement sle39lvr E90/E91/E92/E93 (2006 - 2013) 18 08-28-2018 04:40 PM
Climate control, AC & the mysterious center vent wheel thing? Moderato 3 Series & 4 Series 61 04-09-2004 09:31 AM


All times are GMT -7. The time now is 11:59 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.