Yet another top issue - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-03-2019, 11:37 AM
p598738 p598738 is offline
Registered User
Location: Maine Florida
 
Join Date: Sep 2012
Posts: 98
Mein Auto: Z4 2,5 and 3.0
Yet another top issue

Top suddenly not working. New motor and hinges recently installed. Drains are clean.

One possibility is the 'micro switch' used by the trunk shelf. I understand that the micro stops the motor from working if the shelf is up. I am looking at it and not sure what position it is in.

Please see the picture and tell me what the situation is (if you know). What position should the switch be such that the motor top will work ???

Thanks
Attached Thumbnails
Click image for larger version

Name:	Micro switch.jpg
Views:	49
Size:	142.3 KB
ID:	850373  
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-03-2019, 08:51 PM
Andyz4 Andyz4 is offline
Officially Welcomed to the 'Fest
Location: Orlando, FL
 
Join Date: Mar 2018
Posts: 172
Mein Auto: 2006 Z4 3.0si
Since the trunk shelf was removed and reinstalled when you replaced the top motor, the microswitch may have been disturbed. They are pretty fragile. You can repair, replace or even bypasss the switch if necessary. This may help: https://www.bmwrepairguide.com/bmw-e...switch-repair/
__________________
[SIGPIC]
Reply With Quote
  #3  
Old 05-04-2019, 11:59 AM
Clearancediver's Avatar
Clearancediver Clearancediver is offline
Officially Welcomed to the 'Fest
Location: Victoria BC, Canada
 
Join Date: Oct 2012
Posts: 609
Mein Auto: 2004 Z4, 2009 Nomad mc
Your microswitch lever is missing.... it probably fell off.

Replacing the microswitch is a easy DIY.


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 05-04-2019, 12:54 PM
p598738 p598738 is offline
Registered User
Location: Maine Florida
 
Join Date: Sep 2012
Posts: 98
Mein Auto: Z4 2,5 and 3.0
Now I'm not so sure it could be the microswitch. The down button blinks or is solid red.
Reply With Quote
  #5  
Old 05-04-2019, 01:29 PM
Clearancediver's Avatar
Clearancediver Clearancediver is offline
Officially Welcomed to the 'Fest
Location: Victoria BC, Canada
 
Join Date: Oct 2012
Posts: 609
Mein Auto: 2004 Z4, 2009 Nomad mc
The lever is missing in the picture.... hence an error condition is set. The car thinks the storage tray is in the “up” position.


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #6  
Old 05-06-2019, 09:35 AM
Andyz4 Andyz4 is offline
Officially Welcomed to the 'Fest
Location: Orlando, FL
 
Join Date: Mar 2018
Posts: 172
Mein Auto: 2006 Z4 3.0si
Quote:
Originally Posted by p598738 View Post
Now I'm not so sure it could be the microswitch. The down button blinks or is solid red.
Hmm, yes I think it blinks yellow when the tray is up. Red could be another issue.
__________________
[SIGPIC]
Reply With Quote
  #7  
Old 05-09-2019, 03:35 AM
p598738 p598738 is offline
Registered User
Location: Maine Florida
 
Join Date: Sep 2012
Posts: 98
Mein Auto: Z4 2,5 and 3.0
Replacing the switch today. Fingers crossed.
Reply With Quote
  #8  
Old 05-09-2019, 04:44 PM
p598738 p598738 is offline
Registered User
Location: Maine Florida
 
Join Date: Sep 2012
Posts: 98
Mein Auto: Z4 2,5 and 3.0
No luck. It was not the micro switch. Diagnostics suggest the top motor is shot.

The latest one was installed in December 2017. The car was garaged from May 2018 until October 2018. It's been on the road less than 12 months in total since the new one (#3) was installed.

The newest motor may have been defective. Stay tuned.
Reply With Quote
Reply

See More Related BMW Stories

Tags
top micro switch


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New User - iDrive/Spotify/iPhone Issue JGButler F30 / F31 / F32 / F33 / F34 / F36 (2012 - current) 7 11-15-2016 02:47 PM
BMW 328d torque jumping at idle, causing car to shake violently mattp1 F30 / F31 / F32 / F33 / F34 / F36 (2012 - current) 10 05-20-2016 04:49 PM
How I solved 2A82-2A87 issue Endive E63 / E64 6 Series (2004 - 2010) 0 05-13-2016 12:27 PM
Gas Mileage Issue on 2008 328i Sedan piyu7444 E90/E91/E92/E93 (2006 - 2013) 11 10-08-2012 08:29 AM


All times are GMT -7. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.