Level Control System Malfunction - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-15-2018, 08:51 PM
tjosue tjosue is offline
Registered User
 
Join Date: Nov 2018
Posts: 1
Mein Auto:
Level Control System Malfunction

Hello all, I'm new to the forum, but have really appreciated all of the good advice I've gleaned over the years from the users here.

Here is my situation. For a while I had leaking air struts. Each time I started the X5, it would pump them up, and I thought this was normal. One day my son and I were running errands and I hit a huge pot hole and the left air strut burst. I did a little research on these forums and was able to easily replace both old air struts with Arnotts. This worked great, everything was back to normal, no malfunction lights, great ride, good to go.

Then, this happened: I took the X5 to the dealer to troubleshoot a front-end problem (a weird kind of shudder, but that's a different post) and while it was at the dealer, the compressor stopped working and the Level Control System Malfunction indicator came on. Since they wanted $1200 for a new compressor and $600 to install it, I decided to replace the compressor myself, which was a relatively easy job. Again, I got an new Arnott compressor (less than $600), did the installation, and voila, it won't turn on. I checked the associated fuses, and they are good.

So, I read on a thread somewhere that I should disconnect the battery and let the system reset, and now I have two errors:

Level Control System Malfunction!
Chassis Stabilization Malfunction!

The compressor still wont turn on and the X5 sits with two malfunctions. And, to top it off, my wife is seriously annoyed with me and questioning my mechanic skills

What I want to know is after installation of a new compressor, is it normal that it won't turn on? Does the error need to be cleared or something reset in the computer before it will work?

Is there a tool I can purchase that allows me to reset the indicator, or further troubleshoot the problem.

Anyway, if you made it all the way through this novella, thanks for reading and I look forward to your sage advice.

Last edited by tjosue; 11-15-2018 at 08:54 PM. Reason: grammar
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-17-2018, 01:38 PM
mitocross mitocross is offline
Registered User
Location: Europe
 
Join Date: Jul 2016
Posts: 32
Mein Auto: E70 3.0sd
It could be as simple as checking the fuses and clearing the codes before restarting the car again. You'll need some kind of diagnostic tool to do this - Carly for BMW is the simplest I think.
Reply With Quote
Reply

See More Related BMW Stories

Tags
compressor, e70, lcs, x5


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.