Car temperature high warning. - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)

E60 / E61 (2004 - 2010)
BMW 5-Series E60 Sedan was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E61 wagon followed shortly there after. The E60/E61 5 series is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-13-2017, 08:17 AM
djvaran007 djvaran007 is offline
Registered User
Location: malaysia
 
Join Date: Nov 2017
Posts: 14
Mein Auto: bmw e60 525i mspot
Car temperature high warning.

Big hello to all. M using 525i e60 2006. My car temperature geting high. Radiator fan not working. Yesturday i change thermostat the fan working for awail and its turn off after i on ac and off.
But the fan working when temperature high alarm out.
And the sensor holded pipe from thermostat to radiator bottom are not geting hot.

Can any one advice me, what i should to do now?? Where i have to touch.

Thanks..
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2017, 10:37 PM
tim330i's Avatar
tim330i tim330i is offline
Bimmerfest Founder
Location: Boston
 
Join Date: Dec 2001
Posts: 15,712
Mein Auto: Various
Moved to our E60 5 series forum.
Reply With Quote
  #3  
Old 11-13-2017, 10:43 PM
djvaran007 djvaran007 is offline
Registered User
Location: malaysia
 
Join Date: Nov 2017
Posts: 14
Mein Auto: bmw e60 525i mspot
Thanks tim

Sent from my SM-N9005 using Bimmerfest mobile app
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 11-13-2017, 11:02 PM
acoste's Avatar
acoste acoste is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Nov 2011
Posts: 5,330
Mein Auto: 2010 550i MT
Quote:
Originally Posted by djvaran007 View Post
Big hello to all. M using 525i e60 2006. My car temperature geting high. Radiator fan not working. Yesturday i change thermostat the fan working for awail and its turn off after i on ac and off.
But the fan working when temperature high alarm out.
And the sensor holded pipe from thermostat to radiator bottom are not geting hot.

Can any one advice me, what i should to do now?? Where i have to touch.

Thanks..
Seems like your fan works ok.

Either your thermostat doesn't open or the water pump doesn't spin.
__________________
__________________
2010 BMW 550i MT
2003 BMW 325i @216k and counting
1998 BMW 528i MT @ 231k //sold
1997 Saab 9000 //sold
Reply With Quote
  #5  
Old 11-13-2017, 11:05 PM
djvaran007 djvaran007 is offline
Registered User
Location: malaysia
 
Join Date: Nov 2017
Posts: 14
Mein Auto: bmw e60 525i mspot
Quote:
Originally Posted by acoste View Post
Seems like your fan works ok.

Either your thermostat doesn't open or the water pump doesn't spin.
Can u advise me how to check my water pump working or not..

Sent from my SM-N9005 using Bimmerfest mobile app
Reply With Quote
  #6  
Old 11-13-2017, 11:14 PM
djvaran007 djvaran007 is offline
Registered User
Location: malaysia
 
Join Date: Nov 2017
Posts: 14
Mein Auto: bmw e60 525i mspot
Any one plz let me know the location of water pump fius and relay. E60 525i 2006

Sent from my SM-N9005 using Bimmerfest mobile app
Reply With Quote
  #7  
Old 11-13-2017, 11:18 PM
acoste's Avatar
acoste acoste is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Nov 2011
Posts: 5,330
Mein Auto: 2010 550i MT
The electric water pump can throw a lot of different error messages. Get INPA or ISTA D to read the codes.

Here you can find a lot of information, wiring diagrams, functional descriptions, repair manuals.

https://www.newtis.info/tisv2/a/en/
__________________
__________________
2010 BMW 550i MT
2003 BMW 325i @216k and counting
1998 BMW 528i MT @ 231k //sold
1997 Saab 9000 //sold
Reply With Quote
  #8  
Old 11-13-2017, 11:19 PM
djvaran007 djvaran007 is offline
Registered User
Location: malaysia
 
Join Date: Nov 2017
Posts: 14
Mein Auto: bmw e60 525i mspot
Quote:
Originally Posted by acoste View Post
The electric water pump can throw a lot of different error messages. Get INPA or ISTA D to read the codes.

Here you can find a lot of information, wiring diagrams, functional descriptions, repair manuals.

https://www.newtis.info/tisv2/a/en/
Thnks alots friend. I check and update

Sent from my SM-N9005 using Bimmerfest mobile app
Reply With Quote
  #9  
Old 11-14-2017, 05:35 AM
toga94m toga94m is offline
Officially Welcomed to the 'Fest
Location: Upstate NY
 
Join Date: Apr 2012
Posts: 1,134
Mein Auto: 2006 530xiT
Also try the procedure for venting. This is done with engine off, so you should be able to hear the water pump running, and water moving, if it still works.
https://www.newtis.info/tisv2/a/en/e...-check/ElXYxd2
__________________
2006 530xiT 6MT - 150k miles - 3rd owner - sport & cold packages
Reply With Quote
  #10  
Old 11-14-2017, 05:39 AM
djvaran007 djvaran007 is offline
Registered User
Location: malaysia
 
Join Date: Nov 2017
Posts: 14
Mein Auto: bmw e60 525i mspot
Quote:
Originally Posted by toga94m View Post
Also try the procedure for venting. This is done with engine off, so you should be able to hear the water pump running, and water moving, if it still works.
https://www.newtis.info/tisv2/a/en/e...-check/ElXYxd2
Thanks toga

Sent from my SM-N9005 using Bimmerfest mobile app
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.