****** head unit issues, thinking of going back to oem... Help? - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M5 & M6 > E39 M5 (1998-2003)

E39 M5 (1998-2003)

Reply
 
Thread Tools Display Modes
  #1  
Old 05-22-2018, 05:42 PM
lockeed lockeed is offline
Registered User
Location: Quebec
 
Join Date: Mar 2013
Posts: 35
Mein Auto: E90 M3 Sedan
****** head unit issues, thinking of going back to oem... Help?

My E39 M5 came with a freshly installed ******-PF7139BS head unit with Nav and backup cam, along with a Kenwood XR900-5 amp in the trunk.

I'm seriously thinking of pulling everything out the car and going back to the OEM head unit and amp... I have a hissing sound when the volume isn't muted. The sound quality is terrible. The amp doesn't seem to be driving the sub at all... and the backup camera works, but the beeping sometimes doesn't stop, even after I've been driving (forward!) for 30 seconds.

Any advice, feedback...? Is it worth it to try and diagnose the problems, or should I just go back to OEM?

The sound quality and reliability are more important to me than Bluetooth or media stuff anyway.

Thanks



Last edited by lockeed; 05-22-2018 at 05:43 PM.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M5 & M6 > E39 M5 (1998-2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:30 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.