Apple Car Play not working - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 G05 (2018 - Current)

X5 G05 (2018 - Current)
G05 BMW X5 produced between 2018 to Current. Discuss the G05 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-02-2019, 05:40 AM
trouillard trouillard is offline
Registered User
Location: New Jersey
 
Join Date: Nov 2010
Posts: 14
Mein Auto: 2019 BMW X5 40i
Apple Car Play not working

So Apple Car Play in my 2019 X5 40i has worked fine until yesterday. I have the latest IOS 13.2, and the BMW software is current. Yesterday AM it worked, and three hours later, it will not connect to my phone. I even brought it to my friends at BMW of Morristown and the expert there was stumped and "blamed" it on Apple. Told me to come back in a week if it was still not working. I don't blame him, since we looked at it for an hour. I did everything, including disassociating the iphone from the car multiple times, renaming my phone, confirming all bluetooth and wifi settings are correct, etc... He even engaged Hi BMW and asked for it to start Apple Car Play. The response was that the vehicle was equipped with Apple Car Play. I called the 800 number for help and they had no clue either. Has anyone had this issue?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-02-2019, 07:38 PM
TheTurtleBoy TheTurtleBoy is offline
Officially Welcomed to the 'Fest
Location: Colorado
 
Join Date: Jun 2018
Posts: 215
Mein Auto: 2019 X5 40i
You probably did it already but just to make sure, have you rebooted iDrive? If not, then delete the phone from iDrive, turn off your phone, reboot iDrive, turn on your phone and pair it with iDrive using the CarPlay connection.
Reply With Quote
  #3  
Old 11-28-2019, 07:06 AM
OFFTACKLE01 OFFTACKLE01 is offline
Registered User
Location: Glendale, CA
 
Join Date: Oct 2010
Posts: 2
Mein Auto: 2004 745Li
Reboot iDrive?

I have a 2019 X5 xDrive 50i and have had sporatic issues with Apple Car Play. I have performed much if not all of the same steps that 'trouillard' mentioned. How do you reboot the iDrive and what is lost when rebooted? What car and year do you have and have you rebooted your own iDrive; and for what reason?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 11-28-2019, 04:56 PM
TheTurtleBoy TheTurtleBoy is offline
Officially Welcomed to the 'Fest
Location: Colorado
 
Join Date: Jun 2018
Posts: 215
Mein Auto: 2019 X5 40i
Quote:
Originally Posted by OFFTACKLE01 View Post
I have a 2019 X5 xDrive 50i and have had sporatic issues with Apple Car Play. I have performed much if not all of the same steps that 'trouillard' mentioned. How do you reboot the iDrive and what is lost when rebooted? What car and year do you have and have you rebooted your own iDrive; and for what reason?
Press and hold the volume button for about 30 seconds and it will reboot. Nothing is lost when you do a reboot. I have a 2019 X5v and I used to have to do it because of the BC button issue and for various other things like the seat massage or thigh extension not working. Haven't had to do it in months.

My CarPlay has been solid since iOS 13.x and also getting the .55 iDrive update. What version are you running because from all reports CarPlay issues have disappeared. Did you go in and at least get .53 when BMW sent the email about a free update?
Reply With Quote
  #5  
Old 12-10-2019, 12:54 AM
Phantom38 Phantom38 is offline
Registered User
Location: UK
 
Join Date: Nov 2015
Posts: 4
Mein Auto: X5
I had the same problem with the upgrade - just delete the phone and re-add it, effectively start from scratch, and make sure the relevant Apps are up to date. That fixed it for me. There is still an issue that Car Play sometimes doesn't kick in when I start the car, and stopping switching everything off and on again usually fixes it. Otherwise its a great feature that I use all the time.
Reply With Quote
  #6  
Old 01-03-2020, 10:30 AM
trouillard trouillard is offline
Registered User
Location: New Jersey
 
Join Date: Nov 2010
Posts: 14
Mein Auto: 2019 BMW X5 40i
So BMW had to completely reflash the system to get it to finally work. Nothing else fixed the issue. I tried pushing the volume button for 30 secs, etc... nothing. All good now.
Reply With Quote
Reply

See More Related BMW Stories

Tags
apple car play 2019 x5 40i


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 G05 (2018 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.