M5 transmission malfunction warning??? - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M5 & M6 > E60 M5 (2006 - 2010)

E60 M5 (2006 - 2010)

Reply
 
Thread Tools Display Modes
  #1  
Old 01-19-2011, 08:03 PM
CbadM5 CbadM5 is offline
Registered User
Location: Carlsbad
 
Join Date: Jan 2011
Posts: 17
Mein Auto: Black M5
M5 transmission malfunction warning???

So I'm driving my 06 M5 SMG tonight. I was not in power mode and driving a lil aggressive with the shifter. I was in 3rd gear and all of sudden "transmission malfunction" shows up on heads up display and dash. No loss of power. I slowed down and push the stick into auto mode. The warning went away. Car seemed to be fine. I drive the car later that night and it was fine, no tranny light again. Any ideas???? Similar experiences ????
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-20-2011, 08:24 AM
kaptane kaptane is offline
Registered User
Location: Atlanta
 
Join Date: Jan 2011
Posts: 1
Mein Auto: M5
Same Here

I had the exact same experience last night with my `06 M5. Had it in gear in a parking lot, started car, and all these tranny malfunction lights came on as transmission moved to Neutral and began starting sequence. I drove it to the next destination (cautiously). Car ran fine, and never saw the warning indicators again. Odd.
Reply With Quote
  #3  
Old 01-20-2011, 08:38 AM
CbadM5 CbadM5 is offline
Registered User
Location: Carlsbad
 
Join Date: Jan 2011
Posts: 17
Mein Auto: Black M5
Yeah, I drove it again this morning. No warnings and ran fine.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 02-02-2011, 10:47 AM
Gniruot Gniruot is offline
Registered User
Location: Nc
 
Join Date: Feb 2011
Posts: 43
Mein Auto: M5
check the stored code. probably a p1709.... which is a mystery
Reply With Quote
  #5  
Old 05-16-2011, 02:51 PM
rsmith9717 rsmith9717 is offline
Registered User
Location: Frico Texas
 
Join Date: Jan 2011
Posts: 24
Mein Auto: M5 E60
I have had the same amber warning light for Transmission malfunction about 3 times a week for the last 3 months now. Dealer reckons its a hydraclic leak frtom the SMG. How long have you all had the warning light??
Reply With Quote
  #6  
Old 05-23-2011, 11:50 AM
"S62"'s Avatar
"S62" "S62" is offline
Officially Welcomed to the 'Fest
Location: SF Bay Area, California
 
Join Date: May 2011
Posts: 144
Mein Auto: 2000 Imola Red E39 M5
Yes, the smg 3 sucks, one of the reasons i am not fond of the E60 M5. Have fun!!!!!
Reply With Quote
  #7  
Old 05-23-2011, 02:40 PM
CbadM5 CbadM5 is offline
Registered User
Location: Carlsbad
 
Join Date: Jan 2011
Posts: 17
Mein Auto: Black M5
Should of post a long time ago but my issue ended up being the clutch sensor. Replaced it and no issues ever since.
Reply With Quote
  #8  
Old 06-03-2011, 06:52 PM
rsmith9717 rsmith9717 is offline
Registered User
Location: Frico Texas
 
Join Date: Jan 2011
Posts: 24
Mein Auto: M5 E60
My car finally gave up would not go in any gear. transmission warning came up and the gear 1 was flashing. Switched the engine off and car just would not start.
Hydraulic for SMG parts and labor $4900 bucks. 2 back tires $890 bucks.
Hopefully that will be the end of the SMG saga.....I hope
Reply With Quote
  #9  
Old 06-11-2011, 10:17 AM
rsmith9717 rsmith9717 is offline
Registered User
Location: Frico Texas
 
Join Date: Jan 2011
Posts: 24
Mein Auto: M5 E60
Got my car back SMG hydraulics all replaced. I swear the car is a little faster. Gear changes are quicker even with the gear speed shift on 3 bars. Plus it's a little more enjoyable driving in D1-D7
Reply With Quote
  #10  
Old 06-11-2011, 10:37 AM
mustaine's Avatar
mustaine mustaine is offline
Officially Welcomed to the 'Fest
Location: Dallas, Texas
 
Join Date: Nov 2007
Posts: 766
Mein Auto: 2007 ///M5
Quote:
Originally Posted by rsmith9717 View Post
Got my car back SMG hydraulics all replaced. I swear the car is a little faster. Gear changes are quicker even with the gear speed shift on 3 bars. Plus it's a little more enjoyable driving in D1-D7
I'm glad, it all worked out for you. Who performed the work, Classic??
__________________
So, I ask myself the question, what today..... what tomorrow?
Reply With Quote
  #11  
Old 06-11-2011, 11:34 AM
rsmith9717 rsmith9717 is offline
Registered User
Location: Frico Texas
 
Join Date: Jan 2011
Posts: 24
Mein Auto: M5 E60
I would not use Classic ever. Hate them. Unresponsive and never returns calls reminds me of a ford dealership. Before I purchased my car I wanted then to check it first. Just could not talk to anyone on the phone.
I use BMW of Dallas. Great experience and personal service.
Another reason I cannot stand classic was that when I purchased the car I had 3 months manufacture warrant left and they said nothing. Read my key. Saw the transmission codes and said nothing....
Classic is 6 miles from my hse BMW of Dallas about 20 miles.
Reply With Quote
  #12  
Old 06-11-2011, 12:48 PM
mustaine's Avatar
mustaine mustaine is offline
Officially Welcomed to the 'Fest
Location: Dallas, Texas
 
Join Date: Nov 2007
Posts: 766
Mein Auto: 2007 ///M5
Quote:
Originally Posted by rsmith9717 View Post
I would not use Classic ever. Hate them. Unresponsive and never returns calls reminds me of a ford dealership. Before I purchased my car I wanted then to check it first. Just could not talk to anyone on the phone.
I use BMW of Dallas. Great experience and personal service.
Another reason I cannot stand classic was that when I purchased the car I had 3 months manufacture warrant left and they said nothing. Read my key. Saw the transmission codes and said nothing....
Classic is 6 miles from my hse BMW of Dallas about 20 miles.
Owing to the fact that the transmission error codes were observed prior to expiration of original warranty, . Were the repairs performed as a good will?
What color is your M5? A couple of weeks ago, when I went to pick up our car at BMW Dallas, I saw one Silverstone M5. Was that yours?
__________________
So, I ask myself the question, what today..... what tomorrow?
Reply With Quote
  #13  
Old 06-11-2011, 03:06 PM
rsmith9717 rsmith9717 is offline
Registered User
Location: Frico Texas
 
Join Date: Jan 2011
Posts: 24
Mein Auto: M5 E60
I had to cough up for all repairs myself. Mine is Silver kinda graphite grey. This is my first BMW.
They did not tell me they saw the codes I just know Classic read my key. Whatever that means.
When I took the car to BMW of Dallas they told me there was over 90 occurrences of the transmission warning. Evidently just after my warranty expired. I do have a third party extended warranty but the part is enclosed and lubricated and hence not covered.
Reply With Quote
  #14  
Old 06-11-2011, 03:07 PM
rsmith9717 rsmith9717 is offline
Registered User
Location: Frico Texas
 
Join Date: Jan 2011
Posts: 24
Mein Auto: M5 E60
It is possible the car u saw was mine
Reply With Quote
  #15  
Old 07-04-2011, 08:02 AM
Kurikurd85 Kurikurd85 is offline
Officially Welcomed to the 'Fest
Location: Columbia MD
 
Join Date: Aug 2010
Posts: 137
Mein Auto: 2003 BMW 745li
How much does a clutch sensor cost to change at a dealer ?
Reply With Quote
  #16  
Old 07-04-2011, 09:28 AM
CbadM5 CbadM5 is offline
Registered User
Location: Carlsbad
 
Join Date: Jan 2011
Posts: 17
Mein Auto: Black M5
I believe it was around $700 installed at BMW of San Diego.
Reply With Quote
  #17  
Old 07-10-2011, 07:33 PM
Kurikurd85 Kurikurd85 is offline
Officially Welcomed to the 'Fest
Location: Columbia MD
 
Join Date: Aug 2010
Posts: 137
Mein Auto: 2003 BMW 745li
transmission malfunction came on 3 times, car still ran fine, 4th time came on, stayed in N only, shut engine on, never came bak on again, i had it towed to a bmw mechanic , this time not the dealer, i will find out tomo on the issue, i hoping for somthing minor as a clutch sensor, if not, ima trade it for a 2011 5 series, and never buy a M series again
Reply With Quote
  #18  
Old 07-10-2011, 07:33 PM
Kurikurd85 Kurikurd85 is offline
Officially Welcomed to the 'Fest
Location: Columbia MD
 
Join Date: Aug 2010
Posts: 137
Mein Auto: 2003 BMW 745li
shut engine off that is
Reply With Quote
  #19  
Old 07-10-2011, 08:04 PM
ProRail ProRail is offline
"Clunker" *****
Location: Columbia MD
 
Join Date: May 2006
Posts: 4,684
Mein Auto: 1999 BMW 528A-220K-traded
Quote:
Originally Posted by Kurikurd85 View Post
transmission malfunction came on 3 times, car still ran fine, 4th time came on, stayed in N only, shut engine on, never came bak on again, i had it towed to a bmw mechanic , this time not the dealer, i will find out tomo on the issue, i hoping for somthing minor as a clutch sensor, if not, ima trade it for a 2011 5 series, and never buy a M series again
Sounds like a good plan.
Reply With Quote
  #20  
Old 07-13-2011, 08:45 PM
Kurikurd85 Kurikurd85 is offline
Officially Welcomed to the 'Fest
Location: Columbia MD
 
Join Date: Aug 2010
Posts: 137
Mein Auto: 2003 BMW 745li
Those of you who had trans malfunction and that keeps driving it and thinking its nothng, sry to say but there is somthn wrong , get it checked out, the code is stored , bcuz it will break down on you soon , it happend to me , my car is at the shop 3 days and they still dont kno wats wrong, if not figured out another day , ima take it to the dealer , which i hate bcuz they like to replace major parts all the time
Reply With Quote
  #21  
Old 10-11-2011, 12:13 PM
bhuynh85 bhuynh85 is offline
Registered User
Location: FAIRFAX va
 
Join Date: Sep 2009
Posts: 10
Mein Auto: bmw m5
so had this problem came back up again for you because i just got the same work done please let me know thanks......
Reply With Quote
  #22  
Old 10-15-2011, 09:27 PM
CbadM5 CbadM5 is offline
Registered User
Location: Carlsbad
 
Join Date: Jan 2011
Posts: 17
Mein Auto: Black M5
I don't know if that last post was for me but if so no problems since the sensor was replaced and it's been awhile now.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M5 & M6 > E60 M5 (2006 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:51 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.