E60 EU model with UK seats fitted Airbag and seatbelt error - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)

E60 / E61 (2004 - 2010)
BMW 5-Series E60 Sedan was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E61 wagon followed shortly there after. The E60/E61 5 series is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-09-2019, 03:44 AM
kignrun2 kignrun2 is offline
Registered User
Location: Lithuania
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 BMW E38
E60 EU model with UK seats fitted Airbag and seatbelt error

Hi,

So I had gotten a set of leather seats for the car but the seats were from a UK model so the passenger and driver seats are switched. So now the passenger seat is a driver seat and so on. Problem is after everything is fitted it threw me the airbag and seat belt error for the passenger seat. I am guessing since now that the driver seat is on the passenger side and I'm guessing it doesn't have the scale mat in it that is why it is causing the error. I have heard of the scale mat and belt emulators. But I am wondering since the scale mat is on the driver side now. How would the emulator work . Do i need to plug it in on the driver side or on the passenger side. I'm thinking that the now the driver seat which is currently on the passenger side might not have the necessary connections to do so. It is hard to pin point how the cars sees the seats currently.

For reference it is a 2004 pre-lci model.

Any help would be greatly appreciated.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-09-2019, 05:21 PM
wcr3d wcr3d is offline
Officially Welcomed to the 'Fest
Location: Indiana
 
Join Date: Jul 2012
Posts: 3,218
Mein Auto: 2013 535iX M Sport
How about getting the right seats?
Thinking about it, wouldn't the seat controls be on the wrong side and inaccessible now?
Reply With Quote
  #3  
Old 10-09-2019, 11:01 PM
kignrun2 kignrun2 is offline
Registered User
Location: Lithuania
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 BMW E38
no they aren't that's why you place the passenger seat on the drivers side.

I also launched INPA yesterday so the two faults are these:
SFZ 9AFF
SBSR 9915

Last edited by kignrun2; 10-09-2019 at 11:34 PM.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-10-2019, 01:57 AM
Burning2nd's Avatar
Burning2nd Burning2nd is online now
Under the lift arms
Location: Under the lift Arm
 
Join Date: Aug 2010
Posts: 12,131
Mein Auto: e39, e83, e60
you have an air bag code that is being caused by the restraint system.. that is all..

i dont think you should have any problems at all.. I would think that physically making the seats work/ fit in would be the hardest part..

the wiring should be the same..

have you tried clearing the codes?

you have connected all the connectors on both sides?

you might have a bad buckle latch
__________________
Specializing In Breaking Things Professionally


15486372<-----
Reply With Quote
  #5  
Old 10-10-2019, 01:57 AM
Burning2nd's Avatar
Burning2nd Burning2nd is online now
Under the lift arms
Location: Under the lift Arm
 
Join Date: Aug 2010
Posts: 12,131
Mein Auto: e39, e83, e60
@ the 9915 code i mean
__________________
Specializing In Breaking Things Professionally


15486372<-----
Reply With Quote
  #6  
Old 10-10-2019, 03:52 AM
kignrun2 kignrun2 is offline
Registered User
Location: Lithuania
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 BMW E38
Yeah all the cables are plugged in tried re plugging them as well. I deleted the codes several times but after engine start they come back up. Any searches for the codes lead me to install the seat belt emulator or the BST positive cable bypass. Which I am not sure is needed.
Reply With Quote
  #7  
Old 10-10-2019, 10:21 AM
Burning2nd's Avatar
Burning2nd Burning2nd is online now
Under the lift arms
Location: Under the lift Arm
 
Join Date: Aug 2010
Posts: 12,131
Mein Auto: e39, e83, e60
well the emulator is a tool to remove or jump out simulate a functionally system...

you can either rig it

or you can repair it..

have you the old seats? put the old latch in the new seat
__________________
Specializing In Breaking Things Professionally


15486372<-----
Reply With Quote
  #8  
Old 10-10-2019, 11:03 PM
kignrun2 kignrun2 is offline
Registered User
Location: Lithuania
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 BMW E38
Yeah that's the problem . I chucked the old seats since they wore pretty worn down. I'm guessing to diagnose the issue i should still get the emulators to see if it is the seat belt pretensioner problem and then if the emulator works find a working pretensioner to replace it i guess?
Reply With Quote
  #9  
Old 10-11-2019, 02:17 AM
Burning2nd's Avatar
Burning2nd Burning2nd is online now
Under the lift arms
Location: Under the lift Arm
 
Join Date: Aug 2010
Posts: 12,131
Mein Auto: e39, e83, e60
yeah
__________________
Specializing In Breaking Things Professionally


15486372<-----
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:38 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.