Purge valve code - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2019, 01:24 PM
Fernando51454 Fernando51454 is offline
Registered User
Location: Clearwater fla
 
Join Date: Dec 2015
Posts: 22
Mein Auto: 2004 X5 4.4i
Purge valve code

04 x5 4.4 just had my local import shop replace both valve gaskets along with ignition coil tubes and new spark plugs. Now the check engine light is on and it's throwing a P0444 code. Is it typical that after the leak is repaired the purge valve also needs replaced? I did not have the engine light on when I brought it in and was tired of the oil burning smell and performance hesitation so that's why i had the job done. Wasn't expecting to see a check engine light since I didn't have one going in. Anyone else experience this after their valve cover change? Car has 165k on it. Thanks in advance
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-28-2019, 02:58 PM
Fernando51454 Fernando51454 is offline
Registered User
Location: Clearwater fla
 
Join Date: Dec 2015
Posts: 22
Mein Auto: 2004 X5 4.4i
This group is awesome thanks for all the replies
Reply With Quote
  #3  
Old 06-28-2019, 03:26 PM
Markst Markst is offline
Registered User
Location: Marg
 
Join Date: Apr 2018
Posts: 62
Mein Auto: BMW 5
One whole week without replies to an obscure generic obd error (which you didn't even bother researching) on a 15 year old car and you start complaining?
Oh the humanity!
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 07-12-2019, 06:06 AM
Fernando51454 Fernando51454 is offline
Registered User
Location: Clearwater fla
 
Join Date: Dec 2015
Posts: 22
Mein Auto: 2004 X5 4.4i
You're awesome thanks for the your awesome input! Oh the humanity!
Reply With Quote
  #5  
Old 07-13-2019, 04:58 AM
tttomttt tttomttt is offline
Officially Welcomed to the 'Fest
Location: Long Island NY
 
Join Date: Oct 2010
Posts: 132
Mein Auto: 2005 530i, 05 X5 3.0, 04
This code can be a troubleshooting nightmare. First and foremost do not top off your car after the gas pump clicks off. Just remove the filler and return it to the pump. I only mention this as any troubleshooting job you must first eliminate the silly stuff.
I am not sure how to troubleshoot the valve associated with this code and in addition I am not familiar with this particular code on a V8 engine. I was able to swap the valve on my 3.0 with another vehicle and the code did not return.
On 2 different MB vehicles I troubleshot it was actually a wiring issue one of which was at the computer the other to a wheel well connection.
Best advice I can give you is research this code thoroughly so that you do not needlessly replace parts. I am not sure of your familiarity with this purge valve code and what its job is and/or your troubleshooting skills so some more info of both would be helpful.
Tom T
Reply With Quote
  #6  
Old 07-13-2019, 10:21 AM
Fernando51454 Fernando51454 is offline
Registered User
Location: Clearwater fla
 
Join Date: Dec 2015
Posts: 22
Mein Auto: 2004 X5 4.4i
thank Tom the odd part is that i didn't have the code until after the valve cover gasket job. and was wondering if that had an affect since the injectors had to be messed with and the code is related to fuel. that's what i'm trying to do not just throw parts at it. i understand it could be the valve on the engine or the one in the wheel well next to gas tank. but don't know how to check which one is the culprit. i read where folks changed out the one on the engine but still had the code. thanks again for your input
Reply With Quote
  #7  
Old 07-17-2019, 06:12 PM
primem primem is offline
Registered User
Location: Alberta, Canada
 
Join Date: May 2019
Posts: 15
Mein Auto: 2005 x5 4.4L
the purge valve is an evap system component not related to fuel injectors or fuel injection or fuel supply. the code set when the pcm sees a open (reads a high voltage) in the purge solenoid wiring...it could be set if they missed plugging in the purge valve connector.
Reply With Quote
  #8  
Old 07-18-2019, 05:22 AM
Fernando51454 Fernando51454 is offline
Registered User
Location: Clearwater fla
 
Join Date: Dec 2015
Posts: 22
Mein Auto: 2004 X5 4.4i
Thanks I'll have to go check the electricle connection but it's my understanding that the purge valve is not in the way of a valve cover job so they shouldn't have touched it. Thanks for your reply.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.