Car Battery Replaced, Now Strange Noise Inside - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-16-2019, 01:26 PM
ZoominZ396 ZoominZ396 is offline
Registered User
Location: San Diego
 
Join Date: Feb 2017
Posts: 20
Mein Auto: 96 Z3 Roadster
Car Battery Replaced, Now Strange Noise Inside

I had not moved my Z3 for about 3 months and I tried turning the vehicle on, and of course, battery was dead. I did notice the terminals were corroded so I removed them, cleaned and sprayed a protective coat on them. I then used my car battery charger to turn it on. Once hooked on, I went inside the cabin and started hearing a long noise "beeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee eeeeeeeeeeeeeeeeeeeeeeeeeep". I positioned my key and turned it on the "ON" position and the noise went away but it did not turn on.
This is my first time with this issue and wanted to see if this just means I need a new battery or something else. I will be purchasing one soon, but I would appreciate any input. Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-16-2019, 03:12 PM
southcoastguy southcoastguy is offline
Officially Welcomed to the 'Fest
Location: Mattapoisett, MA
 
Join Date: Jan 2017
Posts: 680
Mein Auto: 328xi
Sounds like an alarm noise?
Reply With Quote
  #3  
Old 04-16-2019, 04:21 PM
ZoominZ396 ZoominZ396 is offline
Registered User
Location: San Diego
 
Join Date: Feb 2017
Posts: 20
Mein Auto: 96 Z3 Roadster
southcoastguy

Im not sure if its an alarm noise. As I mentioned, its my first time dealing with this. Do you know if an alarm is set off when the battery gets disconnected? Because that noise goes away as soon as I turn the ignition(but engine does not turn on). Do you know if there's a need to reset the vehicle with a code because of this? Thanks for your response.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 04-16-2019, 05:51 PM
vintage42's Avatar
vintage42 vintage42 is offline
BMW CCA 1405
Location: Louisville, KY
 
Join Date: Jun 2007
Posts: 4,811
Mein Auto: 1997 BMW Z3 1.9 5MT
Quote:
Originally Posted by ZoominZ396 View Post
... had not moved my Z3 for about 3 months... battery was dead... used my car battery charger to turn it on. Once hooked on, I went inside the cabin and started hearing a long noise... I positioned my key and turned it on the "ON" position and the noise went away but it did not turn on...
It is not clear what you did.
You used the battery charger to start the car, and heard a beeping, but the car did not start?
I would wait until the battery was fully charged, and then try starting the car.
Reply With Quote
  #5  
Old 04-17-2019, 09:17 AM
ZoominZ396 ZoominZ396 is offline
Registered User
Location: San Diego
 
Join Date: Feb 2017
Posts: 20
Mein Auto: 96 Z3 Roadster
Yes, that is correct.
Used the battery charger to charge the vehicle, went inside the cabin and heard that noise. I will take it in to have it fully charged, and if needed, will purchase a new battery.
Reply With Quote
  #6  
Old 04-17-2019, 12:46 PM
NZ00Z3 NZ00Z3 is offline
Officially Welcomed to the 'Fest
Location: New Zealand
 
Join Date: Dec 2015
Posts: 259
Mein Auto: 2000 Z3 3.0i
Disconnect one terminal of the battery and charge it isolated from the car
Reply With Quote
  #7  
Old 04-17-2019, 12:50 PM
vintage42's Avatar
vintage42 vintage42 is offline
BMW CCA 1405
Location: Louisville, KY
 
Join Date: Jun 2007
Posts: 4,811
Mein Auto: 1997 BMW Z3 1.9 5MT
OK, I thought you expected to jump start with the charger, because Post #1 you said "I then used my car battery charger to turn it on."
But then in Post #5 you said "Used the battery charger to charge the vehicle".

So did you wait for the charger to bring the battery up to strength, and did the engine start OK?
Reply With Quote
Reply

See More Related BMW Stories

Tags
bob's shoe


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
**Z3** DIY Guides (post links here) JonM E36/7 Z3 (1996-2002) 95 09-25-2019 12:48 PM
Battery recharge sign....after new battery OnlySkills 7 Series - E65 / E66 (2002 - 2008) 57 10-15-2014 04:36 PM
Battery Replacement iewing E60 / E61 (2004 - 2010) 24 10-19-2010 09:49 PM
bad battery shami E60 / E61 (2004 - 2010) 3 07-12-2010 11:40 AM
523 Strange Noise When Braking sloveridge E39 (1997 - 2003) 3 06-17-2008 05:30 AM


All times are GMT -7. The time now is 10:48 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.