Tv and reverse camera screen go green but working - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X3 M, X5 M, X6 M, Z3 M & Z4 M > E70 X5 M and E71 X6 M (2010 - 2015)

E70 X5 M and E71 X6 M (2010 - 2015)
The BMW X5 M and X6 M are the first xDrive all-wheel-drive vehicles from M GmbH. The M variants offers the same utility as the regular X5 and X6, with the addition of the V8 M TwinPower Turbo, a twin-turbocharged 4.4-liter V8 delivering 560 horsepower and 500 lb·ft of torque.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-28-2018, 04:11 AM
Jurinbobby Jurinbobby is offline
Registered User
Location: Melbourne
 
Join Date: Feb 2018
Posts: 3
Mein Auto: 2007 BMW X5. E70
Tv and reverse camera screen go green but working

Hi how are you? I need a bit of advise here for my display screen on x5 E70 I bought x5 last month and it has water in boot tv and reverse camera not working I replaced tv module and now it work both tv and reverse camera but only color green as in picture anyone have Idea that something wrong with it. Thank youClick image for larger version

Name:	IMG_4591.jpg
Views:	53
Size:	88.9 KB
ID:	779648Click image for larger version

Name:	IMG_4592.jpg
Views:	53
Size:	90.4 KB
ID:	779650Click image for larger version

Name:	IMG_4590.jpg
Views:	51
Size:	88.2 KB
ID:	779652Click image for larger version

Name:	IMG_4563.jpg
Views:	54
Size:	217.8 KB
ID:	779654


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-30-2020, 07:59 AM
enespinar068 enespinar068 is offline
Registered User
Location: Belgium
 
Join Date: Apr 2020
Posts: 1
Mein Auto: x5 e70 3.0si
Quote:
Originally Posted by Jurinbobby View Post
Hi how are you? I need a bit of advise here for my display screen on x5 E70 I bought x5 last month and it has water in boot tv and reverse camera not working I replaced tv module and now it work both tv and reverse camera but only color green as in picture anyone have Idea that something wrong with it. Thank youAttachment 779648Attachment 779650Attachment 779652Attachment 779654


Sent from my iPhone using Bimmerfest mobile app
What was the problem. I bought a x5 with same problem.
The idrive is really laggy and camera screen pops up after 15 seconds. When it pops up it's green. And tv also green.

thanks in advance
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X3 M, X5 M, X6 M, Z3 M & Z4 M > E70 X5 M and E71 X6 M (2010 - 2015)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:25 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.