X5 E70 CCC upgrade to 10.25" Android - Page 39 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #951  
Old 09-10-2019, 12:28 AM
Serge858 Serge858 is offline
Registered User
Location: Moscow Russia
 
Join Date: Aug 2017
Posts: 84
Mein Auto: BMW X5 E70
Quote:
Originally Posted by rbryantaz View Post
I got the new octacore Snapdragon 625 Android 9.0 head unit with 4G/64G from aliexpess (seller Kanor) last week.

The Unit:

I opted for the 4/64 version because it is supposed to have a screen with less glare. It comes with a black surround where the 3/32 octacore version has the silver finish on the surround.

There are also PX6 android units out there which are slightly cheaper and probably fine. The Snapdragon unit also has cellular support and updated video processing so it seemed like a good idea.

I installed most of it over the weekend and it went pretty well even though there was zero documentation other than wire labels.

My X5's options:

My 2007 CCC had the 6.5" screen, no nav, no reverse camera, no rear entertainment but did have the glovebox CD changer and SAT radio.

I have AUX in the center armrest but no USB.

Options were:

S645ABMW US Radio
S655ASatellite tuner
S663ARadio BMW Professional
S672ACD changer for 6 CDs
S677AHiFi System Professional DSP

I did not have to use the AUX cable and the sound is good. I saw no difference between connecting to the AUX in the armrest and not.

AUX input observations:

The aux input that they provide in the unit's wiring is just a splice into the aux input in the aftermarket connector that goes between the radio and the factory wiring. It is just effectively connected to pins 2, 7,8 as shown here from an e60 writeup that appears to be the same as the e70:






Reference: https://www.dvdgpsnav.com/blog/solut...oid-head-unit/

I bet most people's problems would be resolved by removing the wires shown above if using the latest unit (that way they aren't overdriven, grounded out, loaded, etc). I almost wonder if connecting a dummy connector into the AUX jack would also work to disconnect the rest of the system... Often aux jacks have an internal switch/disconnect when you plug something into them so just plugging something in would allow the units connections to start working even without driving a signal to it (because the signal is already driven on the same wires with the new unit)!

Please do let me know if I am missing something with the wiring here... It should be possible to identify any issues precisely...

GPS:

I plan to use the factory GPS connection to the sharkfin. I have to remove it from the connection in the rear behind the right rear panel and connect it via an aftermarket GPS extension cable. I discovered however that if I disconnect the antenna from the box I get an annoying SOS error when I start the car so I will have to either code that out or split the antenna. For now I ordered a splitter.
I recommend buying a 16ft fakra cable with male on one end and female on the other (extender) and then using a male to dual female splitter. The reason to do male to dual female and not the other way around (no threesome jokes please) is that the splicing of the cable is done in a better way than most fmale to dual male splitters that I see.

Aftermarket rear camera:

I bought a $21 latch camera with fake dynamic lines. The dynamic lines move if the car is moving and stay for a couple of seconds if you slow to a stop. I haven't tested it much but it seems okay and it can be ignored if desired. I used the latch camera because it seemed more centered. On second thought perhaps having it offset to the passenger side would given a better curb view when parallel parking.... I also needed a new latch because the rubber/plastic on mine had gone goopy from the sun here in AZ. I may consider splurging another $20 to put a camera in the factory location. I wired it so that it can be swapped with just the video and power connector so it is no big deal.

The install was actually easier than a lot of howto's show. The unit has a "camera 12v" line and a "Camera Det" line. I am not sure what the "Camera Det" line does but the 12v line does indeed drive battery voltage when the x5 goes into reverse. This is handy because you can connect that to the red wire that comes with the video cable as a power source. This is much better than connecting to reverse light (possibly with relay to make it stable, etc). I also ran a ground wire from the hatch to the ground lug on the passenger side (behind the access panel). I probably could have just connected it to the hatch body but this seemed like an easy thing to do that will provide a very stable ground.

Attachment 863419
I crimped a spade splice in just incase my camera video line fails or I need to upgrade it to one with more shielding but so far it seems just fine. Plus it is just nice to be able to disconnect things and i had them laying around.


I don't have object detection (perhaps that is what the det line is for but it seems to work just fine for $20 instead of hundreds for a factory camera retrofit.
Hey Rich,

Congrats with new Android device!

Regarding sound, did you try to disconnect AUX factory wires from the socket in the armrest? It gives better sound quality not only for Android but for factory sound as well.
You can see it in my video:


Have you connected central speaker to the android and tested it with factory radio and navigation on android? Without any installation manual it is not that obvious to connect those wires correctly. Two short twisted wires of android harness (white and blue) should be connected together, and two long twisted wires should go to the central speaker.

Do I get it right you've got the rear camera with dynamic lines? Actually Android has its own dynamic lines so you supposed to have them both now on the screen, which is not comfortable.
I always recommend this camera to the standard place (and order it without parking lines): http://ali.onl/1onP
It has Sony sensor, great picture in day and night time, wide angle, very good quality.
Regarding connection, NO need to connect ground wire, the ground is in RCA yellow video cable, the additional one may give noise/lines to the picture.
Here you can see that cam angle from factory place and android dynamic lines:


I don't recommend to use GPS antenna splitter, it may give voltage issues and destroy GPS android module. GPS extension cable to the factory antenna is the best solution. Good to know you've come to that solution.
__________________
E70 3.0d DPF/EGR off + chip Stage 1 (~290 hp).
Android 4.4 => Android 8.1

Last edited by Serge858; 09-10-2019 at 12:35 AM.
Reply With Quote
Sponsored Links
Advertisement
 
  #952  
Old 09-10-2019, 12:52 AM
rbryantaz rbryantaz is offline
Registered User
 
Join Date: Jul 2018
Posts: 31
Mein Auto:
Quote:
Originally Posted by Serge858 View Post
Hey Rich,

Congrats with new Android device!

Regarding sound, did you try to disconnect AUX factory wires from the socket in the armrest? It gives better sound quality not only for Android but for factory sound as well.
You can see it in my video:

Have you connected central speaker to the android and tested it with factory radio and navigation on android? Without any installation manual it is not that obvious to connect those wires correctly. Two short twisted wires of android harness (white and blue) should be connected together, and two long twisted wires should go to the central speaker.

Do I get it right you've got the rear camera with dynamic lines? Actually Android has its own dynamic lines so you supposed to have them both now on the screen, which is not comfortable.
I always recommend this camera to the standard place (and order it without parking lines): http://ali.onl/1onP
It has Sony sensor, great picture in day and night time, wide angle, very good quality.
Regarding connection, NO need to connect ground wire, the ground is in RCA yellow video cable, the additional one may give noise/lines to the picture.

I don't recommend to use GPS antenna splitter, it may give voltage issues and destroy GPS android module. GPS extension cable to the factory antenna is the best solution. Good to know you've come to that solution.
I might not have turned on the android lines, I currently only have one set which match what the camera is supposed to supply. I will have to check the setting and compare which is better. If android is better then I might switch to a camera without lines. Interesting point on using the video cable ground as the power ground, I didn't try that.

I don't have factory parking sensors, is there an extra aftermarket sensor that adds the detection and beeps? I saw the "camera det" wire but did not connect it.

I did connect the center speaker and it works well including for google maps. There were 2 speaker wires that I didn't connect They were something like Seaker 1 Fl and Speaker 2 Fl. They had the same connectors as the center and could have been connected into each other but they didn't seem to do anything:

Click image for larger version

Name:	android head unit Speaker FL1 FL2.jpg
Views:	30
Size:	86.3 KB
ID:	864095


The aux line from the armrest is just connected to the same exact wires that the head unit connects to (as I referenced in the connector pictures). The only way I can see it giving better sound is if the aux line in the arm rest to the radio connector is adding noise or in a setup where connecting to it disconnects from other things. That would make sense for people that have a the rear AV setup.

I did try to connect to the AUX input at first and saw no difference. I then traced the wires and saw that the aux input connects into the radio harness. The AUX output from the android unit just connects to the same exact wires as the aux input from the armrest doe on the other side of the connector. So connecting to the aux input just connects it back to wires it is already connected to through a longer wire (which is pointless).


Thanks,

Rich

Last edited by rbryantaz; 09-10-2019 at 12:59 AM.
Reply With Quote
  #953  
Old 09-10-2019, 02:53 AM
Serge858 Serge858 is offline
Registered User
Location: Moscow Russia
 
Join Date: Aug 2017
Posts: 84
Mein Auto: BMW X5 E70
Quote:
Originally Posted by rbryantaz View Post
I might not have turned on the android lines, I currently only have one set which match what the camera is supposed to supply. I will have to check the setting and compare which is better. If android is better then I might switch to a camera without lines. Interesting point on using the video cable ground as the power ground, I didn't try that.

I don't have factory parking sensors, is there an extra aftermarket sensor that adds the detection and beeps? I saw the "camera det" wire but did not connect it.

I did connect the center speaker and it works well including for google maps. There were 2 speaker wires that I didn't connect They were something like Seaker 1 Fl and Speaker 2 Fl. They had the same connectors as the center and could have been connected into each other but they didn't seem to do anything:

Attachment 864095


The aux line from the armrest is just connected to the same exact wires that the head unit connects to (as I referenced in the connector pictures). The only way I can see it giving better sound is if the aux line in the arm rest to the radio connector is adding noise or in a setup where connecting to it disconnects from other things. That would make sense for people that have a the rear AV setup.

I did try to connect to the AUX input at first and saw no difference. I then traced the wires and saw that the aux input connects into the radio harness. The AUX output from the android unit just connects to the same exact wires as the aux input from the armrest doe on the other side of the connector. So connecting to the aux input just connects it back to wires it is already connected to through a longer wire (which is pointless).


Thanks,

Rich
There is a choice of aftermarket universal parking sensors but not sure if they will work with android easily. Not sure about Camera DET wire function.

Regarding AUX in the armrest I meant there is a filter inside that unit, so for better sound quality you need to unplug it.
__________________
E70 3.0d DPF/EGR off + chip Stage 1 (~290 hp).
Android 4.4 => Android 8.1
Reply With Quote
  #954  
Old 09-23-2019, 11:31 PM
rbryantaz rbryantaz is offline
Registered User
 
Join Date: Jul 2018
Posts: 31
Mein Auto:
Quote:
Originally Posted by Serge858 View Post
There is a choice of aftermarket universal parking sensors but not sure if they will work with android easily. Not sure about Camera DET wire function.

Regarding AUX in the armrest I meant there is a filter inside that unit, so for better sound quality you need to unplug it.
There is no filter on my '07 e70 Aux only input (the one without the USB).

The factory Aux plus USB has a filter as does the aftermarket copy that I have but that should not introduce noise. All high end audio equipment has RC protection on line level inputs, they are to keep the noise down and for ESD protection.
I did some listening tests and did not notice a difference by plugging it the aux input block (with no aux cable installed). Have you repeated the experiment or could you just have had a bad one? It really shouldn't impact sound quality at all to have the RC components there in the sizes I saw.

I happened to have the original e70 aux only input, my e90 aux+usb, and an aftermarket aux+usb.


Note that the connectors on the BMW pieces are barely soldered at all, I think they are some sort of snap in connection. I decided that I didn't like it and soldered them both.

The E70 is really simple with just a connection:
Click image for larger version

Name:	e70 aux input back.jpg
Views:	27
Size:	166.6 KB
ID:	865559
Click image for larger version

Name:	e70 aux input front.jpg
Views:	23
Size:	147.6 KB
ID:	865561


The E90 has 100nF caps and a 300k Ohm resistor (as does the aftermarket unit).
Click image for larger version

Name:	e90 aux back.jpg
Views:	20
Size:	128.2 KB
ID:	865563
Click image for larger version

Name:	e90 aux front.jpg
Views:	20
Size:	132.5 KB
ID:	865565

Aftermarket ebay/aliexpress unit. The usb is probably fine but the aux input 3.5mm connector didn't seem great. I don't really plan on using it much anyway.
Click image for larger version

Name:	aftermarket aux back.jpg
Views:	24
Size:	107.5 KB
ID:	865567
Click image for larger version

Name:	aftermarket aux front.jpg
Views:	22
Size:	120.9 KB
ID:	865569


I did something slightly different for the USB. My e70 didn't have USB so I used the aftermarket USB+aux connector with an aftermarket BMW style USB cable. I then cut one end off from the USB cable and soldered on a universal USB 2.0 male (USB A) connector. This was long enough to reach the android head unit USB connectors in the glovebox from the armrest. This way there is no cutting or changing to have USB in the armrest. My next step is to put in an OTG charge connector to charge from the power port and still connect to the data... Note that the wire colors were non standard on the wire but I just checked them with my ohm meter. I was able to test it by using it as a USB extension cable with my mouse to my PC to know that I got it right.

I also did the other end of the cable which I can use with a basic USB extension cable if desired. I didn't take a picture of the long cable but here is the short one.

Click image for larger version

Name:	custom usb cable.jpg
Views:	18
Size:	60.3 KB
ID:	865571

There is a seller on aliexpress who makes this cable with or without the aux/usb input piece if anyone wants it. I just made one because I didn't feel like waiting: https://www.aliexpress.com/item/3284...c00icOPZe&mp=1



Now...

Does anyone know how to get the head unit to tether over USB rather than WIFI? Most of the apps to turn on the hotspot on my phone with bluetooth don't seem to work with my new android 9 phone.


-Rich

Last edited by rbryantaz; 09-23-2019 at 11:38 PM.
Reply With Quote
Reply

See More Related BMW Stories

Tags
10.25" ccc e70 android radio


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:32 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.