X5 E70 CCC upgrade to 10.25" Android - Page 36 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #876  
Old 01-31-2019, 01:04 PM
Jock gt Jock gt is offline
Officially Welcomed to the 'Fest
Location: Aberdeen -uk
 
Join Date: Mar 2014
Posts: 190
Mein Auto: E70 - 40d
Quote:
Originally Posted by Absentmathis View Post
Iím not sure which version I have, but the issue is that the volume from the android to car is nearly silent. Canít stream music, canít use nav, etc. I had to connect the audio cable to the center console to get any sound at all, but in order to hear anything I have to turn the car volume up to max and of course at that point itís still too quiet and sounds awful. The android volume out level is already set to max as well.

Iím certainly not defending Avin, however

I have Individual Audio with Bluetooth streaming -
When I got the car, I read the build spec and acknowledged the Bluetooth Audio
Tried it and no success, following multiple attempts I learnt the volume knob had to be screwed midway, switching between Bluetooth Audio and OEM Audio, almost blows me off my seat, literally soiling myself as the volume is set so loud
I tried this with USB to the same effect
Not deterred, I also tried the Aux in same effect

Irrespective of connection method, all require significant column increase on OEM setting

So whilst many consider the Avin screens deficiency of crap sound, is the problem on the input side of the OEM system ie BMW side???


<~~~pulls the pin, throws and runs.....
__________________
Reply With Quote
Sponsored Links
Advertisement
 
  #877  
Old 01-31-2019, 07:24 PM
Absentmathis Absentmathis is offline
Officially Welcomed to the 'Fest
Location: Charlotte
 
Join Date: Jun 2015
Posts: 585
Mein Auto: E70
I can plug anything else into the aux input and it works at normal volume. It's only the Avin that comes through at the volume of an ant.
Reply With Quote
  #878  
Old 01-31-2019, 07:32 PM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Quote:
Originally Posted by Absentmathis View Post
I can plug anything else into the aux input and it works at normal volume. It's only the Avin that comes through at the volume of an ant.
Did you increase volume in both Avin audio settings and the Android audio settings? There's two different places.

Sent from my XT1635-01 using Bimmerfest mobile app
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
Sponsored Links
Advertisement
 
  #879  
Old 02-07-2019, 01:53 PM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Android/Carplay wifi connection

AVIN Android 4.4, so can't load Android Auto since that needs Android 5...so I'm stuck connecting via cable and using Android Auto on my phone. I see options for Android and iPhone wifi but can't get Android Auto/CarPlay to appear without a cable. Screen says do first time setup via cable, done that dozens of times and no results, still need the cable.

I know I can make my phone a hotspot and run maps, music, etc apps on the AVIN by themselves but like the ease of use of Android Auto. Would be even better if I could simply hop in the car and it kicks on the AVIN without connecting a cable.
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
  #880  
Old 02-07-2019, 05:59 PM
Absentmathis Absentmathis is offline
Officially Welcomed to the 'Fest
Location: Charlotte
 
Join Date: Jun 2015
Posts: 585
Mein Auto: E70
Quote:
Originally Posted by cvgtpc1 View Post
Did you increase volume in both Avin audio settings and the Android audio settings? There's two different places.

Sent from my XT1635-01 using Bimmerfest mobile app
Not sure. Can you elaborate on how to do so? I know I did one of them, not sure about the other.
Reply With Quote
  #881  
Old 02-08-2019, 02:38 PM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Quote:
Originally Posted by Absentmathis View Post
Not sure. Can you elaborate on how to do so? I know I did one of them, not sure about the other.
Go to Settings then Audio for one audio setting.

The other, Android sound, is Settings, then Settings again. Scroll to Sound, tap and on right side you see Volume. Tap that to adjust volumes there. Once I did that it was much better. Hope this helps.
Attached Thumbnails
Click image for larger version

Name:	Avin Setting Audio.jpg
Views:	114
Size:	69.6 KB
ID:	839359   Click image for larger version

Name:	Avin Setting Setting.jpg
Views:	98
Size:	74.1 KB
ID:	839361   Click image for larger version

Name:	Avin Setting Setting Sound Volume.jpg
Views:	103
Size:	77.4 KB
ID:	839363   Click image for larger version

Name:	Avin Setting Setting Sound Volume Adjust.jpg
Views:	99
Size:	63.1 KB
ID:	839365  
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
  #882  
Old 02-08-2019, 04:37 PM
thefys thefys is offline
Registered User
Location: Vancouver, Canada
 
Join Date: Jan 2013
Posts: 55
Mein Auto: X3 F25 2013
The sheer size of this thread scares me.
I have been reading up on the X5/X3 forums about these two touch screen upgrades to the OEM screen which bring Android Auto + Car Play to our F25 X3s. (Mine is a 2013)

BMW X3 X4 Series 8.8" F25 F26 2010 - 2018 CIC NBT Multimedia Navigation System


The other unit that is getting some love is the CAR NAVI BMW X3(F25)/X4(F26) 2011-2017 Radio upgrade

As you can see below they are very similar, perhaps identical hardware + software with different branding.

I would like to ask the folks here that have done the install two things:

1) - Bluetooth connectivity apparently is not that great compared to OEM - what is your experience workarounds (some folks have flat out returned the unit base on this single issue

2) - Audio quality is subpar for many folks due to a) audio gain mismatches and b) audio noise and interference due to the analog Aux In additional run from dash to center console.

Please share your thoughts.

Many thanks !



__________________
What's a Sound Designer ?

... "someone who makes noises for a living" [Un-named software engineer at Electronic Arts]

Me :
Reply With Quote
  #883  
Old 02-09-2019, 06:10 AM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Both are fine on mine...when it works as it should. Will have days where it's wow love it then when I really need it in a tight spot and it hangs up I regret it. And that's more frequent than I believe it should be. Thing is pretty touchy in my experience.

Sent from my XT1635-01 using Bimmerfest mobile app
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
  #884  
Old 02-09-2019, 09:41 AM
gsnake2000 gsnake2000 is online now
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Nov 2016
Posts: 234
Mein Auto: 2013 X5 35i (M-Sport)
Quote:
Originally Posted by cvgtpc1 View Post
Both are fine on mine...when it works as it should. Will have days where it's wow love it then when I really need it in a tight spot and it hangs up I regret it. And that's more frequent than I believe it should be. Thing is pretty touchy in my experience.

Sent from my XT1635-01 using Bimmerfest mobile app
that is exactly how I felt about it when I tried it for a few days. so unreliable.. great idea though.. my 5 old android phone looked like a sample of a perfect stable device comparing to this unit. maybe one day it will be more stable..
Reply With Quote
  #885  
Old 02-09-2019, 11:00 AM
thefys thefys is offline
Registered User
Location: Vancouver, Canada
 
Join Date: Jan 2013
Posts: 55
Mein Auto: X3 F25 2013
Thanks for the quick reply. Can you guys identify what version Android software you're running on your system currently?
__________________
What's a Sound Designer ?

... "someone who makes noises for a living" [Un-named software engineer at Electronic Arts]

Me :
Reply With Quote
  #886  
Old 02-09-2019, 01:29 PM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Quote:
Originally Posted by thefys View Post
Thanks for the quick reply. Can you guys identify what version Android software you're running on your system currently?
Mine is Android 4.4.

I suggest you join a Facebook group called The Android Head Unit Group. Good info and discussion of issues.
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
  #887  
Old 02-09-2019, 02:13 PM
thefys thefys is offline
Registered User
Location: Vancouver, Canada
 
Join Date: Jan 2013
Posts: 55
Mein Auto: X3 F25 2013
Thank you.

4.4 Is pretty old - Do you think the inconsistently somewhat perhaps improved with 8.1 Oreo and new hardware?

The facebook thing seems good - thank you for sharing that
__________________
What's a Sound Designer ?

... "someone who makes noises for a living" [Un-named software engineer at Electronic Arts]

Me :
Reply With Quote
  #888  
Old 02-09-2019, 02:19 PM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Quote:
Originally Posted by thefys View Post
Thank you.

4.4 Is pretty old - Do you think the inconsistently somewhat perhaps improved with 8.1 Oreo and new hardware?

The facebook thing seems good - thank you for sharing that
From msg boards I'm on it seems to not matter. Why I haven't pulled the trigger to upgrade my hardware.
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
  #889  
Old 02-09-2019, 02:33 PM
thefys thefys is offline
Registered User
Location: Vancouver, Canada
 
Join Date: Jan 2013
Posts: 55
Mein Auto: X3 F25 2013
Ugh - that's a drag. Its a pretty expensive upgrade for it not to work consistently.

I'd basically be happy with just Android Auto and CarPlay working, and then reverting back to BMW OS for the rest. But that means the Audio needs to work from my Nexus Pixel XL and an Iphone when in Android Auto / Carplay mode.

It's impossible to tell from the mega thread how much of this actually consistently works.

Thanks Again !
__________________
What's a Sound Designer ?

... "someone who makes noises for a living" [Un-named software engineer at Electronic Arts]

Me :
Reply With Quote
  #890  
Old 02-09-2019, 03:06 PM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Well since Android Auto could be loaded directly due to the unit being above Android 5, I would think it'd work great using the phone as a hot spot? Sounds good in theory at least!
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
  #891  
Old 02-10-2019, 11:24 AM
ansh22197 ansh22197 is offline
Registered User
Location: houston
 
Join Date: Mar 2014
Posts: 29
Mein Auto: x5
There is more good than bad with this unit.
Key points:
1) Bluetooth - just use the stock Bluetooth for phone calls; it works fine with iPhone
2) Audio - code/enable the AUX port on the head in addition to the one in armrest and then set it as default audio source. The audio quality will be as good as any other BMW source.
3) the android interface is slow and because of that feels outdated. However, the CarPlay interface (a dongle is extra) is super responsive; suspect that it relies on the computing power of iPhone. I only use CarPlay interface for music and navigation.


Sent from my iPhone using Bimmerfest
Reply With Quote
  #892  
Old 03-28-2019, 01:22 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,005
Mein Auto: 2009 X5
Recently my Avin 4.4 crashed but was able to recover it but now I have a few issues:

-I lost the ability to speak while connected to the android bluetooth (they cant hear me...no sound at all). I tried my original bluetooth and the caller was able to hear me and I was able to hear them perfectly.
-I was able to listen to music/play movie and the GPS (GoogleMaps) instructions from my iPhone via Android bluetooth. Right now, I have to selected the bluetooth on the android and stay on the screen to hear the directions. If I minimize it (switch to another screen/app), I will not hear it.

Avin site was selling Sygic maps on a microSD card. I am wondering how is it possible to save/run the maps from the SD card. When I installed Sygic, it doesnt see/recognize the external SD card...I cant even move my maps there like Sygic website support suggested. Are you guys able to do it? If so, how?
Avin site was selling the SWAP memory microSD card. Do you guys know how to do it?
Reply With Quote
  #893  
Old 03-28-2019, 01:22 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,005
Mein Auto: 2009 X5
...

Last edited by ill_kuma; 03-28-2019 at 01:23 PM. Reason: double posted.
Reply With Quote
  #894  
Old 03-29-2019, 11:37 AM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Quote:
Originally Posted by ill_kuma View Post
Recently my Avin 4.4 crashed but was able to recover it but now I have a few issues:

-I lost the ability to speak while connected to the android bluetooth (they cant hear me...no sound at all). I tried my original bluetooth and the caller was able to hear me and I was able to hear them perfectly.
-I was able to listen to music/play movie and the GPS (GoogleMaps) instructions from my iPhone via Android bluetooth. Right now, I have to selected the bluetooth on the android and stay on the screen to hear the directions. If I minimize it (switch to another screen/app), I will not hear it.

Avin site was selling Sygic maps on a microSD card. I am wondering how is it possible to save/run the maps from the SD card. When I installed Sygic, it doesnt see/recognize the external SD card...I cant even move my maps there like Sygic website support suggested. Are you guys able to do it? If so, how?
Avin site was selling the SWAP memory microSD card. Do you guys know how to do it?
Not sure about the BT issues...but have you tried moving the actual sygic files into a different folder?
__________________
2007 X5 3.0 Si
Reply With Quote
  #895  
Old 03-29-2019, 12:38 PM
robnitro robnitro is offline
Officially Welcomed to the 'Fest
Location: NYC area
 
Join Date: Aug 2016
Posts: 627
Mein Auto: x5 35d e70 2011
Quote:
Originally Posted by ansh22197 View Post
There is more good than bad with this unit.
Key points:
1) Bluetooth - just use the stock Bluetooth for phone calls; it works fine with iPhone
2) Audio - code/enable the AUX port on the head in addition to the one in armrest and then set it as default audio source. The audio quality will be as good as any other BMW source.
3) the android interface is slow and because of that feels outdated. However, the CarPlay interface (a dongle is extra) is super responsive; suspect that it relies on the computing power of iPhone. I only use CarPlay interface for music and navigation.


Sent from my iPhone using Bimmerfest
What's coding to extra aux entail and does it allow you to still use the aux for other things?

Also how is the bt audio streaming, it goes through the avin without needing the combox bmw bt music?

Oh and cameras, does it work with the stock bmw rear and side (top view) cameras?
Reply With Quote
  #896  
Old 03-29-2019, 04:18 PM
miltonlacey1960 miltonlacey1960 is offline
Registered User
 
Join Date: Mar 2019
Posts: 1
Mein Auto:
I installed a new 8.8 from Avin USA. I have had nothing but problems with this thing. They are no help. They will not answer my emails, or let me exchange it under their 1 year replacement. $600.00 for? Maybe someone here can help me. I have followed the instructions to the 'T'. I have no sounds, no radio stations or XM. I cannot go into the settings for the treble or any of the other radio settings. Any ideas? Thanks
Reply With Quote
  #897  
Old 03-30-2019, 12:00 PM
cvgtpc1 cvgtpc1 is offline
Officially Welcomed to the 'Fest
Location: Atlanta area
 
Join Date: Dec 2016
Posts: 709
Mein Auto: 2002 E39, 2008 E70
Quote:
Originally Posted by miltonlacey1960 View Post
I installed a new 8.8 from Avin USA. I have had nothing but problems with this thing. They are no help. They will not answer my emails, or let me exchange it under their 1 year replacement. $600.00 for? Maybe someone here can help me. I have followed the instructions to the 'T'. I have no sounds, no radio stations or XM. I cannot go into the settings for the treble or any of the other radio settings. Any ideas? Thanks
Have you tried running a cable from the avin aux out connector to the armrest aux? I didn't have to fro audio but some have to for some reason.

Whenever I've had problems reseating everything fixes it.

I'll love my avin 4.1 one day and want to rip it out with a crowbar the next. Very unstable. Tempted but not convinced upgrading to 8.x will be any better.
__________________
cvgtpc1
---------
- 08 E60 LCI 528i - VIN: C112981, Engine: N52K, MONACOBLAU METALLIC, Prod.date: 2008-05-15
- 08 E70 X5 3.0Si - VIN: L008866, Engine: N52K, TITANSILBER METALLIC, Prod.date: 2007-12-22

RIP 04/23/18
- 02 E39 525i
Reply With Quote
  #898  
Old 03-30-2019, 04:56 PM
sunny_j's Avatar
sunny_j sunny_j is offline
bmw addiction
Location: Vancouver, Britsh Columbia
 
Join Date: Sep 2006
Posts: 7,067
Mein Auto: X5d
Has anyone purchased the unit with the built in dash cam? How's the quality and placement of the camera?
__________________

2012 X5d | White on Black | Sports Package | EGR/DPF/SCR Delete | BRR Tune | DWR TCU Tune | 10.25" Android 8.1 Screen

Build Log
https://www.bimmerfest.com/forums/sh....php?t=1290337
Reply With Quote
  #899  
Old 04-01-2019, 10:40 AM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,005
Mein Auto: 2009 X5
Quote:
Originally Posted by noelskii View Post
Not sure about the BT issues...but have you tried moving the actual sygic files into a different folder?
I actually did tried moving the sygic folder to the external sd card and copied the maps that I already have from my computer into the external sd card. After that, when I start the Sygic app...it recreates the folders back into the internal drive.

As for the BT issue, I have noticed that after I recovered and updated the AVIN...the actual interface for when I make a phone call is different from before. That could be the problem. I will get a photo of it later to show you guys.
Reply With Quote
  #900  
Old 04-01-2019, 11:15 AM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,005
Mein Auto: 2009 X5
Here's the pic when I am connected and using the Bluetooth. It is definitely different interface as the one I was using before.
Click image for larger version

Name:	IMG_0308.jpg
Views:	72
Size:	81.5 KB
ID:	846109


Sent from my iPhone using Bimmerfest mobile app

Last edited by ill_kuma; 04-01-2019 at 11:18 AM.
Reply With Quote
Reply

See More Related BMW Stories

Tags
10.25" ccc e70 android radio


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:43 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.