X5 E70 CCC upgrade to 10.25" Android - Page 7 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #151  
Old 09-05-2017, 04:46 AM
weaselchops weaselchops is offline
Registered User
Location: UK
 
Join Date: Aug 2017
Posts: 11
Mein Auto: X5 E70 3.0sd
Quote:
Originally Posted by rpoitras View Post
So if you have factory cameras does the unit automatically switch from Android to the car screen when, for example, putting the car in reverse? Or do you have to switch it yourself every time?
Yes, auto switches to factory camera view.
Reply With Quote
Sponsored Links
Advertisement
 
  #152  
Old 09-05-2017, 09:26 AM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
Quote:
Originally Posted by IvanBux View Post
Hello!
2. Middle speaker in/out is made for passing through the sound from Android to OEM middle speaker if you have this one. I've got HiFi pro system with the Center speaker in the centre of the dash. So you should connect the OUT to the speaker and IN to the OEM CENTRAL speaker connector. If you don't have such speaker the easist way just not to connect this. Or you can run the wires to the LEFT or RIGHT speaker of the car, which won't be easy.
My car also has top hifi. Where are the connectors of the speaker and central speaker that you connected the middle speaker in/out wires to? Do you feel the sound better when connected than not connected to those speaker? Thanks
Reply With Quote
  #153  
Old 09-05-2017, 10:01 AM
IvanBux IvanBux is offline
Registered User
Location: Russia
 
Join Date: Sep 2013
Posts: 6
Mein Auto: BMW X5 E70LCI MY2011
Quote:
Originally Posted by pplayer View Post
My car also has top hifi. Where are the connectors of the speaker and central speaker that you connected the middle speaker in/out wires to? Do you feel the sound better when connected than not connected to those speaker? Thanks
It's in the center of the console.
See attached images.

So you should remove central speaker to get to the connector and remove installed Android screen and than connect the speaker and connectors.

As for the sound - this is not for the quality but for the Android navigation can "talk" through the speaker while you are listening the radio.
Attached Thumbnails
Click image for larger version

Name:	01.png
Views:	311
Size:	56.8 KB
ID:	658585   Click image for larger version

Name:	02.png
Views:	300
Size:	76.6 KB
ID:	658593   Click image for larger version

Name:	03.png
Views:	280
Size:	56.8 KB
ID:	658601   Click image for larger version

Name:	E70 Speaker Layout (Premium Audio).jpg
Views:	368
Size:	99.8 KB
ID:	658609   Click image for larger version

Name:	E70 Speaker Layout (Standard Audio).jpg
Views:	311
Size:	93.5 KB
ID:	658617  

Click image for larger version

Name:	x5-central.jpg
Views:	294
Size:	125.7 KB
ID:	658625  
Reply With Quote
Sponsored Links
Advertisement
 
  #154  
Old 09-05-2017, 10:15 AM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
Quote:
Originally Posted by IvanBux View Post
It's in the center of the console.
See attached images.

So you should remove central speaker to get to the connector and remove installed Android screen and than connect the speaker and connectors.

As for the sound - this is not for the quality but for the Android navigation can "talk" through the speaker while you are listening the radio.
Thanks a lot Ivan. By doing this, is the OEM radio or music still able to output to the central speaker?

Sent from my SM-G920F using Tapatalk
Reply With Quote
  #155  
Old 09-05-2017, 10:21 AM
IvanBux IvanBux is offline
Registered User
Location: Russia
 
Join Date: Sep 2013
Posts: 6
Mein Auto: BMW X5 E70LCI MY2011
Quote:
Originally Posted by pplayer View Post
Thanks a lot Ivan. By doing this, is the OEM radio or music still able to output to the central speaker?

Sent from my SM-G920F using Tapatalk
Yes, radio will be muted through the central speaker only in case of Android navigation is speaking.
Reply With Quote
  #156  
Old 09-08-2017, 03:44 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,006
Mein Auto: 2009 X5
Might be a dumb questions but do you have to disconnect the battery before doing all the wiring?
Reply With Quote
  #157  
Old 09-08-2017, 04:09 PM
miguellara420 miguellara420 is offline
Registered User
 
Join Date: Sep 2014
Posts: 73
Mein Auto:
Quote:
Originally Posted by ill_kuma View Post
Might be a dumb questions but do you have to disconnect the battery before doing all the wiring?
You're supposed to.

Sent from my Pixel using Tapatalk
Reply With Quote
  #158  
Old 09-08-2017, 04:34 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Unboxing AVIN

Got my AVIN CIC model in. Also added CarPlay (I am an iPhone user and mainly wanted ability to view Waze app on the big screen). No included instructions so will follow what people have done in this thread.
Attached Thumbnails
Click image for larger version

Name:	image1 (1).JPG
Views:	255
Size:	86.0 KB
ID:	661609   Click image for larger version

Name:	image2.JPG
Views:	241
Size:	71.8 KB
ID:	661617   Click image for larger version

Name:	image3.JPG
Views:	236
Size:	110.3 KB
ID:	661625   Click image for larger version

Name:	image4.JPG
Views:	285
Size:	97.9 KB
ID:	661633   Click image for larger version

Name:	image5.JPG
Views:	256
Size:	68.7 KB
ID:	661641  

Click image for larger version

Name:	image6.JPG
Views:	309
Size:	116.4 KB
ID:	661649  

Last edited by msan; 09-08-2017 at 04:46 PM.
Reply With Quote
  #159  
Old 09-08-2017, 04:45 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
More pics
Attached Thumbnails
Click image for larger version

Name:	image7.JPG
Views:	245
Size:	86.9 KB
ID:	661657   Click image for larger version

Name:	image8.JPG
Views:	249
Size:	111.4 KB
ID:	661665   Click image for larger version

Name:	image9.JPG
Views:	247
Size:	102.8 KB
ID:	661673   Click image for larger version

Name:	image10.JPG
Views:	217
Size:	85.1 KB
ID:	661681   Click image for larger version

Name:	image11.JPG
Views:	204
Size:	103.9 KB
ID:	661689  

Reply With Quote
  #160  
Old 09-08-2017, 05:13 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,006
Mein Auto: 2009 X5
Quote:
Originally Posted by miguellara420 View Post
You're supposed to.

Sent from my Pixel using Tapatalk
Yeah, I know we are "supposed" but did anyone of you guys did disconnect the battery first?
Reply With Quote
  #161  
Old 09-09-2017, 01:34 AM
Serge858 Serge858 is offline
Registered User
Location: Moscow Russia
 
Join Date: Aug 2017
Posts: 84
Mein Auto: BMW X5 E70
Does anyone know what the Camera DET cable is intended for? I am about to purchase the Android head unit together with an aftermarket wireless rear view camera and trying to understand how to connect it to the unit. The main question is if the Camera +12V is ON all the time or on reverse gearbox mode only. I don't want the camera receiver to be ON all the time (only when Reverse is ON) in order to avoid any radio interference. Appreciate any clarifications.

Last edited by Serge858; 09-09-2017 at 04:11 AM.
Reply With Quote
  #162  
Old 09-09-2017, 03:53 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Got it hooked up but I also get "No Signal" when trying to view the original car CIC..... Tried unplugging and re plugging the y adapter to no avail....
Reply With Quote
  #163  
Old 09-09-2017, 04:34 PM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
Quote:
Originally Posted by ill_kuma View Post
Yeah, I know we are "supposed" but did anyone of you guys did disconnect the battery first?
No, I didn't
Reply With Quote
  #164  
Old 09-09-2017, 05:43 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Quote:
Originally Posted by lalit.sis View Post
Hey Guys installed my yokotron, took me 3 hrs also being a first timer. However it showing no signal! Any ideas please? Also I couldn't find place to put one cable from the original unit with locking hatch and 8 pins female to new unit? Pretty Poor instructions for installation....
Did you solve your issue? I'm having the same problem
Reply With Quote
  #165  
Old 09-09-2017, 06:37 PM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
I also got the "No signal" sometimes but normally after a reboot it is ok. Below is what I got from their newest instructions. I've never tried it.

iDrive Reboot
Symptoms: prolonged BMW screen at startup, then "NO SIGNAL" when switching to "original car," no audio, iDrive controller only partially worked in the AVIN menus, and green SOS light in headlineroccasionally blinked.
Push both eject buttons (DVD and CD) and the volume knob (a.k.a themute button) at the same time. Wait about 30 seconds for the factory system to complete its reboot. https://www.bimmerfest.com/forums/sho...d.php?t=254420
Reply With Quote
  #166  
Old 09-09-2017, 10:08 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
I am an idiot. I never reconnected the "purple" plug into the new screen. Once I connected it it's all good
Reply With Quote
  #167  
Old 09-10-2017, 02:54 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Quote:
Originally Posted by pplayer View Post
What are the wires "Middle Speaker In", "Middle Speaker Out", "Camera DET"? Where to connect them to? I guess the "Camera DET" and "Camera +12V provide power for rear camera. However under the name "Camera DET" there are Chinese words start with 360 so I guess they may have something to do with 360 degree camera.

Sorry I tried to post the picture from my google photos but it did not show up. But those who has the unit should know those wires.
You will see a middle speaker cable where you removed your old screen. Just unplug and plug in the two plugs in and out. No need to mess with the middle speaker from the top. The cable is accessible from under/behind the screen.
Reply With Quote
  #168  
Old 09-10-2017, 06:10 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Can you guys tell me "CAN type" setting works for you and what size screen you started with? I have a 2012 CIC 8.8" and can't find a good CAN type. I used #6 per instructions but original car doesn't work when I restart the car. I get a blank screen .
Reply With Quote
  #169  
Old 09-11-2017, 07:14 AM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Finally got my Apple CarPlay adapter. Pretty cool!
__________________
2007 X5 3.0 Si
Reply With Quote
  #170  
Old 09-11-2017, 03:46 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
I just made it. I felt so bad that my CCC didn't show an original screen like CIC. Anyway, everything worked fine except the knob of course as well as the Aux sound for android. It's kinda of having a background noise when you play someting. My next project is going to be retrofitting a CIC which I already have all parts (But original camera didn't work before) and I will use an emulator I received from bimmerretrofit OR I will ask the Chinese friends to make an emulator to operate the follows ( RFK original camera, TV and DVD). I shall order another android screen that supports the CIC and give a try.
Attached Thumbnails
Click image for larger version

Name:	20170912_010907_1505169812809.jpg
Views:	376
Size:	57.2 KB
ID:	663385   Click image for larger version

Name:	20170911_232302_1505169863274.jpg
Views:	358
Size:	42.6 KB
ID:	663393  
__________________
Reply With Quote
  #171  
Old 09-11-2017, 03:57 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Click image for larger version

Name:	20170912_005112.jpg
Views:	446
Size:	40.8 KB
ID:	663401Click image for larger version

Name:	20170911_225842.jpg
Views:	408
Size:	45.2 KB
ID:	663409Click image for larger version

Name:	20170911_230931.jpg
Views:	422
Size:	105.3 KB
ID:	663417Click image for larger version

Name:	20170911_230426.jpg
Views:	412
Size:	102.5 KB
ID:	663425Click image for larger version

Name:	20170912_010835.jpg
Views:	432
Size:	72.4 KB
ID:	663433Click image for larger version

Name:	20170912_005102.jpg
Views:	409
Size:	40.0 KB
ID:	663441

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #172  
Old 09-11-2017, 06:08 PM
BiGJZ74 BiGJZ74 is offline
Registered User
Location: American Canyon, CA
 
Join Date: Aug 2016
Posts: 8
Mein Auto: 2008 BMW X5
Audio when mirroring???

I installed the unit in my X5 today, when i try to use Airplay screen mirroring for my Iphone 7plus running w/ ios 11, the 10.25 inch screen goes blank gray, and audio just crackles and makes popping noises, Bluetooth audio works fine otherwise. Has anyone else had this issue? or know what to troubleshoot. Could it be do to my phone using a beta version of ios11 and not ios 10?

On a side note, does anyone know the password to the DEVELOPERS SETTINGS? in android?
Reply With Quote
  #173  
Old 09-11-2017, 06:11 PM
BiGJZ74 BiGJZ74 is offline
Registered User
Location: American Canyon, CA
 
Join Date: Aug 2016
Posts: 8
Mein Auto: 2008 BMW X5
Is there a way to get Media cover art when using BT Audio?
Reply With Quote
  #174  
Old 09-11-2017, 06:41 PM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
Quote:
Originally Posted by Dubai2013 View Post
I just made it. I felt so bad that my CCC didn't show an original screen like CIC. Anyway, everything worked fine except the knob of course as well as the Aux sound for android. It's kinda of having a background noise when you play someting. My next project is going to be retrofitting a CIC which I already have all parts (But original camera didn't work before) and I will use an emulator I received from bimmerretrofit OR I will ask the Chinese friends to make an emulator to operate the follows ( RFK original camera, TV and DVD). I shall order another android screen that supports the CIC and give a try.
Knob should work well with old CCC controller: Go to Settings -> System Info -> Factory -> Enter 1314 OK -> CCC IDrive Type = iDrive B
Reply With Quote
  #175  
Old 09-11-2017, 08:03 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Quote:
Originally Posted by BiGJZ74 View Post
I installed the unit in my X5 today, when i try to use Airplay screen mirroring for my Iphone 7plus running w/ ios 11, the 10.25 inch screen goes blank gray, and audio just crackles and makes popping noises, Bluetooth audio works fine otherwise. Has anyone else had this issue? or know what to troubleshoot. Could it be do to my phone using a beta version of ios11 and not ios 10?

On a side note, does anyone know the password to the DEVELOPERS SETTINGS? in android?
1314

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
Reply

See More Related BMW Stories

Tags
10.25" ccc e70 android radio


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:08 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.