X5 E70 CCC upgrade to 10.25" Android - Page 8 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #176  
Old 09-11-2017, 08:04 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Quote:
Originally Posted by BiGJZ74 View Post
I installed the unit in my X5 today, when i try to use Airplay screen mirroring for my Iphone 7plus running w/ ios 11, the 10.25 inch screen goes blank gray, and audio just crackles and makes popping noises, Bluetooth audio works fine otherwise. Has anyone else had this issue? or know what to troubleshoot. Could it be do to my phone using a beta version of ios11 and not ios 10?

On a side note, does anyone know the password to the DEVELOPERS SETTINGS? in android?
Ooh sorry, this is not for the developers settings.

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
Sponsored Links
Advertisement
 
  #177  
Old 09-11-2017, 08:05 PM
BiGJZ74 BiGJZ74 is offline
Registered User
Location: American Canyon, CA
 
Join Date: Aug 2016
Posts: 8
Mein Auto: 2008 BMW X5
That is for factory settings not for the android developers settings
Reply With Quote
  #178  
Old 09-11-2017, 08:05 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Quote:
Originally Posted by pplayer View Post
Knob should work well with old CCC controller: Go to Settings -> System Info -> Factory -> Enter 1314 OK -> CCC IDrive Type = iDrive B
Thanks. Will give a try today.

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
Sponsored Links
Advertisement
 
  #179  
Old 09-11-2017, 08:06 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Quote:
Originally Posted by BiGJZ74 View Post
That is for factory settings not for the android developers settings
Yes that's right. Does anyone know the one for Developers Settings? I will also ask the Chinese supplier.

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #180  
Old 09-11-2017, 09:24 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Middle Speaker Plug

Here's a pic of the cable and connection for the middle speaker. It is located behind the screen and under the dash. You can access it once the screen is out. First pic shows it already unplugged ready for me to insert the new cable in between them. Second pic is the label that is attached to cable, you can't miss it.
Attached Thumbnails
Click image for larger version

Name:	image2 (1).JPG
Views:	352
Size:	75.9 KB
ID:	663865   Click image for larger version

Name:	image1 (3).JPG
Views:	347
Size:	110.4 KB
ID:	663873  

Last edited by msan; 09-11-2017 at 09:26 PM.
Reply With Quote
  #181  
Old 09-11-2017, 09:28 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
I just did that last night. What did you do with the cable that you unplugged? Did you connect it to the middle speaker in?

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #182  
Old 09-11-2017, 09:33 PM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Quote:
Originally Posted by msan View Post
Here's a pic of the cable and connection for the middle speaker. It is located behind the screen and under the dash. You can access it once the screen is out. First pic shows it already unplugged ready for me to insert the new cable in between them. Second pic is the label that is attached to cable, you can't miss it.
What did you do with the cable that you unplugged from the middle speaker connector? Did you plug it to the middle speaker in?

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #183  
Old 09-11-2017, 09:34 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Audio Out cable runs

No ones really talked about this part of the install but I had to run the Audio Out cable to my center armrest and the USB plugs out to the passenger footwell. Here's pics. The Audio out plug runs under the center tunnel carpeting up to the armrest. Cables run from the screen down the center, then behind the CIC headunit and down and out the bottom right side. I used a wire coat hanger and brought the USB plug and Audio cable plug up into the headunit area. Pic 2 shows the Audio out cable going straight down into the carpet. Also have the 2 USB wires hanging out for now.
Attached Thumbnails
Click image for larger version

Name:	IMG_8553.JPG
Views:	399
Size:	98.6 KB
ID:	663881   Click image for larger version

Name:	IMG_8554.JPG
Views:	374
Size:	143.7 KB
ID:	663889  

Last edited by msan; 09-11-2017 at 09:35 PM.
Reply With Quote
  #184  
Old 09-11-2017, 09:36 PM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Quote:
Originally Posted by Dubai2013 View Post
What did you do with the cable that you unplugged from the middle speaker connector? Did you plug it to the middle speaker in?

Sent from my SM-G935F using Bimmerfest mobile app
Yes I plugged both in and out from the new cable to the original plugs.
Reply With Quote
  #185  
Old 09-11-2017, 09:41 PM
hotwillz33 hotwillz33 is offline
Registered User
Location: Prairieville, La
 
Join Date: Jun 2007
Posts: 41
Mein Auto: 2009 X5 4.8I, 2000 Vette
Install instructions

Can somebody please provide a DIY? I have purchased the Yokotron version and would like to avoid repeating everyone else's mistakes.
__________________
2002 BMW 745i
2000 Chevy Corvette Convertible
2008 Cadillac Escalade
Reply With Quote
  #186  
Old 09-11-2017, 10:23 PM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
Quote:
Originally Posted by hotwillz33 View Post
Can somebody please provide a DIY? I have purchased the Yokotron version and would like to avoid repeating everyone else's mistakes.
i have a writeup that i am just putting finishing touches on and will have it for you guys very soon in a new post. Also FYI i bought both a MUFL unit and the other unit thinking that was the problem with my aux not working. Turns out they didnt fix it. My AUX just wont work, i think i may need to get a reprogram. I have an appointment to deal with some recalls next week so i think i will have them check that as well.
Reply With Quote
  #187  
Old 09-12-2017, 05:10 AM
hotwillz33 hotwillz33 is offline
Registered User
Location: Prairieville, La
 
Join Date: Jun 2007
Posts: 41
Mein Auto: 2009 X5 4.8I, 2000 Vette
Quote:
Originally Posted by rediahad View Post
i have a writeup that i am just putting finishing touches on and will have it for you guys very soon in a new post. Also FYI i bought both a MUFL unit and the other unit thinking that was the problem with my aux not working. Turns out they didnt fix it. My AUX just wont work, i think i may need to get a reprogram. I have an appointment to deal with some recalls next week so i think i will have them check that as well.
Are both units identical, if not what's the differences? What drawbacks have you noticed? I love the look but wonder what drawbacks there are if any? I purchased the CCC version for my 09 X5.

Any feedback would be appreciated.
__________________
2002 BMW 745i
2000 Chevy Corvette Convertible
2008 Cadillac Escalade
Reply With Quote
  #188  
Old 09-12-2017, 06:47 AM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Quote:
Originally Posted by hotwillz33 View Post
Are both units identical, if not what's the differences? What drawbacks have you noticed? I love the look but wonder what drawbacks there are if any? I purchased the CCC version for my 09 X5.

Any feedback would be appreciated.
I have three concerns based on using the system for one day:

1- Aux sound quality is not clear I don't know why!

2- the glare of the screen is annoying (I ordered anti glare film from amazon) still didn't arrive yet.

3- the CCC interface since it boots from cam. I was hoping to have the CIC interface in the main menu but it's ok for now.

The last thing that I want to check is that sometimes the screen keeps blinking the colors with start-up for like 10 seconds before normal.

Apart from the points above, the upgrade is nice and gives a cool look inside the car.

PS
You will not be pleased with the original camera quality. I recommend purchasing an aftermarket one which will end up with way better quality of the OEM!

The screen comes with RFK option and I beleive that they will be visible with the aftermarket camera, but make sure the camera doesn't have any parking lanes options.


Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #189  
Old 09-12-2017, 06:54 AM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Hello guys,
Does anyone face an issue with flickering screen while booting on a start-up? Any solution for that?

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #190  
Old 09-12-2017, 08:20 AM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
Quote:
Originally Posted by msan View Post
Audio Out cable runs

No ones really talked about this part of the install but I had to run the Audio Out cable to my center armrest and the USB plugs out to the passenger footwell. Here's pics. The Audio out plug runs under the center tunnel carpeting up to the armrest. Cables run from the screen down the center, then behind the CIC headunit and down and out the bottom right side. I used a wire coat hanger and brought the USB plug and Audio cable plug up into the headunit area. Pic 2 shows the Audio out cable going straight down into the carpet. Also have the 2 USB wires hanging out for now.
For me it is not Audio Out as it said. It is actually AUX in which I can connect to my phone 3.5mm jack. I wired it together with 2 USB ports to the glove box in the dash.
Reply With Quote
  #191  
Old 09-12-2017, 08:32 AM
msan msan is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 24
Mein Auto: 2012 X5 35i / 2011 E90 M3
Quote:
Originally Posted by pplayer View Post
For me it is not Audio Out as it said. It is actually AUX in which I can connect to my phone 3.5mm jack. I wired it together with 2 USB ports to the glove box in the dash.
WellI thought It was audio out because I had no sound from the video player but once I plugged it into the aux in in the armrest I had sound from the video playing on my car speakers

Can you share a pic of thegove box with the wires?

Last edited by msan; 09-12-2017 at 08:34 AM.
Reply With Quote
  #192  
Old 09-12-2017, 08:42 AM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71
Quote:
Originally Posted by msan View Post
WellI thought It was audio out because I had no sound from the video player but once I plugged it into the aux in in the armrest I had sound from the video playing on my car speakers

Can you share a pic of thegove box with the wires?
Same here. For me it's an audio out, once I switch to aux sound gets activated.

Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #193  
Old 09-12-2017, 08:44 AM
Dubai2013's Avatar
Dubai2013 Dubai2013 is offline
Officially Welcomed to the 'Fest
Location: Dubai
 
Join Date: Mar 2013
Posts: 122
Mein Auto: F01 & E71


Sent from my SM-G935F using Bimmerfest mobile app
__________________
Reply With Quote
  #194  
Old 09-12-2017, 09:54 AM
604nguyen 604nguyen is offline
Registered User
Location: Vancouver BC
 
Join Date: Jan 2014
Posts: 25
Mein Auto: 2009 X5 4.8i
Does the screen compensate for ambient light levels? IE. Dim when it's dark out, brightens when it's bright out? Also does the dimmer switch on the headlight controls have any control over the screen brightness?
Reply With Quote
  #195  
Old 09-12-2017, 09:57 AM
IvanBux IvanBux is offline
Registered User
Location: Russia
 
Join Date: Sep 2013
Posts: 6
Mein Auto: BMW X5 E70LCI MY2011
Yes, it dims when you turn on the light

Last edited by IvanBux; 09-12-2017 at 10:03 AM.
Reply With Quote
  #196  
Old 09-12-2017, 01:02 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,006
Mein Auto: 2009 X5
Quote:
Originally Posted by rediahad View Post
i have a writeup that i am just putting finishing touches on and will have it for you guys very soon in a new post. Also FYI i bought both a MUFL unit and the other unit thinking that was the problem with my aux not working. Turns out they didnt fix it. My AUX just wont work, i think i may need to get a reprogram. I have an appointment to deal with some recalls next week so i think i will have them check that as well.
Hopefully you will have the write-up ready by this weekend. I have this unit for 2-3 weeks now and finally this coming weekend is the only time I have to install it. Looking forward for a write-up!
Reply With Quote
  #197  
Old 09-12-2017, 11:38 PM
BiGJZ74 BiGJZ74 is offline
Registered User
Location: American Canyon, CA
 
Join Date: Aug 2016
Posts: 8
Mein Auto: 2008 BMW X5
Here are some photos, I have the Yokotron version, ( I think they might be the manufacturer in China) I spoke with one of the techs and found out that the Developers password i was looking for is proprietary for their software engineers only and not for the public. I did notice that the Airplay ScreenMirroring for the Iphone 7+ with IOS10 only covers about 2/3's of the screen when in landscape mode....wondering if there will be a fix for that, gonna send them another message. I also included a few pics of my previous install, an 8.8" bimmertech Vivid screen I retrofitted for my X5 which included a Multimedia interface and Apple TV3. I also informed Yokotron of the issues I had trying to mirror with a beta version of IOS11 and they said they were unaware but would get a beta copy and be looking into a fix for it since the release ios11 coming up soon.

Overall I am happy with the install. I do wish they had some Audio/video in inputs or HMDI connections. When listening to BT audio while using the Android nav feature I have yet to figure out how to turn down the Volume of the GPS voice. There is a volume setting for GPS volume but that only affects the original GPS voice. If you listen to music a a high level, GPS sounds like screaming. I ran the Aux cable underneath the passenger side wood trim, and the 2 USB ports into the glove box....Tommy at Avin said they would have a USB Front DVR camera available on their website in the next week or so. I am probably going to get Carplay as I assume you would get full screen as opposed to the Mirroring partial screen I get now, plus I hope you can probably get Media cover Art with car play using apps since you don't get Media Art using BT AUDIO.

The only thing I find lacking in the unit is the ability to connect other Mutlimedia Inputs, RCA's etc. RCA's to 3.5mm out i think may have been better...3.5mm or seems like it may be Mono and not stereo. I was hoping I could find a way to attach my Multimedia inteface to it as well as apple TV but I do not think that there is a way...I may try to attach the LVDS in that Goes in to the Monitor into the MMI then attach the LVDS out in MMI to the Monitor and see if it works. Unsure of audio though...since both would need the aux in port in the glove box for sound. If you use a splitter, the signal strength will be bad with one connection. If I can't figure it out, I'll be selling the 8.8" HD VividScreen, MMI interface and Apple TV3.

Hopefully this will hold me over with my Tech addiction until I get a full NBT EVO-touch retrofit.
Attached Thumbnails
Click image for larger version

Name:	FD54951A-1901-4C3E-A151-F652C0D22A37.jpg
Views:	314
Size:	45.8 KB
ID:	664401   Click image for larger version

Name:	E9B31505-493D-42F2-A085-3981756576AC.jpg
Views:	293
Size:	55.6 KB
ID:	664409   Click image for larger version

Name:	C9562558-9624-4121-9D4D-7E2EA1840853.jpg
Views:	304
Size:	54.5 KB
ID:	664417   Click image for larger version

Name:	AFEC85DC-8B6D-413A-888A-47728A5A60B2.jpg
Views:	297
Size:	44.0 KB
ID:	664425   Click image for larger version

Name:	81E51B36-24AC-495F-A7E9-FD0897C32BEC.jpg
Views:	286
Size:	48.7 KB
ID:	664441  

Click image for larger version

Name:	78511FAB-B5F0-4EBB-974B-889C973E9A08.jpg
Views:	281
Size:	69.9 KB
ID:	664449   Click image for larger version

Name:	75979B20-8864-47C1-BE2C-CF8D67E33CF0.jpg
Views:	282
Size:	53.5 KB
ID:	664457   Click image for larger version

Name:	451FA98B-C5A7-4FCB-BD42-9C33347970D6.jpg
Views:	274
Size:	56.7 KB
ID:	664465   Click image for larger version

Name:	4413C8AF-1B3A-4F33-8E9D-113C0B138C45.jpg
Views:	274
Size:	48.5 KB
ID:	664473   Click image for larger version

Name:	0962AC4D-4B4A-43CF-9588-B7B2C0F652E7.jpg
Views:	303
Size:	68.2 KB
ID:	664481  

Click image for larger version

Name:	499A6CE9-3FF4-4E0E-BF2D-7AE9CE65947D.jpg
Views:	283
Size:	47.4 KB
ID:	664489   Click image for larger version

Name:	47AB7498-F23D-4428-90DD-F4515B2BF33A.jpg
Views:	284
Size:	78.8 KB
ID:	664497   Click image for larger version

Name:	037A2398-D1C5-4BF5-8B20-4025B6F1ED6E.jpg
Views:	268
Size:	66.6 KB
ID:	664505   Click image for larger version

Name:	9B195E95-0E3A-4AAE-9C06-0144DD24CAD9.jpg
Views:	280
Size:	73.4 KB
ID:	664513   Click image for larger version

Name:	8D0997DB-FC6D-444C-99CA-0C20C8BD2F69.jpg
Views:	254
Size:	43.1 KB
ID:	664521  

Click image for larger version

Name:	2F9243EA-0EF2-4D14-A0A3-0C516A4AD3EA.jpg
Views:	261
Size:	55.0 KB
ID:	664529   Click image for larger version

Name:	624C48C5-5467-45A9-B63E-3D51EC10E9E1.jpg
Views:	323
Size:	96.9 KB
ID:	664545   Click image for larger version

Name:	5A547C18-7BB9-4E85-81F2-95C54A8BA6B9.jpg
Views:	268
Size:	105.4 KB
ID:	664553   Click image for larger version

Name:	76213687-130F-42BE-B2F0-E909AC9FC79A.jpg
Views:	294
Size:	117.8 KB
ID:	664561  
Reply With Quote
  #198  
Old 09-13-2017, 10:29 AM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Quote:
Originally Posted by ill_kuma View Post
Hopefully you will have the write-up ready by this weekend. I have this unit for 2-3 weeks now and finally this coming weekend is the only time I have to install it. Looking forward for a write-up!
What year is your car? I can help you if you're close by.
__________________
2007 X5 3.0 Si
Reply With Quote
  #199  
Old 09-13-2017, 12:34 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,006
Mein Auto: 2009 X5
Quote:
Originally Posted by noelskii View Post
What year is your car? I can help you if you're close by.
It is a 2009 with the CCC unit. I am in Douglaston...its 10-15 mins from the Throgs Neck in the Queens side.
Reply With Quote
  #200  
Old 09-13-2017, 12:47 PM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Quote:
Originally Posted by ill_kuma View Post
It is a 2009 with the CCC unit. I am in Douglaston...its 10-15 mins from the Throgs Neck in the Queens side.
I'm right over that bridge in the Bronx. Lmk if you wanna cross over one of these days.
__________________
2007 X5 3.0 Si
Reply With Quote
Reply

See More Related BMW Stories

Tags
10.25" ccc e70 android radio


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.