Reverse Lights, MID Radio, Turn Signals All Not Working - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-01-2019, 12:07 AM
Raviosaur11 Raviosaur11 is offline
Registered User
 
Join Date: Dec 2019
Posts: 1
Mein Auto:
Reverse Lights, MID Radio, Turn Signals All Not Working

Hey all,

Lately I've been having this issue with my 2003 530i in which when I shift into reverse, the reverse lights don't turn on. This happens randomly, where sometimes they'll turn on and other times they don't.

When the reverse lights fail to turn on, other problems happen simultaneously too; the MID radio will go black and turn off, after which it produces no sound (effectively making it dead). The turn signals will also not register in the cluster, though they do show on the outside of the car.

All of these issues seem to be linked in some way where if one happens, sure enough the others are present too. All of this happens randomly - sometimes they'll not be working when I turn the car on, sometimes they'll all cut out in the middle of me driving, and sometimes they all return in the middle of me driving!

Any idea what this could be?

Thanks all in advance.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-01-2019, 01:34 AM
528iAut 528iAut is offline
Officially Welcomed to the 'Fest
Location: Moraira, Spain
 
Join Date: May 2016
Posts: 2,208
Mein Auto: 1996 528i
Try and do the ignition switch test, just search for it.
__________________
E39 528i Steptronic 1996, Comfort seats, Rear sunshade, Focal amplifier and front speakers, Oxford Green.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:33 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.