2009 560 E63 I controller knob - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2004 - 2010)

E63 / E64 6 Series (2004 - 2010)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-23-2019, 03:07 PM
Newbimmerguy19 Newbimmerguy19 is offline
Registered User
 
Join Date: Jul 2019
Posts: 9
Mein Auto:
2009 560 E63 I controller knob

I bought this car used and the you can rotate the knob on the I controller and move through various menu items . The only problem is when you Cannot select any menu option by pushing down on the controller knob. Is there a fix for this ? Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-25-2019, 11:00 AM
Hsurf's Avatar
Hsurf Hsurf is offline
Super Moderator
Location: East Sussex
 
Join Date: May 2015
Posts: 1,581
Mein Auto: E63 645ci
I personally only remember this being posted about once and that was fixed by a new controller, I'd first though try resetting the CIC which I believe is simply a case of pressing in and holding the volume control knob for around 15 to 20 seconds, just to make sure the system isn't stuck somewhere.
If it were me I'd also run the codes to see if anything pops up (unlikely) and pull the centre console to make sure there's no loose connections on the wiring before spending out on a controller, I'm sure someone here will have some better solutions .
__________________

Neal.
_________________
E63 645Ci
Toyota Hilux Surf 3.0
Honda CBR1100XX
_________________
Reply With Quote
  #3  
Old 08-26-2019, 05:34 AM
Newbimmerguy19 Newbimmerguy19 is offline
Registered User
 
Join Date: Jul 2019
Posts: 9
Mein Auto:
Thank You for the information. I tried pushing the control knob and resetting the system. System still has the same issue. I have to take the car in soon for state inspection I will have them scan for codes . Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 08-27-2019, 03:28 AM
Hsurf's Avatar
Hsurf Hsurf is offline
Super Moderator
Location: East Sussex
 
Join Date: May 2015
Posts: 1,581
Mein Auto: E63 645ci
I'd highly recommend you get ISTA either from ebay/dedicated supplier or downloaded from the programming and coding forum, even if your not a "hands on" kind of owner and the car always goes to a garage for repairs at least you'll be able to run any codes and get a heads up on exactly what's involved and basic costs of what your looking at before the car goes in.
Getting to the controller can be a fit of a faff and if your not used to taking the car apart I couldn't blame you for wanting to hand it over to a garage but if this doesn't turn out to be something simple then it may get a bit expensive as the labour may push the costs up quite a bit.
__________________

Neal.
_________________
E63 645Ci
Toyota Hilux Surf 3.0
Honda CBR1100XX
_________________
Reply With Quote
  #5  
Old 08-27-2019, 06:50 AM
Newbimmerguy19 Newbimmerguy19 is offline
Registered User
 
Join Date: Jul 2019
Posts: 9
Mein Auto:
Thanks for the Info. I'll give that a shot .
Reply With Quote
  #6  
Old 08-27-2019, 07:17 AM
roseng's Avatar
roseng roseng is offline
Officially Welcomed to the 'Fest
Location: Calabasas, CA
 
Join Date: Apr 2006
Posts: 2,351
Mein Auto: 2016 528i + 2007 650 Vert
If you do need to replace the controller it's not hard to remove the center console, and used controllers re available on eBay.
__________________

I Love LA. It lets me ride in the winter with the top down.
07' E64/Black....14' F10/M-Sport White
Reply With Quote
  #7  
Old 08-27-2019, 04:45 PM
HerbP HerbP is offline
Super Moderator
Location: Georgia
 
Join Date: Jul 2009
Posts: 6,824
Mein Auto: 05 645Ci, 14 750 M-Sport
Quote:
Originally Posted by Newbimmerguy19 View Post
Thank You for the information. I tried pushing the control knob and resetting the system. System still has the same issue. I have to take the car in soon for state inspection I will have them scan for codes . Thanks
The state can't run codes for the IDrive.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.