X5 E70 CCC upgrade to 10.25" Android - Page 4 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #76  
Old 08-08-2017, 03:42 PM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
it's a 2007 4.8i and both the usb and aux dont work. Also interesting my bluetooth in the car never worked either. sounds like a mulf issue correct? also radio is the base one nothing special, the car didnt come with navi or backup cam
Reply With Quote
Sponsored Links
Advertisement
 
  #77  
Old 08-08-2017, 03:49 PM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Quote:
Originally Posted by rediahad View Post
it's a 2007 4.8i and both the usb and aux dont work. Also interesting my bluetooth in the car never worked either. sounds like a mulf issue correct? also radio is the base one nothing special, the car didnt come with navi or backup cam
USB and AUX that's straight from the back of the AVIN radio?
Reply With Quote
  #78  
Old 08-08-2017, 03:54 PM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
no, it's the aux that is in the armrest of the x5. i plugged the avin into a separate speaker and it works fine. that is why i am assuming it could be a mulf issue. my sos fault has been on for the passed year and i never actually used the usb or aux before to test them out but they are also not working also bluetooth isn't working. that is the faulty mulf trifecta....errrr quadfecta? either way you know what i mean.
Reply With Quote
Sponsored Links
Advertisement
 
  #79  
Old 08-08-2017, 09:14 PM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
i installed it and most things work( the rest are prob just settings). However, where does the original plug that was plugged in to the original display go to? DOes it just hang? Lol
Reply With Quote
  #80  
Old 08-08-2017, 10:17 PM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
Quote:
Originally Posted by noelskii View Post
i installed it and most things work( the rest are prob just settings). However, where does the original plug that was plugged in to the original display go to? DOes it just hang? Lol
thats a good question, one that i had myself as well. i just left it hanging out in the back and havent seen anything that would lead me to believe that it goes to anything. Does anyone know whether aux in is run off the tcu or the mulf unit?
Reply With Quote
  #81  
Old 08-09-2017, 08:38 AM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,002
Mein Auto: 2009 X5
Seems like there is a lot of questions. Did the unit come with installation instructions? Did you guys contacted the seller? I am waiting for my unit and not sure if I even want it anymore.
Reply With Quote
  #82  
Old 08-09-2017, 09:20 AM
5XTHEPROBLEMS 5XTHEPROBLEMS is offline
Registered User
Location: Atlanta
 
Join Date: Apr 2017
Posts: 26
Mein Auto: 2008 BMW X5
No install directions, but the install is very easy. I used a few YouTube videos to guide me:

Screen removal--

I-drive unit removal to attach new cables behind unit-- or

Mounting spot for new GPS antenna (same spot as the 3series shown in this video)--

I only had the one issue: with my SOS malfunction and Sat radio not working. That is most likely related to not plugging the green wire tightly.

I had no technical issues in my car beforehand, and everything worked just fine after install. PM if you need additional help. I am unable to do a write-up for install, since I am going to be out of the country until the 22nd. I can do one afterward (if no one has done one by then).
Reply With Quote
  #83  
Old 08-09-2017, 09:40 AM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,002
Mein Auto: 2009 X5
Quote:
Originally Posted by 5XTHEPROBLEMS View Post
No install directions, but the install is very easy. I used a few YouTube videos to guide me:

Screen removal--

I-drive unit removal to attach new cables behind unit--

Mounting spot for new GPS antenna (same spot as the 3series shown in this video)--

I only had the one issue: with my SOS malfunction and Sat radio not working. That is most likely related to not plugging the green wire tightly.

I had no technical issues in my car beforehand, and everything worked just fine after install. PM if you need additional help. I am unable to do a write-up for install, since I am going to be out of the country until the 22nd. I can do one afterward (if no one has done one by then).
Thank you so much. This will definitely be useful. Did anyone buy an aftermarket camera to use with this unit? If so, which camera did you guys get?
Reply With Quote
  #84  
Old 08-09-2017, 10:28 AM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
Quote:
Originally Posted by ill_kuma View Post
Thank you so much. This will definitely be useful. Did anyone buy an aftermarket camera to use with this unit? If so, which camera did you guys get?
i bought the latch handle camera add on from avinusa, i like it. i will post pics and a writeup tonight after work.
Reply With Quote
  #85  
Old 08-09-2017, 10:41 AM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,002
Mein Auto: 2009 X5
Quote:
Originally Posted by rediahad View Post
i bought the latch handle camera add on from avinusa, i like it. i will post pics and a writeup tonight after work.
A write-up would be much appreciated. Especially which is the reverse light wire will you need to tap into and how to get power for the backup camera. The only reason I didnt buy that one is because its the latch handle one. I have the hole in my X5 (currently cover by a piece of plastic) for it already and feel it would look more OEM if I can get a camera to match that hole instead.

Last edited by ill_kuma; 08-09-2017 at 10:43 AM.
Reply With Quote
  #86  
Old 08-09-2017, 11:12 AM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
Quote:
Originally Posted by ill_kuma View Post
A write-up would be much appreciated. Especially which is the reverse light wire will you need to tap into and how to get power for the backup camera. The only reason I didnt buy that one is because its the latch handle one. I have the hole in my X5 (currently cover by a piece of plastic) for it already and feel it would look more OEM if I can get a camera to match that hole instead.
To me the latch is actually an improvement because it feels better and softer than original, and the harness comes with the both the plugs you need to give power and video to your camera, no need to tap into anything.
Reply With Quote
  #87  
Old 08-09-2017, 11:27 AM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
Also another thing I noticed, i ordered for a 6.5 inch CCC setup and my idrive knob doesn't work. It will go exactly one tile the opposite way and thats it. Perhaps a CIC upgrade is in order?
Reply With Quote
  #88  
Old 08-09-2017, 12:17 PM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Quote:
Originally Posted by rediahad View Post
Also another thing I noticed, i ordered for a 6.5 inch CCC setup and my idrive knob doesn't work. It will go exactly one tile the opposite way and thats it. Perhaps a CIC upgrade is in order?
I have the lowest of the lowest CCC setup. The iDrive knob works perfectly fine for me in the 'Original Car' screen. It also works a little on the droid screen. Just gotta work out a few kinks here and there, but the display quality is fiyaa (when it's not on the 'OC' (original car) menu!!

Right now I'm just trying to figure out a final place (and how to fish out) the 2 dual USB inputs and the AUX input. I'm thinking glove, but I don't see any firewalls to fish it out through. And where to mount the GPS antenna (gotta watch that video link posted above).
__________________
2007 X5 3.0 Si
Reply With Quote
  #89  
Old 08-09-2017, 12:23 PM
ninja_zx11 ninja_zx11 is offline
Officially Welcomed to the 'Fest
Location: Vancouver,Canada
 
Join Date: Feb 2014
Posts: 734
Mein Auto: 2009 X5 35D
Quote:
Originally Posted by noelskii View Post
but the display quality is fiyaa (when it's not on the 'OC' (original car) menu!!.
I think one can have better resolution in the car mode if you had 8.5" screen previously.If you had 6.5" then i think new screen just stretch it out.If thats the case then i believe CCC can be coded to 8.5" screen so that CCC outputs full size picture.Just guessing.
__________________


Reply With Quote
  #90  
Old 08-09-2017, 12:43 PM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
Quote:
Originally Posted by noelskii View Post
I have the lowest of the lowest CCC setup. The iDrive knob works perfectly fine for me in the 'Original Car' screen. It also works a little on the droid screen. Just gotta work out a few kinks here and there, but the display quality is fiyaa (when it's not on the 'OC' (original car) menu!!

Right now I'm just trying to figure out a final place (and how to fish out) the 2 dual USB inputs and the AUX input. I'm thinking glove, but I don't see any firewalls to fish it out through. And where to mount the GPS antenna (gotta watch that video link posted above).
of course knob is going to work the same in the original menu. in the back of your glove compartment the plastic panel comes off, then you can send the usb cables through there. Once i'm done with my writeup you will see pics
Reply With Quote
  #91  
Old 08-09-2017, 01:14 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,002
Mein Auto: 2009 X5
Quote:
Originally Posted by rediahad View Post
of course knob is going to work the same in the original menu. in the back of your glove compartment the plastic panel comes off, then you can send the usb cables through there. Once i'm done with my writeup you will see pics
I am planning to route the USB cables into the glove compartment as well. Let me know if you or anyone can find a way to mount the USBs instead of letting it dangle in there.
Reply With Quote
  #92  
Old 08-09-2017, 01:48 PM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Quote:
Originally Posted by rediahad View Post
of course knob is going to work the same in the original menu. in the back of your glove compartment the plastic panel comes off, then you can send the usb cables through there. Once i'm done with my writeup you will see pics
I have a 6 cd changer in there and iit sucks cause I have to break off the clips to remove the surrounding panel. I'll probably do it anyway...

Also adding one of these on the passenger side kick panel or completely replace the cig lighter with it:

https://www.amazon.com/USB-Mount-Cab...lush+mount+kit
__________________
2007 X5 3.0 Si
Reply With Quote
  #93  
Old 08-09-2017, 02:04 PM
rediahad rediahad is offline
Registered User
Location: Sac
 
Join Date: Dec 2009
Posts: 33
Mein Auto: 330ci
Quote:
Originally Posted by noelskii View Post
I have a 6 cd changer in there and iit sucks cause I have to break off the clips to remove the surrounding panel. I'll probably do it anyway...

Also adding one of these on the passenger side kick panel or completely replace the cig lighter with it:

https://www.amazon.com/USB-Mount-Cab...lush+mount+kit
there are plenty of options for those on the internet, i just searched usb port for car. i ordered a couple of them off ebay so i just drill a hole and then mount them onto the plastic for a clean look
Reply With Quote
  #94  
Old 08-09-2017, 04:16 PM
X5Dinosaur X5Dinosaur is offline
Registered User
Location: Chicago
 
Join Date: Feb 2017
Posts: 79
Mein Auto: X5D
looks like this might be the same unit? $469.99 shipped rebranded mcwauto (LOL) has more features too, door open indicator headlight indicator etc

https://www.amazon.com/dp/B074DWGPT6

Last edited by X5Dinosaur; 08-09-2017 at 04:24 PM.
Reply With Quote
  #95  
Old 08-09-2017, 04:23 PM
ill_kuma's Avatar
ill_kuma ill_kuma is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jan 2007
Posts: 1,002
Mein Auto: 2009 X5
Quote:
Originally Posted by rediahad View Post
there are plenty of options for those on the internet, i just searched usb port for car. i ordered a couple of them off ebay so i just drill a hole and then mount them onto the plastic for a clean look
What did you have in mind?

This USB panel is perfect for us. Just needs an AUX but not as important to me since I have AUX in my center console.

When you install the backup camera, can you document what wire needs to go where and some pics?

Last edited by ill_kuma; 08-09-2017 at 05:44 PM.
Reply With Quote
  #96  
Old 08-09-2017, 06:10 PM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Just fished the 2 USB and 1 Aux to the glove- easier than I thought. Hooked up my back up camera. Camera was easy since I already had an AM LCD on top of my rearview mirror. All I had to do was fish the video cable through the glove.

AVIN also just emailed me some quick startup guides with some instructions... see attached.
__________________
2007 X5 3.0 Si
Reply With Quote
  #97  
Old 08-10-2017, 05:02 PM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
A bit confuse about the AUX and USB. We originally have one USB and AUX under the armrest. With this unit I see there are 2 USB and a AUX coming out from it. So now we have 3 USB and 2 AUX in total. Or we have to connect them together so finally we only have 2 USB and 1 AUX?
Reply With Quote
  #98  
Old 08-10-2017, 06:36 PM
noelskii noelskii is offline
Officially Welcomed to the 'Fest
Location: Bronx, NY
 
Join Date: Aug 2014
Posts: 232
Mein Auto: E70
Quote:
Originally Posted by pplayer View Post
A bit confuse about the AUX and USB. We originally have one USB and AUX under the armrest. With this unit I see there are 2 USB and a AUX coming out from it. So now we have 3 USB and 2 AUX in total. Or we have to connect them together so finally we only have 2 USB and 1 AUX?
The ones that come with the new unit are all additional...for me at least. I don't have USB in my armrest, only AUX. now I have 2 aux and 2 USB.
__________________
2007 X5 3.0 Si
Reply With Quote
  #99  
Old 08-10-2017, 07:47 PM
pplayer pplayer is offline
Registered User
Location: Vietnam
 
Join Date: May 2017
Posts: 58
Mein Auto: BMW X5 E70
Quote:
Originally Posted by noelskii View Post
The ones that come with the new unit are all additional...for me at least. I don't have USB in my armrest, only AUX. now I have 2 aux and 2 USB.
Thanks for the confirmation. Waiting for my unit to arrive
Reply With Quote
  #100  
Old 08-11-2017, 06:23 PM
lalit.sis lalit.sis is offline
Registered User
Location: Perth
 
Join Date: Aug 2017
Posts: 11
Mein Auto: E70
Hi guys, m tempted to install this unit just because my 2008 3.0sd already had a sos call failure and my aux n reverse camera not working. Need to replace bluetooth module which would be hefty $450 aud!! So would rather install this unit but unsure if all functions will work incl reverse camera with the this annoying error. Any suggestions guys?


Sent from my iPhone using Bimmerfest
Reply With Quote
Reply

See More Related BMW Stories

Tags
10.25" ccc e70 android radio


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:33 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.