Drive Train Malfunction Message - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > G30 (2017 - Current)

G30 (2017 - Current)
The next generation 5 Series, chassis code G30, arrives at dealers in February 2017. Looking like a scaled down 7 Series and riding on the CLAR platform, the new 5 Series will have a focus on lightweight and sporty performance. Engines options will come from BMW's new B family for the 530 and 540 and a turbocharged V8 for the M550i. Read more about the 2017 5 Series

Reply
 
Thread Tools Display Modes
  #1  
Old 09-01-2019, 03:57 PM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Drive Train Malfunction Message

Hi all,
Newbie here! My husband and I bought an used 2019 540i last week, 10k miles, CPO with the convenience and premium packages. The price was good for us. Fast forward to this week and we are having a couple of issues.

Problems with BMW Connected - Can't connect. This doesn't worry me too much.

We installed a GPS tracker called Automatic and from this point a bunch of messages are popping up. Not sure if this is related to the GPS tracker interfering with the car computer or something more serious. The Automatic website says that 540i's are compatible with this device. This device goes into the OBD port. GPS tracker was removed.

Problems:
Alarm going off when locking the car. Happened twice. Hasn't happened since the Automatic GPS device that was in the OBD port, was removed.
Check engine light on. This comes and goes.
XM Radio doesn't load
Navigation system always stays on the loading message and never loads

List of messages:
Drive train malfunction message
Driving assist cannot be activated
To engage gear, press brake

At this point I'm freaking out and don't want to drive the car. I already made an appointment with BMW for service but this may take a while due to hurricane Dorian.

Could it be possible that the GPS tracker fried something? Or something else is going on here? The car drives and feels fine according to my husband.

I'm just bummed since this is the car of our dreams and already having some issues.

Thanks!

Last edited by mayene; 09-01-2019 at 03:58 PM.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-01-2019, 04:13 PM
Phas Phas is offline
Registered User
Location: Great White North
 
Join Date: Mar 2014
Posts: 98
Mein Auto: 2018 540i xDrive
I think this thread(starting from #10) maybe able to shed some light on your problem.
https://www.bimmerfest.com/forums/sh....php?t=1302615
It would appear that others are having varied problems with items plugged into the OBD port.
Other posters maybe able to address your specific issue, however, based on the above thread, it would appear that plugging into the OBD port could be the root of the issue.
Hope that helps.
Cheers
__________________
“Never argue with an idiot. They will only bring you down to their level and beat you with experience.”

George Carlin
Reply With Quote
  #3  
Old 09-01-2019, 04:27 PM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Quote:
Originally Posted by Phas View Post
I think this thread(starting from #10) maybe able to shed some light on your problem.
https://www.bimmerfest.com/forums/sh....php?t=1302615
It would appear that others are having varied problems with items plugged into the OBD port.
Other posters maybe able to address your specific issue, however, based on the above thread, it would appear that plugging into the OBD port could be the root of the issue.
Hope that helps.
Cheers
Hi Phas,
Thanks for your reply! I found this thread and replied to it hoping to find out if the OP solved the issue and how. In his case, it was an insurance driving pattern tracking GPS device which is similar to ours but we don't used it for insurance purposes. I'm just worried that BMW service will say that the warranty is voided or some sort of crap.

Lesson learned here: never plug in anything to your OBD port unless you are a 150% it won't break your car. Ugh!
Thanks!
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 09-02-2019, 09:04 AM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Update:
Went to turn on the car this morning and the car is dead and asking to pair the remote with the key icon under the steering wheel. Fun times! At least is inside the garage so it will be protected from the hurricane winds. I will update this once is taken to the dealer.
Reply With Quote
  #5  
Old 09-02-2019, 10:13 AM
luigi524td luigi524td is online now
Officially Welcomed to the 'Fest
Location: The State of Southern NJ
 
Join Date: Apr 2005
Posts: 3,966
Mein Auto: '17 540xDrive; '98 Z3 2.8
I wouldn't mention anything about the OBD "tracker" you temporarily installed - otherwise they might deny WARRANTY coverage.
IF YOUR INSURANCE COMPANY is "promoting" these devices they should be warned they may be causing (permanent) damage to newer model cars (esp BMW's ??).

BTW - I used an android app on my Samsung phone that provides similar driver feedback ... but after a while I decided that I wasn't going to drive as ultra-conservatively as it was trying to promote. So I just deleted it ... without the side-benefit of frying any of my BMWs electronics!
__________________
My opinions are free - you'll get exactly what you pay for!
Current: '17 540 xDrive | '13 X1 MSport | '98 Z3 2.8
Past: '13 535xDrive|'07 530xi|'01 740i|'98 740i|'94 740i |'86 524TD
"Seek and ye shall find" - start with your owner's manual!


Click on the MrRebates logo/link for cash back savings at on-line stores like Tirerack!Mr. Rebates

Last edited by luigi524td; 09-02-2019 at 10:17 AM.
Reply With Quote
  #6  
Old 09-02-2019, 10:19 AM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Quote:
Originally Posted by luigi524td View Post
I wouldn't mention anything about the OBD "tracker" you temporarily installed - otherwise they might deny WARRANTY coverage.
BUT I WOULD DEFINITELY NOTIFY YOUR INSURANCE COMPANY that the devices they are "promoting" may be causing permanent damage to newer model cars (esp BMW's ??)
Hi Luigi!
Thanks for the tip I will definitely notify the company that sells this tracker and service, (which is called Automatic and owned by Sirius XM)about this. We used it for diagnostics in our 2015 Lexus and not for insurance purposes. Then was planning to use it for the same purpose on our Bimmer. In the Automatic website they say that it's compatible with 2019 BMW's 540i. I still cannot believe that this little thing will cause all this. My goodness!

Last edited by mayene; 09-02-2019 at 10:25 AM. Reason: Added more details
Reply With Quote
  #7  
Old 09-02-2019, 10:25 AM
luigi524td luigi524td is online now
Officially Welcomed to the 'Fest
Location: The State of Southern NJ
 
Join Date: Apr 2005
Posts: 3,966
Mein Auto: '17 540xDrive; '98 Z3 2.8
My insurance company promotes a similar device for a discount on premiums but DOES NOT recommend it for "newer" cars - would only allow me to use it on my '98 Z3. I only drive that car a few hundred miles a year and the premium is so low I didn't feel an insurance "nanny" device was worth it.
__________________
My opinions are free - you'll get exactly what you pay for!
Current: '17 540 xDrive | '13 X1 MSport | '98 Z3 2.8
Past: '13 535xDrive|'07 530xi|'01 740i|'98 740i|'94 740i |'86 524TD
"Seek and ye shall find" - start with your owner's manual!


Click on the MrRebates logo/link for cash back savings at on-line stores like Tirerack!Mr. Rebates
Reply With Quote
  #8  
Old 09-02-2019, 11:26 AM
Bebespapa Bebespapa is offline
Officially Welcomed to the 'Fest
Location: NW Wisconsin
 
Join Date: Aug 2017
Posts: 112
Mein Auto: 2014 428 GC
Your XM may have expired. They come with one year. CPOs usually have some period added on, but not always.
Take that gps device and throw it in the trash. I would never mess with anything that plugs into the ODB port. I would say your ODB thing messed up some thing in your body computer. The company you got it from might not even tried it in your model car. I would hold them responsible.
Your owner manual should tell you how to change the fob battery. Depends on the cars in service date.
Did you get a car fax report? Anything odd on it?
I hope Bmw gets it sorted out for you. It should be great car.
__________________
In the Great North...

2018 530e Xdrive
2015 428I Xdrive - sold
2011 X3 35I - sold
2017 Honda Ridgeline. Gotta have a truck.

Last edited by Bebespapa; 09-02-2019 at 11:41 AM.
Reply With Quote
  #9  
Old 09-02-2019, 11:26 AM
BobinIl BobinIl is online now
Officially Welcomed to the 'Fest
Location: Illinois
 
Join Date: Oct 2014
Posts: 842
Mein Auto: 2019 X3 Black Sapphire
Quote:
Originally Posted by mayene View Post
Update:
Went to turn on the car this morning and the car is dead and asking to pair the remote with the key icon under the steering wheel. Fun times! At least is inside the garage so it will be protected from the hurricane winds. I will update this once is taken to the dealer.
It might not be the same issue, but we've had this happen a couple of times with our car. The fob isn't being recognized and nothing happens. I've found it works to lock and unlock the car from the outside and that seems to reset things (maybe security related?) and things work as normal.
__________________
2019 G01/Black Sapphire/Canberra Beige Vernasca Leather
2019 G30/Bluestone Metallic/Ivory White Leather
Reply With Quote
  #10  
Old 09-02-2019, 11:35 AM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Quote:
Originally Posted by Bebespapa View Post
Your XM may have expired. They come with one year. CPOs usually have some period added on, but not always.
Take that gps device and throw it in the trash. I would never mess with anything that plugs into the ODB port. I would say your ODB thing messed up some thing in your body computer. The company you got it from might not even tried it in your model car. I would hold them responsible.
Your owner manual should tell you how to change the fob battery. Depends on the cars in service date.
Did you get a car fax report? Anything odd on it?
Hi Bebespapa!

Thanks for your reply. That thing is already in the trash! I will contact Automatic about this for sure. We call BMW assist and they were able to start the car so at least is running. Taking it for service ASAP or when weather permits. We may have to have it towed to the service center.

I checked the CarFax report and nothing out of the ordinary there.
Reply With Quote
  #11  
Old 09-02-2019, 11:36 AM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Quote:
Originally Posted by BobinIl View Post
It might not be the same issue, but we've had this happen a couple of times with our car. The fob isn't being recognized and nothing happens. I've found it works to lock and unlock the car from the outside and that seems to reset things (maybe security related?) and things work as normal.
Thanks for your reply!
Good to know that this could happen to us as well.
Once the car was jumped started the key fobs worked again.
Reply With Quote
  #12  
Old 09-02-2019, 12:37 PM
BradN BradN is offline
Officially Welcomed to the 'Fest
Location: Davenport, IA
 
Join Date: Jan 2018
Posts: 256
Mein Auto: 2018 530e xDrive
I've had my '18 in twice for really weird codes and electrical behavior. They finally replaced a "control module" and I haven't had any problems since. I had not plugged in any foreign devices.

Be safe down there!! Where are you in Florida?
__________________
2018 530e xDrive M sport Black Sapphire - Current
2015 535i xDrive Alpine White - Gone
2012 535i xDrive Graphite - Gone


If at first you don't succeed, maybe skydiving isn't for you!
Reply With Quote
  #13  
Old 09-02-2019, 02:19 PM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Quote:
Originally Posted by BradN View Post
I've had my '18 in twice for really weird codes and electrical behavior. They finally replaced a "control module" and I haven't had any problems since. I had not plugged in any foreign devices.

Be safe down there!! Where are you in Florida?
Good to know and that you were able to solve the issue! We are in the central part of FL
Reply With Quote
  #14  
Old 09-02-2019, 05:16 PM
BobinIl BobinIl is online now
Officially Welcomed to the 'Fest
Location: Illinois
 
Join Date: Oct 2014
Posts: 842
Mein Auto: 2019 X3 Black Sapphire
Quote:
Originally Posted by mayene View Post
Good to know and that you were able to solve the issue! We are in the central part of FL

Stay safe. We have friends in central Florida (The Villages) and they seem to be prepared as much as possible.
__________________
2019 G01/Black Sapphire/Canberra Beige Vernasca Leather
2019 G30/Bluestone Metallic/Ivory White Leather
Reply With Quote
  #15  
Old 09-03-2019, 11:17 AM
mayene mayene is offline
Registered User
Location: Florida
 
Join Date: Aug 2019
Posts: 12
Mein Auto: 2019 540i
Quick update:
The service center called me today and I took the car for service. Turns out that the problem was a faulty battery which will cause modules to shut down little by little hence the problems with XM radio, navigation and other messages. The battery was replaced and they tested it and said everything was fine. I have no idea what they tested to ensure that everything is fine. My husband is on his way to pick it up since they are closing early due to the weather. This car is a year old, although new for us. I'm glad it wasn't other issues caused by the Automatic GPS tracker.
Thanks!
Reply With Quote
  #16  
Old 09-04-2019, 06:14 AM
silberma1 silberma1 is offline
silberma1
Location: Florida
 
Join Date: Feb 2014
Posts: 197
Mein Auto: 2018 540i
Allstate requested that I plug a drive wise device into my OBD board. Shortly afterwards I started getting error messages on my car. Took it to the dealer and the first thing they asked is I had anything plugged into the OBD. As soon as I removed it all the error messages disappeared. I advised Allstate of this issue and they still gave me the discount.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > G30 (2017 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 03:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.