ABS, DSC, BRAKE lights on & Speedometer not working. Help! - Page 2 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #26  
Old 11-29-2016, 09:03 PM
brennancody0 brennancody0 is offline
Registered User
Location: US
 
Join Date: Nov 2016
Posts: 2
Mein Auto: 1999 323
Any idea what would happen if I plugged in the abs module but didn't have fluid going into it?

Sent from my SAMSUNG-SM-G900A using Tapatalk
Reply With Quote
Sponsored Links
Advertisement
 
  #27  
Old 11-29-2016, 09:17 PM
smolck's Avatar
smolck smolck is offline
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 23,654
Mein Auto: 2003 330ci (5 speed)
Quote:
Originally Posted by brennancody0 View Post
Any idea what would happen if I plugged in the abs module but didn't have fluid going into it?

Sent from my SAMSUNG-SM-G900A using Tapatalk
What are you trying to accomplish?
__________________
Check out my YouTube Channel for DIY's and other fun stuff HERE
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #28  
Old 11-29-2016, 09:19 PM
brennancody0 brennancody0 is offline
Registered User
Location: US
 
Join Date: Nov 2016
Posts: 2
Mein Auto: 1999 323
Quote:
Originally Posted by smolck View Post
What are you trying to accomplish?
I'm trying to get my speedo , and rev past 5500 Rpm with out re routing brake lines into the abs module. The module is currently out of the car and I am Wondering if I could get it out of limp mode with out running lines through the abs module


Sent from my SAMSUNG-SM-G900A using Tapatalk
Reply With Quote
  #29  
Old 06-15-2019, 10:52 AM
MattMattBoBatt MattMattBoBatt is offline
Registered User
Location: Pennsylvania
 
Join Date: Jun 2019
Posts: 1
Mein Auto: X3 E83
Glad I found this old thread. I cleaned and swapped the rear sensors on my old 2006 X3 E83 and all the lights went out and the speedo works again.

Thanks for the clues!
Reply With Quote
  #30  
Old 09-10-2019, 11:36 AM
Leipzig Leipzig is offline
Registered User
Location: Pennsylvania
 
Join Date: Aug 2013
Posts: 5
Mein Auto: BMW 135i
Quote:
Originally Posted by hexy27 View Post
Most common cause of these symptoms is a bad wheel speed sensor and I believe a dead speedo usually points to the left rear wheel's sensor. There is no relation to having just changed the fuel pump......simply a coincidence.
I know this post and thread are super old, but I wanted to thank you for this rather concise response. My 2009 135i just failed an inspection and my right rear wheel sensor was out (confirmed it with an Autel MX808 scanner). Well, the right rear ABS is not a reason to fail inspection, so I was a bit shocked when the dealer called me and told me that my speedo wasn't working (even tho it worked on way to the dealer) - and the malfunctioning speedo WAS the reason for the fail.

Well, I replaced my right rear wheel speed sensor with a $70 + Wells/Airtex sensor from Rock Auto (that turned out to be just a repackaged OE German ATE brand - which is another story). Installation went rather smoothly except for some fiddly connectors, and then drive the car only to realize that the ABS lights won't go off. I took the Autel out and cleared all the codes - but the ABS came back on (and the speedo was also still not working).

Well, I ran another scan with the Autel to find out that, damn, now my rear left ABS wheel speed sensor is ALSO out! Your post confirmed that this is most likely the reason for the speedo going out as well (fingers crossed as I have not replaced it, yet). So, the OE ATE part is on order from FCP Euro (this time, under $40 - love FCP Euro)... and should be here by Wed. Now that I've done the passenger side rear, the driver side rear should be substantially quicker.

Thanks again for this thread -- and, hopefully my addition might help someone else out as well.

Oh, and PS -- I live in Pittsburgh. As somebody that grew up as a fan of Lemieux and Jaeger (and to a lesser extent Barasso) -- we all HATED Hextall!

Last edited by Leipzig; 09-10-2019 at 11:40 AM.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:15 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.