DYNAVIN N7 Multimedia GPS System.... New for 2018 - Page 2 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #26  
Old 01-08-2019, 06:31 PM
crowz's Avatar
crowz crowz is offline
Officially Welcomed to the 'Fest
Location: Alabama
 
Join Date: Oct 2006
Posts: 5,370
Mein Auto: '00 323i/97 528i/05 X5
Quote:
Originally Posted by eagara View Post
Hi

I have recently installed a new Dynavin N7 into my X5 E53. Everything works well, however it keeps draining the battery on the car. I've taken it to a specialist but can't find the fault. The unit keeps resetting itself overnight, i.e. i lose the radio presets and the settings such as colour.
Does anybody else have similar problems, and how do you fix this?

thanks
Arran
I would contact them directly. The customer support from them is supposed to be 1st rate from what I have read.
__________________
My BMW howto's

1995 318is

1997 528i

2000 323i 400k miles and climbing
Converted from automatic to 5 speed manual

2005 X5 3.0 with Nav, adaptive headlights etc

2013 X5 xdrive35 Turbo
Reply With Quote
Sponsored Links
Advertisement
 
  #27  
Old 01-09-2019, 06:41 AM
marcozandrini marcozandrini is offline
Officially Welcomed to the 'Fest
Location: Virginia
 
Join Date: Feb 2014
Posts: 4,926
Mein Auto: 2018 M240i
Quote:
Originally Posted by eagara View Post
Hi



I have recently installed a new Dynavin N7 into my X5 E53. Everything works well, however it keeps draining the battery on the car. I've taken it to a specialist but can't find the fault. The unit keeps resetting itself overnight, i.e. i lose the radio presets and the settings such as colour.

Does anybody else have similar problems, and how do you fix this?



thanks

Arran


Did you install the head unit yourself? Modern head units have 2 power sources. One power source is always on. This power source maintains the radio presets. The other power source is on when the ignition is in the accessory or run modes. This is called switched power. Id pull the fuse for the switched power to see what happens.
Reply With Quote
  #28  
Old 01-09-2019, 05:37 PM
[email protected] jeffb325@NavigationSolutions is offline
J&T Distributing
Location: California
 
Join Date: Jun 2014
Posts: 214
Mein Auto: BMWs
Two things,

Contact your dealer for a firmware update, you need to be on the newest firmware to be sure your troubleshooting is accurate.

There are no "known issues" related to power drain but BMWs are notorious for all kinds of electrical issues so there are a lot of directions this could go. Have your battery load tested, the installation process and playing with our new toy can push a marginal battery over the edge. If it passes the load test, pull the unit out and check the yellow constant power wire and the red ignition turn on wire for function as Marco points out above. A malfunctioning ignition relay in the car can cause all kinds of tricky to sort out issues.
__________________
Reply With Quote
Sponsored Links
Advertisement
 
  #29  
Old 01-18-2019, 02:35 PM
drexellak drexellak is offline
Descendant of Vikings
Location: Columbia, SC
 
Join Date: Jun 2013
Posts: 87
Mein Auto: E46 330ci vert 325xi
Is the model with Android Auto out yet?
__________________
The only stupid question is the question never asked.
Reply With Quote
  #30  
Old 03-20-2019, 03:48 PM
PsychoCemia PsychoCemia is offline
Registered User
Location: Atlanta
 
Join Date: Apr 2010
Posts: 3
Mein Auto: '05 330Ci ZHP
Just finished tr install on my 2005 with HK & Nav, and have a couple issues.

- I've got a constant low-to-medium volume static coming from my speakers when the unit is on. The Fakra cable is currently running down the center of the car (the battery line is running down passenger doors I'll). I've set the HiFi amp to Enabled and put it on the lowest volume.

- The unit will constantly wake up after the car is off, and it's draining my battery. After turning off the car, my draw is about 1.2A. 15-20 minutes later everything goes to sleep and it drops to ~.30A. Every so often after that, the draw jumps back up to 1.2A for another 20 minutes. Overnight my battery is drained, and the Dynavin unit is warm (outside temp is in the 50s). Pulling the #41 fuse (radio) fixes the battery drain issue.

Any ideas?
__________________

Last edited by PsychoCemia; 03-20-2019 at 03:49 PM.
Reply With Quote
  #31  
Old 03-20-2019, 03:56 PM
[email protected] jeffb325@NavigationSolutions is offline
J&T Distributing
Location: California
 
Join Date: Jun 2014
Posts: 214
Mein Auto: BMWs
There is a setting in the audio settings called "factory amp", turn that setting on and adjust it down. That should lower any noise you might have. Generally speaking we suggest running the cable down the drivers side in a 3 series, although running it down the center is not necessary an issue.

The Dynavin only stays in standby for 5 minutes after getting the "wake up" (unlock) command from the car, not 20 minutes. The CAR does stay on for 20 minutes. It sounds like your car is waking up the dynavin periodically. You should see a drop in the draw on the car after 5 minutes when the dynavin shuts down and then another drop after 20 when the rest of the car shuts down. If thats not happening it could be something like the trunk or hood sensors, etc. If you got this unit from us you should email us about it so we can do some troubleshooting to try to track down the culprit.
__________________
Reply With Quote
  #32  
Old 03-20-2019, 04:00 PM
drexellak drexellak is offline
Descendant of Vikings
Location: Columbia, SC
 
Join Date: Jun 2013
Posts: 87
Mein Auto: E46 330ci vert 325xi
I was just going to say contact the seller.

Jeff, is the model with Android Auto out yet? Any discounts coming up?
__________________
The only stupid question is the question never asked.
Reply With Quote
  #33  
Old 03-20-2019, 04:06 PM
[email protected] jeffb325@NavigationSolutions is offline
J&T Distributing
Location: California
 
Join Date: Jun 2014
Posts: 214
Mein Auto: BMWs
The current N7 can screen mirror with android and you can run the android auto app if you like.

We always have the forum discount, the code is in my signature.
__________________
Reply With Quote
  #34  
Old 04-20-2019, 01:52 AM
Bertieb.oz Bertieb.oz is offline
Registered User
 
Join Date: Apr 2019
Posts: 1
Mein Auto:
Hi Jeff and forum Members. I have just had an N7 installed in my Mercedes here in Australia. Unfortunately I'm not getting much support from the installer yet and am trying the local Dynavin dealer.

I'm really liking the N7 however there are two issues that are really affecting the experience.

(1) unlike a previous Nav system I had in another car , the Dynavin won't boot up into the Navigation maps, even if that was the last thing on the N7 when powered off. I read the 80 pages of the N6 discussion and there was a section where most users were adamant that regardless of the time between shutoff and restart (5 mins, 20 minutes, hours..) if the map was showing when the unit was switched off, it would come back on when the system next powered up. I would love that to happen with my N7 but it doesn't.

(2) iGo navigation. The manual for the navigation (and the whole N7) is woeful - I'm having to find things out by trial and error. A major problem I have is that I can't seem to search for addresses or key words or anything. The only thing I can find is existing POIs / restaurants etc near me. If I search for anything it just goes into an endless "Search in progress..." screen. On the "search area" section it's blank with a " - ". If I try to change the search area as I type, there are no results , and searching for anything in the search area section (Sydney, New South Wales, etc) just goes into the endless "Search in progress". It is like some part of the database hasn't loaded.

I have updated iGo navigation software on the SD card and had everything selected to download / update. I might try again. I also have the latest firmware installed in the N7. (I think 1.0.5.6 ??).

Does anybody have any advice on these two issues ?

Thank you

bertieb.oz

Last edited by Bertieb.oz; 04-20-2019 at 01:56 AM.
Reply With Quote
  #35  
Old 04-22-2019, 01:21 PM
[email protected] jeffb325@NavigationSolutions is offline
J&T Distributing
Location: California
 
Join Date: Jun 2014
Posts: 214
Mein Auto: BMWs
I just checked and they nav will not auto start, you have to select it after a shutdown. Im not 100% sure but I dont recall that the N7s have ever been that way.

It sounds like you may have the wrong nav map package. Does it show your location or is the screen blank? If its blank its the wrong (or a bad) card.

Regardless of what the above situation turns out to be you should probably get in touch with your dealer and swap out the card.
__________________
Reply With Quote
  #36  
Old 04-30-2019, 12:26 PM
Wombat201 Wombat201 is offline
Registered User
Location: NJ
 
Join Date: May 2016
Posts: 39
Mein Auto: 2005 330ci cabrio
Is this still a 4 channel system? Are all the speakers and sub wired to the unit?
Reply With Quote
  #37  
Old 04-30-2019, 08:19 PM
[email protected] jeffb325@NavigationSolutions is offline
J&T Distributing
Location: California
 
Join Date: Jun 2014
Posts: 214
Mein Auto: BMWs
Quote:
Originally Posted by Wombat201 View Post
Is this still a 4 channel system? Are all the speakers and sub wired to the unit?
If its a North American spec car it has an amplifier that actually powers all the speakers, the input to the amp is 4 channels, the output is 8-10 channels. The Dynavin is the same as the stock head unit in that respect, so no change from stock.
__________________
Reply With Quote
  #38  
Old 07-05-2019, 07:47 PM
seemyad's Avatar
seemyad seemyad is offline
BMW ****ie
Location: Seattle WA
 
Join Date: Jul 2011
Posts: 1,741
Mein Auto: 530i Sport Package
N7-E39 vs N7-E39 PRO?

What does the PRO offer over the original N7-E39?

Also, can I opt to reuse my N6 connectors if I install the N7?

Thanks.
__________________
___________________________________
2002 530i with Sport, Cold Weather, & Premium Package
17" BBS Style 42s (stock)
Conti Extreme Contact 06 DWS
HAWK Ceramic Performance brake pads
KONI FSD
DINAN Tune (+AFE dry air filter)
Dynavin N6 (NAV Unit) + Rearview Camera
BavSound Stage 1 Speaker Upgrade + JL Wedge SubWoofer
Reply With Quote
  #39  
Old 07-08-2019, 09:19 AM
[email protected] jeffb325@NavigationSolutions is offline
J&T Distributing
Location: California
 
Join Date: Jun 2014
Posts: 214
Mein Auto: BMWs
built in carplay and android auto. Yes, the N6, N7, and N7 Pro connections are the same (there are some limited exceptions but Im not going to confuse the issue by going into that here).
__________________
Reply With Quote
  #40  
Old 07-08-2019, 09:46 AM
540fan 540fan is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Mar 2007
Posts: 299
Mein Auto: 2001 540iT
Ok, I bit and ordered the Pro and the Bav stage 1 speakers. Not for the E46 but for my 540iT. It's getting a new engine so why not a new stereo!
Reply With Quote
Reply

See More Related BMW Stories

Tags
bluetooth, bmw, dynavin, gps, navigation, radio


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.