1998 Bmw 540i - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-01-2008, 07:55 AM
crownpointauto crownpointauto is offline
 
Join Date: Jul 2008
Posts: 1
Mein Auto:
1998 Bmw 540i

When I start my car it sputters really bad, sometimes cutting off if I don't hold my foot on the gas. Once it warms up, it is OK. However, the check engine light has came on and reads P0170 Fuel Trim (Bank 1) and P0173 Fuel Trim (Bank 2). I think this has something to do with the sputtering when it is cold. I have googled Fuel trim and it said it could be a number of things from dirty fuel injectors to this and that. If someone has had this same problem, could you please lead me in the right direction on fixing this problem I have. Thank You for the replies.

BH
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-10-2008, 05:24 PM
bains540 bains540 is offline
Registered User
Location: UK, Engkand
 
Join Date: Dec 2007
Posts: 44
Mein Auto: BMW 540i Touring 1998
I had a similar problem which was fixed by replacing my thermostat sensor
__________________
V8 POWER DRIVER
Reply With Quote
  #3  
Old 07-10-2008, 06:39 PM
stefinn stefinn is offline
 
Join Date: Apr 2006
Posts: 7
Mein Auto:
Take a look at a post I did over on another board back a while ago. It sounds a whole lot like the problem I had with the intake manifold cover (aka CCV, CVV, or EGR valve). When you look at the post, note that I did have a bad camshaft position sensor at the time but that was unrelated to the poor cold-starting.

http://bimmer.roadfly.com/bmw/forums/e39/8054432-1.html
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 07-10-2008, 06:55 PM
meatrolla meatrolla is offline
Registered User
Location: Altus, OK
 
Join Date: May 2007
Posts: 43
Mein Auto: 1997 540i
I have a 97 540 and I had the same problem throwing the same codes. I had my intake resealed because I had a small vacuum leak and it solved the problem, but I think every car is different. I would check for any vacuum leaks or disconnected hoses/worn out hoses before going to the stealership and having them tell you they need to do a $1000 dollars worth of work.



Quote:
Originally Posted by crownpointauto View Post
When I start my car it sputters really bad, sometimes cutting off if I don't hold my foot on the gas. Once it warms up, it is OK. However, the check engine light has came on and reads P0170 Fuel Trim (Bank 1) and P0173 Fuel Trim (Bank 2). I think this has something to do with the sputtering when it is cold. I have googled Fuel trim and it said it could be a number of things from dirty fuel injectors to this and that. If someone has had this same problem, could you please lead me in the right direction on fixing this problem I have. Thank You for the replies.

BH
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.