Electric problem - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)

X6 E71 / E72 (2008 - 2014)
The BMW X6 luxury crossover went on sale in April 2008 as a 2009 model year. BMW referes to the X6 as a Sports Activity Coupe (SAC) as it combines the attributes of an SUV (high ground clearance, xDrive and all-weather ability) with the stance, styling and roof line shape of a coupe. The E71 X6 was built off the E70 X5 (2007 - 2013) platform at BMW's Spartanburg, SC plant. Total worldwide sales were just over 235,000, sold mostly to the BRIC countries. US total sales was 34,082 vehicles.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-16-2019, 04:35 AM
imth imth is offline
Registered User
 
Join Date: Feb 2019
Posts: 1
Mein Auto:
Electric problem

Hello guys,im new to the forum !

I have problem with my bmx6 2012 4d car

When I start the engine and drive for few miles everything is ok but after 2-3 miles few things are not working anymore: I cant open the tailgate,my spray gun for the wipers is not working ,climate control is gone and also I cant open the glove compartment..atleast that's what I notice is not working, after I stop the car and wait sometime to cool down everything is back to normal..once I start to drive again all is gone !
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-06-2019, 09:17 AM
Dlovan778's Avatar
Dlovan778 Dlovan778 is offline
Officially Welcomed to the 'Fest
Location: Iraq/kurdistan
 
Join Date: Jun 2015
Posts: 168
Mein Auto: BmwFxx
Quote:
Originally Posted by imth View Post
Hello guys,im new to the forum !



I have problem with my bmx6 2012 4d car



When I start the engine and drive for few miles everything is ok but after 2-3 miles few things are not working anymore: I cant open the tailgate,my spray gun for the wipers is not working ,climate control is gone and also I cant open the glove compartment..atleast that's what I notice is not working, after I stop the car and wait sometime to cool down everything is back to normal..once I start to drive again all is gone !
Probably water leaked to a ecu
Take a look at hkl control unit

Sent from my SM-G955F using Tapatalk
Reply With Quote
  #3  
Old 04-09-2019, 10:03 AM
Mulchman's Avatar
Mulchman Mulchman is offline
Officially Welcomed to the 'Fest
Location: Valley Forge, PA
 
Join Date: Jul 2011
Posts: 695
Mein Auto: '07 650i
Quote:
Originally Posted by imth View Post
Hello guys,im new to the forum !

I have problem with my bmx6 2012 4d car

When I start the engine and drive for few miles everything is ok but after 2-3 miles few things are not working anymore: I cant open the tailgate,my spray gun for the wipers is not working ,climate control is gone and also I cant open the glove compartment..atleast that's what I notice is not working, after I stop the car and wait sometime to cool down everything is back to normal..once I start to drive again all is gone !
How old is your battery? These cars eat batteries and when they start to go they cause little gremlins. I'd start there.
__________________
'14 X6 i50 - Deep Sea Blue Matallic
'07 650i Coupe - Black Sapphire Metallic
'11 328i Sedan - Alpine White

Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pierburg Electric Water Pump Newparts.com Site Sponsors & Bimmerfest Group Buys 0 08-27-2018 03:58 PM
ZHP "shudders" - not an idle problem (long) kiteboy 3 Series & 4 Series 27 08-25-2004 02:30 AM
Hot car CD problem cowgit General BMW Questions 3 08-04-2004 01:37 PM
Back from dealer; still have idle problem toddkageals 3 Series & 4 Series 9 05-04-2004 11:00 AM
interesting ethical problem.. Cliff330i 3 Series & 4 Series 10 03-31-2003 06:33 PM


All times are GMT -7. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.