Flashing ECU's with E-sys [GUIDE] - Page 13 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #301  
Old 08-24-2019, 09:24 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by kujass.pl View Post
Which e-sys should I use for flashing?

Injecting CAFD and Flashing ECU's with >= v.4.17.20 PSdZData require using newer E-Sys 3.33.x:

1) Install E-Sys 3.27.1 to default location, C:\EC-Apps\ESG\E-Sys.
2) Use E-Sys 3.27.1 for normal FDL and VO Coding. For FDL Coding, use E-Sys Launcher PREMIUM 2.x to launch E-Sys 3.27.1,
3) Install E-Sys 3.33.4 to different location, e.g. C:\EC-Apps\ESG\E-Sys_3.33.4
4) Use E-Sys 3.33.4 for CAFD Injection and Flashing. Do NOT use with E-Sys Launcher PREMIUM 2.x.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
Sponsored Links
Advertisement
 
  #302  
Old 08-24-2019, 10:02 AM
kujass.pl kujass.pl is offline
Registered User
Location: Poland
 
Join Date: Aug 2019
Posts: 14
Mein Auto: F10 535i
Thanks @shawnsheridan, I will go with the 3.31.0 (the newsest I have).



So I have two weirdos.

1. I don't know why some folders are blue/red, some black?
2. I have one icon with two green arrows, which means that ECU has changed? Strange thing, because there is nothing about it in the car history and this ECU is Function unit roof... (no, the car hadn't accident before .

one more thing, I have retrofit combox with esys and there is no green arrows in that ecu.. What I was expecting.

Attached Thumbnails
Click image for larger version

Name:	IMG_5044.jpg
Views:	31
Size:	237.6 KB
ID:	862165  
__________________
535i F10 / USA






Last edited by kujass.pl; 08-24-2019 at 10:04 AM.
Reply With Quote
  #303  
Old 08-24-2019, 10:15 AM
kujass.pl kujass.pl is offline
Registered User
Location: Poland
 
Join Date: Aug 2019
Posts: 14
Mein Auto: F10 535i
Ok, Probably I'm going nowhere without the newsest 3.33.4...... Shwan, do you mind if I ask you for the link (32 bit)?


Code:
Error in module "TALL processing" while reading element  from XML file "svt_tal.xml". [C352] 

Error in XML parser: File "C:\Data\TAL\svt_tal.xml" is corrupt or not of type XML. [C087]
-------------------

Invalid "Tal": "cvc-elt.1.a: Cannot find the declaration of element 'svt'. [line 2, column 48]" [C294]





Update: I got 3.33.0 (the last one with 32 bit support)

__________________
535i F10 / USA






Last edited by kujass.pl; 08-24-2019 at 10:56 AM.
Reply With Quote
  #304  
Old 08-24-2019, 11:07 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by kujass.pl View Post
Thanks @shawnsheridan, I will go with the 3.31.0 (the newsest I have).

So I have two weirdos.

1. I don't know why some folders are blue/red, some black?
2. I have one icon with two green arrows, which means that ECU has changed? Strange thing, because there is nothing about it in the car history and this ECU is Function unit roof... (no, the car hadn't accident before .

one more thing, I have retrofit combox with esys and there is no green arrows in that ecu.. What I was expecting.
blue/red means ECU has some firmware update(s). Black means no update.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #305  
Old 08-25-2019, 09:38 PM
Almaretto's Avatar
Almaretto Almaretto is offline
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,010
Mein Auto: Test Vehicles
Quote:
Originally Posted by kujass.pl View Post
Which e-sys should I use for flashing?

Thanks for the reminder. I have added 3.33.4 to list.
Reply With Quote
  #306  
Old 08-25-2019, 11:11 PM
weebyx weebyx is offline
Officially Welcomed to the 'Fest
Location: Denmark
 
Join Date: May 2018
Posts: 237
Mein Auto: BMW 320d F30 2018
Quote:
Originally Posted by kujass.pl View Post
Thanks @shawnsheridan, I will go with the 3.31.0 (the newsest I have).



So I have two weirdos.

1. I don't know why some folders are blue/red, some black?
2. I have one icon with two green arrows, which means that ECU has changed? Strange thing, because there is nothing about it in the car history and this ECU is Function unit roof... (no, the car hadn't accident before .

one more thing, I have retrofit combox with esys and there is no green arrows in that ecu.. What I was expecting.
The green arrows does not mean ECU has been changed. It means that this ECU is not the correct HWEL version for your car/I-Step, and needs to be changed to match the car.

If it is the original module, then you probably have selected the wrong I-Step Factory when doing the TAL calculation ?

/Weebyx
Reply With Quote
  #307  
Old 08-27-2019, 02:58 PM
Stoonage1 Stoonage1 is offline
Registered User
 
Join Date: Aug 2019
Posts: 13
Mein Auto:
Flashing ECU's with E-sys [GUIDE]

Hello everyone,

I guess my FZD needs to be flashed since my sunroof and read lights are not working.

I have esys installed and working ( coded some CFADís) i am using an enet cable.

Here are my questions:

1 is the enet cable correct for flashing activities? ( i cannot connect to the gateway)

2 is it mandatory to connect to the gateway for flashing ?

3 i tried the inject with no success (see picture3)

4 i am trining to flash the fzd according to the guide but also with no success ( see picture )

5 no possibility to read coding data

Thanks in advance

[
Click image for larger version

Name:	IMG_1958.jpg
Views:	24
Size:	157.0 KB
ID:	862537
Click image for larger version

Name:	IMG_1957.jpg
Views:	22
Size:	117.5 KB
ID:	862541Click image for larger version

Name:	IMG_1957.jpg
Views:	22
Size:	117.5 KB
ID:	862541
ATTACH]862539[/ATTACH]) Click image for larger version

Name:	IMG_1958.jpg
Views:	24
Size:	157.0 KB
ID:	862537


Sent from my iPhone using Bimmerfest mobile appClick image for larger version

Name:	IMG_1959.jpg
Views:	20
Size:	210.6 KB
ID:	862539

Last edited by Stoonage1; 08-27-2019 at 03:06 PM.
Reply With Quote
  #308  
Old 08-27-2019, 04:51 PM
Curamrda's Avatar
Curamrda Curamrda is offline
Officially Welcomed to the 'Fest
Location: Europe
 
Join Date: Aug 2016
Posts: 213
Mein Auto: Fxx
i do not read so much German..but did you read or set FA before flashing? what car??
Reply With Quote
  #309  
Old 08-27-2019, 11:34 PM
Stoonage1 Stoonage1 is offline
Registered User
 
Join Date: Aug 2019
Posts: 13
Mein Auto:
Quote:
Originally Posted by Curamrda View Post
i do not read so much German..but did you read or set FA before flashing? what car??


Yes i was already able to vo code but when it comes to flashing itís nit working. Maybe i need to connect to the gateway?

Thanks


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #310  
Old 08-28-2019, 01:19 AM
Curamrda's Avatar
Curamrda Curamrda is offline
Officially Welcomed to the 'Fest
Location: Europe
 
Join Date: Aug 2016
Posts: 213
Mein Auto: Fxx
on the 3rd picture.. does it say, you have to define FA first ? So you were able to connect to the car, read FA/ SVT, calculate tal .. but not able flash?
Reply With Quote
  #311  
Old 08-28-2019, 01:27 AM
Stoonage1 Stoonage1 is offline
Registered User
 
Join Date: Aug 2019
Posts: 13
Mein Auto:
Yes it said the FA must be set when Tal contains coding transactions

Yes, but it was a connection via vin and not gateway


Gesendet von iPhone mit Bimmerfest
Reply With Quote
  #312  
Old 08-28-2019, 09:05 AM
Stoonage1 Stoonage1 is offline
Registered User
 
Join Date: Aug 2019
Posts: 13
Mein Auto:
Click image for larger version

Name:	IMG_1969.jpg
Views:	49
Size:	123.9 KB
ID:	862689


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #313  
Old 08-28-2019, 11:20 AM
Stoonage1 Stoonage1 is offline
Registered User
 
Join Date: Aug 2019
Posts: 13
Mein Auto:
Quote:
Originally Posted by Stoonage1 View Post
Attachment 862689


Sent from my iPhone using Bimmerfest mobile app







Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #314  
Old 08-28-2019, 11:23 AM
Stoonage1 Stoonage1 is offline
Registered User
 
Join Date: Aug 2019
Posts: 13
Mein Auto:
Quote:
Originally Posted by shawnsheridan View Post
blue/red means ECU has some firmware update(s). Black means no update.


Here ist picture i hope you can help

Click image for larger version

Name:	IMG_1969.jpg
Views:	37
Size:	123.9 KB
ID:	862691



Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #315  
Old 08-29-2019, 01:07 AM
Curamrda's Avatar
Curamrda Curamrda is offline
Officially Welcomed to the 'Fest
Location: Europe
 
Join Date: Aug 2016
Posts: 213
Mein Auto: Fxx
Quote:
Originally Posted by Stoonage1 View Post
Here ist picture i hope you can help

Attachment 862691



Sent from my iPhone using Bimmerfest mobile app

well, the error note is quite explaining... " FA must not be a Null.... " . Did you set proper SVT, TAL and FA before flashing? show us the those fields or attach the FA.xml file
Reply With Quote
  #316  
Old 08-29-2019, 11:08 AM
Maxwell4321 Maxwell4321 is offline
Registered User
Location: uk
 
Join Date: Jan 2014
Posts: 76
Mein Auto: e64
Quote:
Originally Posted by Stoonage1 View Post
Here ist picture i hope you can help

Attachment 862691



Sent from my iPhone using Bimmerfest mobile app
You have made a mistake in reading the VIN

In TAL Processing:

Click on Read FA button to generate FA_aus_VCM
Select Read VIN out of FA then click on Read VIN

If you click Read VIN while Enter VIN is selected you will get the FA Null error
Reply With Quote
  #317  
Old 08-29-2019, 06:53 PM
Almaretto's Avatar
Almaretto Almaretto is offline
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,010
Mein Auto: Test Vehicles
Quote:
Originally Posted by Stoonage1 View Post
Attachment 862689


Sent from my iPhone using Bimmerfest mobile app
"FA must not be a Null"

https://www.bimmerfest.com/forums/sh...d.php?t=876038
Reply With Quote
  #318  
Old 09-03-2019, 01:32 AM
pablito_f10 pablito_f10 is offline
Registered User
Location: United Kingdom
 
Join Date: Aug 2019
Posts: 8
Mein Auto: Bmw F10 3.0d
For both esys should I use full psdzdata?
Reply With Quote
  #319  
Old 09-03-2019, 07:24 PM
Almaretto's Avatar
Almaretto Almaretto is offline
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,010
Mein Auto: Test Vehicles
Quote:
Originally Posted by pablito_f10 View Post
For both esys should I use full psdzdata?
You can use lite to calculate. But, need full to actually flash.
Reply With Quote
  #320  
Old 09-07-2019, 04:33 PM
pablito_f10 pablito_f10 is offline
Registered User
Location: United Kingdom
 
Join Date: Aug 2019
Posts: 8
Mein Auto: Bmw F10 3.0d
Thanks for reply
I have got some more questions to make sure I'll do everything correct . I have calculated SVT an TAL in Esys 3.2.7 . Finally I understood what dependencies are - I need to check ecu which I want to update for any PreRequsite ECU and update them aswell . Here are my some questions .

1) As you can see on picture -for example Kombi has got PreRequsite of TalLine 1 ,3 and 15 - TalLine 3 and 15 is same ECU-ZGW. So why it has got two PreRequsite if this is one module ?

2) when I open ESYS 3.33.4 and want to open SVT file generated in esys 3.2.7 warrning alert comes up. Why ? There is same problem for TAL .

3) ECU list in tal processing shows me 2 the same ecu's SM 6E and 6D.

4) as some ecu's have got dependencies of ZGW ,should I be worried to flash it ?

5) what ecu's do you recommend to update ? some told me to update Steering,Fuel pump,traction and automatic gearbox but I cannot see fuel pomp,gearbox and steering on ecus list.
Attached Thumbnails
Click image for larger version

Name:	svt1.jpg
Views:	21
Size:	61.9 KB
ID:	863733   Click image for larger version

Name:	problem.jpg
Views:	24
Size:	88.8 KB
ID:	863735  
Reply With Quote
  #321  
Old 09-13-2019, 11:19 PM
motorberserker motorberserker is offline
Registered User
Location: Japan
 
Join Date: Mar 2017
Posts: 4
Mein Auto: F10 520d
I got the problgm of "I-Step ist not available" too.
have tried the E-Sys versions of 3.26, 3.27, 3.28, 3.30 and 3.34. The problam unfortunately remains.
Actually I successfully update the ZGW2 last year by following the this guide, however it doesn't work with the new PSDzData Full (Extracted from ISTA version 4.17.13), and all the E-Sys mentioned above.
Is there anything else I missed?

thanks an advance.
Attached Thumbnails
Click image for larger version

Name:	Untitled-1.jpg
Views:	17
Size:	104.5 KB
ID:	864617  

Last edited by motorberserker; 09-13-2019 at 11:26 PM.
Reply With Quote
  #322  
Old 09-14-2019, 12:03 AM
Almaretto's Avatar
Almaretto Almaretto is offline
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,010
Mein Auto: Test Vehicles
Quote:
Originally Posted by motorberserker View Post
I got the problgm of "I-Step ist not available" too.
have tried the E-Sys versions of 3.26, 3.27, 3.28, 3.30 and 3.34. The problam unfortunately remains.
Actually I successfully update the ZGW2 last year by following the this guide, however it doesn't work with the new PSDzData Full (Extracted from ISTA version 4.17.13), and all the E-Sys mentioned above.
Is there anything else I missed?

thanks an advance.
Switch bullet to "Complete Flash."
Reply With Quote
  #323  
Old 09-14-2019, 01:54 AM
motorberserker motorberserker is offline
Registered User
Location: Japan
 
Join Date: Mar 2017
Posts: 4
Mein Auto: F10 520d
Quote:
Originally Posted by Almaretto View Post
Switch bullet to "Complete Flash."
I've tried, it still doesn't work.

I remember these two fields "I-Step (shipm.) & I-Step (target)" shoud show the version no. after reading and activing the FA, but the "I-Step (target)" could be modifed only if the Calculation Strategy is switched to "Complete Flash". However it shows "not available" no metter I switch to "Complete Flash" before or after reading th FA.
Attached Thumbnails
Click image for larger version

Name:	Untitled-1.jpg
Views:	17
Size:	117.6 KB
ID:	864633  
Reply With Quote
  #324  
Old 09-14-2019, 01:59 AM
pablito_f10 pablito_f10 is offline
Registered User
Location: United Kingdom
 
Join Date: Aug 2019
Posts: 8
Mein Auto: Bmw F10 3.0d
Reinstall esys. Uninstall esys and his file like DATA folder etc. Remember, DATA folder needs to be deleted manually. Install esys again with psdzdata . Should help.
Reply With Quote
  #325  
Old 09-14-2019, 02:21 AM
Almaretto's Avatar
Almaretto Almaretto is offline
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,010
Mein Auto: Test Vehicles
Quote:
Originally Posted by motorberserker View Post
I've tried, it still doesn't work.

I remember these two fields "I-Step (shipm.) & I-Step (target)" shoud show the version no. after reading and activing the FA, but the "I-Step (target)" could be modifed only if the Calculation Strategy is switched to "Complete Flash". However it shows "not available" no metter I switch to "Complete Flash" before or after reading th FA.
Then you have something installed incorrectly. All you need are three things:
1. FA
2. SVT
3. Complete Flash
Then, you should be able to select shipment. You can even do with Psdzdata lite.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:16 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.