Fxx-/Ixx-/Gxx-series F07 IHKA CAFD Missing....heated seat??? - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-03-2019, 12:05 PM
Dave530d Dave530d is offline
Registered User
Location: UK
 
Join Date: Sep 2019
Posts: 8
Mein Auto: BMW 530D GT
F07 IHKA CAFD Missing....heated seat???

Hi all,
1st post, so please be gentle. Recently bought a 530D GT 2010 and only just noticed that the front heated seat controls don't light or seats heat. Did the usual fuse check and connector checks under the seat, eventually bought a lead and downloaded E-Sys. It appears that I'm missing the CAFD for the IHKA module. I get the error below:

Failed to get CAFs for SWE "SWFL_000003d5-005_019_001"

Could someone point me in the direction of how I locate/source the required files please?

Other than that the car is amazing, replaced the silver cabin trim with a dark wood variant......plenty of things planned for the car, but would like to sort the seats.....

Cheers
DC
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-03-2019, 07:25 PM
Almaretto's Avatar
Almaretto Almaretto is offline
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,006
Mein Auto: Test Vehicles
What is vehicle I-step and which Psdzdata and E-sys are you using?
Reply With Quote
  #3  
Old 09-04-2019, 03:36 AM
Dave530d Dave530d is offline
Registered User
Location: UK
 
Join Date: Sep 2019
Posts: 8
Mein Auto: BMW 530D GT
Hi,
I'm using E-sys 3.24.1 and Psdzdata 63.3 full (but, looks like I have 3 rar files missing!!! 1, 6 and 16 of the set of 19). When I'm connected E-sys shows. the I-step target as F001-17-11-520.

I think I may need to download the full PSDZdata set again!!!

Thanks in advance for all your help.

Cheers
DC
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 09-04-2019, 05:37 AM
weebyx weebyx is offline
Officially Welcomed to the 'Fest
Location: Denmark
 
Join Date: May 2018
Posts: 234
Mein Auto: BMW 320d F30 2018
Quote:
Originally Posted by Dave530d View Post
Hi,
I'm using E-sys 3.24.1 and Psdzdata 63.3 full (but, looks like I have 3 rar files missing!!! 1, 6 and 16 of the set of 19). When I'm connected E-sys shows. the I-step target as F001-17-11-520.

I think I may need to download the full PSDZdata set again!!!

Thanks in advance for all your help.

Cheers
DC
You dont need Full psdz to inject CAFD.

Here is a link to the latest lite version. I think(someone correct me) that the latest psdz needs E-Sys 3.3x, and there is also a link to 3.31 E-sys.

https://www.bimmerfest.com/forums/sh...d.php?t=983244

/Weebyx
Reply With Quote
  #5  
Old 09-04-2019, 12:10 PM
Dave530d Dave530d is offline
Registered User
Location: UK
 
Join Date: Sep 2019
Posts: 8
Mein Auto: BMW 530D GT
Ok, making a little bit of progress I think!!! Installed E-sys 3.33.4 with the PSDZdata lite and the software now shows the IHKA module with a red CAFD file CAFD_00000092_004_002_010. It also shows 2 SWFL files SWFL_000003D5_005_019_001 and _002.

I assume my next step is to try and locate the file CAFD_00000092_004_002_010 and inject it.
Reply With Quote
  #6  
Old 09-04-2019, 09:29 PM
Almaretto's Avatar
Almaretto Almaretto is offline
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,006
Mein Auto: Test Vehicles
Quote:
Originally Posted by Dave530d View Post
Hi,
I'm using E-sys 3.24.1 and Psdzdata 63.3 full (but, looks like I have 3 rar files missing!!! 1, 6 and 16 of the set of 19). When I'm connected E-sys shows. the I-step target as F001-17-11-520.

I think I may need to download the full PSDZdata set again!!!

Thanks in advance for all your help.

Cheers
DC
Try E-sys 3.27.1 and same Psdzdata.

You do not need full to inject. But, since you have older I-Step, using newer Psdzdata can cause issues injecting.

CAFD_00000092.caf.004_002_010 is in latest. But, rather than picking latest I-Step, try one closest to actual I-Step when injecting.
Reply With Quote
  #7  
Old 09-09-2019, 06:53 AM
Dave530d Dave530d is offline
Registered User
Location: UK
 
Join Date: Sep 2019
Posts: 8
Mein Auto: BMW 530D GT
OK, bit of an update which may help others.....while trying other ideas regarding the IHKA missing CAFD files and issues with the cars heating controls I decided to install ISTA+

After resetting the module, I have fully working heated seats, correct indications and the rear climate controls also work as they should. The CAFD also appears in the IHKA module when viewed in E Sys.

Now my next problem, when I switch the car off and return to it the fault appears to come back to it defaults back to no heated seats and the rear controls don't work.

Early days, but this may help others.

Last edited by Dave530d; 09-09-2019 at 09:29 AM.
Reply With Quote
  #8  
Old 09-10-2019, 03:40 AM
tafikhulafa tafikhulafa is online now
Registered User
Location: indonesia
 
Join Date: Apr 2018
Posts: 32
Mein Auto: E39 530i
Have you succeeded injecting the cafd? if not i can help you send the required CAFD.

good luck
Reply With Quote
  #9  
Old 09-10-2019, 11:35 AM
Dave530d Dave530d is offline
Registered User
Location: UK
 
Join Date: Sep 2019
Posts: 8
Mein Auto: BMW 530D GT
All sorted, new to BMW's and coding, but looks like all the errors I was getting was due to the car not having the CAFD, the solution was to connect with ISTA+, runt the car test to identify the modules and faults, clear the faults. Then exit ISTA+ and open E-Sys without turning off the car power(engine running for me as I don't have a power supply). Once I opened E-Sys it showed the correct CAFD under the IHKA module, I then did the normal module flash by right click on "IHKA" and select "CODE". This then injected the CAFD into the IHKA and all problems are now gone.

Originally when I connected with ISTA+ it would work once I reset the modules, but once I turned the car off and on again it would go back to as before i.e. no heated seats, missing CAFD and rear climate control not working.

Posted this in the 5 Series forum for others as well.

https://www.bimmerfest.com/forums/sh....php?t=1345739
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:20 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.