Flashing ECU's with E-sys [GUIDE] - Page 2 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #26  
Old 12-18-2016, 05:33 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by egisz View Post
Hi All!

Thanks zkiifreak for great manual, I tried to flash ZGW yesterday and it was not as straight forward as I expected
Details are on another thread, but I'd like to ask few questions here as it may be also usefull for other users.

I have some questions:
  1. Should I use Esys Launcher for flashing ECU? For me it was only way to flash ZGW with launcher ...
  2. What Esys options should be set for ECU flashing? Are they same as for Coding? Should I set Update VCM after TAL execution and Update MSM after TAL execution?
  3. What can cause warnings " VCM-Update is deactivated"? Can it be that Esys/pszdata is too new version for my car?
  4. What could cause warning Could not read ComParam 'MODE_CHANGE_PARAMETER'?
...
Asked and answered back in original thread, but here is again for benefit of this thread:.

1. E-Sys Launcher is needed only for FDL Coding. Why would you introduce an unneeded variable that adds no value into an already delicate and complicated flashing process?

2. Incidentally, the very errors you are asking about "MODE_CHANGE_PARAMETER doesn't map to an item'" are introduced by using E-Sys Launcher.

3. "Update VCM after TAL execution" and "Update MSM after TAL execution" should always remain unchecked. If you want top udpate car I-Step after a Full Update of car, then go to VCM Module and manually update I-Step Current.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.

Last edited by shawnsheridan; 12-18-2016 at 05:36 AM.
Reply With Quote
Sponsored Links
Advertisement
 
  #27  
Old 01-08-2017, 09:12 AM
tom2325 tom2325 is offline
Registered User
Location: Japan
 
Join Date: May 2013
Posts: 51
Mein Auto: F30,F10
Hi,
This is the information for guys who have a plan to retrofit Automatic trunklid.

I have failed to flash HKFM_LS module.

The process is as follows.

1) Done Automatic trunklid retrofit to my Activehybrid 5.
2) I added 316 to FA Salapa.
3) I could not inject cafd by using the 'Detect CAF for SWE' button because there is no cafd file maching swfl_00000D9A_006_007_000.
I have never got this error when detecting CAF.


So, I decided to update the SWE file of HKFM_LS module in order to inject latest cafd file.

4) I tried flashing HKFM_LS by E-SYS as instructed in zkiifreak's manual.
5) I got erorr when calculating TAL. This is the first error.
I can not figure out but I continued my work because SME2 module may be no relevant to HKFM_LS.


5) Checked only HKFM_LS on the ECU list of TAL-Processing.
6) I got second error when executing TAL flashing HKFM_LS.
Quote:
TAL execution started.
VCM Update: VCM-Update is deactivated. VCM will not be updated. [C197]
ExecutionID=2017/01/07-14:53:25.638
[HKFM_LS - 6B] - [Exception - HKFM_LS - 6b] SVK-Ist does not match expected SGBMIDs for ecu ECUId:HKFM_LS_0x6B.
Excpected (relevant process classes only):[hwel_00000d98-004_002_000],
Actual (relevant process classes only): [hwel_00000d98-004_001_000],
Missing SGBMID(s): [hwel_00000d98-004_002_000],
Surplus SGBMID(s): [hwel_00000d98-004_001_000]
TAL-Execution finished with status: "FinishedWithError". [C207]
TAL execution finished. Duration: "1min 3s". [C206]
I think the causes of this error may be;
1. Flashing by modified FA caused confusion.
2. Retrofitted HKFM_LS module is older than my F10, so E-Sys could not inject latest cafd or firmware into the module.

I can not figure out the confusion of using modified FA, so I will try the another HKFM_LS module which has the latest SWFL file.

Will be reported soon.
Reply With Quote
  #28  
Old 01-18-2017, 05:38 PM
powershot powershot is offline
Registered User
Location: Portugal
 
Join Date: Oct 2016
Posts: 2
Mein Auto: BMW F31 318d
Hi Guys,

I need to upgrade the FEM in my F31.

I bought a used MAX FEM and a guy already coded my car VIN in the used FEM.
The problem is that he cannot update the software in the FEM, he says the software finishes and then restarts, in loop (he is not using E-sys).

Do you think that is possible to flash the FEM with E-sys by following the steps in this tutorial?

I already coded some things with E-sys and it seems easy to execute this tutorial.
My only concern is to identify the correct dependencies for the FEM.

Many thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #29  
Old 01-21-2017, 06:32 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
I would like to update the DSC I& EGS ecus in my 2010 F10, would I need to update SHE aswell?

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #30  
Old 01-21-2017, 10:04 AM
Almaretto's Avatar
Almaretto Almaretto is online now
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,012
Mein Auto: Test Vehicles
Quote:
Originally Posted by flashdash View Post
I would like to update the DSC I& EGS ecus in my 2010 F10, would I need to update SHE aswell?

Sent from my SM-G935F using Tapatalk
I am not sure what SHE is, but guide goes over dependencies.
Reply With Quote
  #31  
Old 01-21-2017, 10:06 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by Almaretto View Post
I am not sure what SHE is, but guide goes over dependencies.
Sorry I meant ZGW,

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #32  
Old 01-21-2017, 10:08 AM
Almaretto's Avatar
Almaretto Almaretto is online now
Super Moderator
Location: Mountain View, CA
 
Join Date: Nov 2015
Posts: 7,012
Mein Auto: Test Vehicles
Quote:
Originally Posted by flashdash View Post
Sorry I meant ZGW,

Sent from my SM-G935F using Tapatalk
Answer is still the same: "How to identify dependencies:"
Reply With Quote
  #33  
Old 01-21-2017, 04:09 PM
Tak Miya's Avatar
Tak Miya Tak Miya is offline
Officially Welcomed to the 'Fest
Location: JAPAN
 
Join Date: Oct 2015
Posts: 103
Mein Auto: F34 320i
Quote:
Originally Posted by tom2325 View Post
Hi,
This is the information for guys who have a plan to retrofit Automatic trunklid.

I have failed to flash HKFM_LS module.

The process is as follows.

1) Done Automatic trunklid retrofit to my Activehybrid 5.
2) I added 316 to FA Salapa.
3) I could not inject cafd by using the 'Detect CAF for SWE' button because there is no cafd file maching swfl_00000D9A_006_007_000.
I have never got this error when detecting CAF.


So, I decided to update the SWE file of HKFM_LS module in order to inject latest cafd file.

4) I tried flashing HKFM_LS by E-SYS as instructed in zkiifreak's manual.
5) I got erorr when calculating TAL. This is the first error.
I can not figure out but I continued my work because SME2 module may be no relevant to HKFM_LS.


5) Checked only HKFM_LS on the ECU list of TAL-Processing.
6) I got second error when executing TAL flashing HKFM_LS.


I think the causes of this error may be;
1. Flashing by modified FA caused confusion.
2. Retrofitted HKFM_LS module is older than my F10, so E-Sys could not inject latest cafd or firmware into the module.

I can not figure out the confusion of using modified FA, so I will try the another HKFM_LS module which has the latest SWFL file.

Will be reported soon.
Hi Tom

I & U are on the same boat probably.

Refer my experience "HKFM module flashing procedure" as below for your reference.

https://www.bimmerfest.com/forums/sho...98&postcount=6

And let me suggest that you may change language setting of e-sys from Germany to English for easy understanding unless you are Germany...

option --> setting --> language

Thanks
__________________

F34 320iGT 2013 OCT manufactured by Dingolfing , Germany
Reply With Quote
  #34  
Old 01-23-2017, 03:41 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Tried to update CID & HU_CIC ecus with esys 3.2.8.1 and got following errors also my navigation is greyed out if i press nav button it says currently unavailable can anyone help please

Click image for larger version

Name:	20170123_095912.jpg
Views:	460
Size:	57.9 KB
ID:	587573Click image for larger version

Name:	20170123_100527.jpg
Views:	404
Size:	52.5 KB
ID:	587574

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #35  
Old 01-23-2017, 05:51 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by flashdash View Post
Tried to update CID & HU_CIC ecus with esys 3.2.8.1 and got following errors also my navigation is greyed out if i press nav button it says currently unavailable can anyone help please

Attachment 587573Attachment 587574

Sent from my SM-G935F using Tapatalk
This "SVK-Ist does not match expected SGBMIDs for ecu..." means you have chosen an improper I-Step Shipment when you made your SVT Target (SVT_soll).
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #36  
Old 01-23-2017, 05:53 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by shawnsheridan View Post
This "SVK-Ist does not match expected SGBMIDs for ecu..." means you have chosen an improper I-Step Shipment when you made your SVT Target (SVT_soll).
How can I revert back to standard is this possible I saved all data, any help appreciated

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #37  
Old 01-23-2017, 06:06 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by flashdash View Post
How can I revert back to standard is this possible I saved all data, any help appreciated

Sent from my SM-G935F using Tapatalk
You picture shows flash went for 46 minutes before faling...I don't think there is any turning back. You need to properly flash it, using correct I-Step Shipment of car.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #38  
Old 01-23-2017, 10:11 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by shawnsheridan View Post
You picture shows flash went for 46 minutes before faling...I don't think there is any turning back. You need to properly flash it, using correct I-Step Shipment of car.
I double checked the I shipment of my car it is f010-10-09-524 but still getting the same error, any possibility you can do remote access to fix, I Dont mind paying

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #39  
Old 01-23-2017, 10:16 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by flashdash View Post
I double checked the I shipment of my car it is f010-10-09-524 but still getting the same error, any possibility you can do remote access to fix, I Dont mind paying

Sent from my SM-G935F using Tapatalk
In SVT_soll (Target), does HWEL show as Balck, or Red / Blue?
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #40  
Old 01-23-2017, 10:27 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by shawnsheridan View Post
In SVT_soll (Target), does HWEL show as Balck, or Red / Blue?
Black. I dont seem to have a CAFD under HU_CIC and cannot seem to code one in either

Sent from my SM-G935F using Tapatalk

Last edited by flashdash; 01-23-2017 at 10:31 AM.
Reply With Quote
  #41  
Old 01-23-2017, 10:37 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Well, that confirms I-Step shipment is correct, so now I am at a loss as to why you have "SVK-Ist does not match expected SGBMIDs for ecu..." in first place.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #42  
Old 01-23-2017, 10:39 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by shawnsheridan View Post
Well, that confirms I-Step shipment is correct, so now I am at a loss as to why you have "SVK-Ist does not match expected SGBMIDs for ecu..." in first place.
I managed to update my KOMBI, and EGS fine on the hu_cic I get error and also on cid, problem now is,my navigation says unavailable also now my car is,saying battery low ,Recharge even though I've charged battery and registered a new battery using diagnostic tool, wish I never messed with the I drive

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #43  
Old 01-23-2017, 10:41 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Does CIC and CIC have CAFD with Green Dot? Are they codeabale?
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #44  
Old 01-23-2017, 10:51 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by shawnsheridan View Post
Does CIC and CIC have CAFD with Green Dot? Are they codeabale?
CAFD is missing in CIC I cannot code or add CAFD always gives error

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #45  
Old 01-23-2017, 10:55 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,263
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by flashdash View Post
CAFD is missing in CIC I cannot code or add CAFD always gives error

Sent from my SM-G935F using Tapatalk
Well, you you will need to try flashing CIC again. I would start over, make new Flash TAL and run it for CIC only.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #46  
Old 01-23-2017, 10:57 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by shawnsheridan View Post
Well, you you will need to try flashing CIC again. I would start over, make new Flash TAL and run it for CIC only.
Ok thanks will try tomorrow

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #47  
Old 01-24-2017, 12:38 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by shawnsheridan View Post
Well, you you will need to try flashing CIC again. I would start over, make new Flash TAL and run it for CIC only.
If I wanted to flash back to original factory shipment state what version psdzdata would I need any ideas

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #48  
Old 01-24-2017, 03:13 AM
milkyway's Avatar
milkyway milkyway is offline
Officially Welcomed to the 'Fest
Location: OWL, Germany
 
Join Date: Jan 2013
Posts: 1,063
Mein Auto: F10 M5
Hello!

WDBI_CPS in HU_CIC means WriteDataByIdentifier_CodierPrüfstempel. E-Sys wasn't able to write the correct VIN into the Head Unit. Normally you will get those problems when your VO has a wrong VIN inside or anything else. It seems that E-Sys stopped the flash procedure during the cdDeploy (WDBI_CPS is an error for cdDeploy). Please mark the event box in folder logs in TAL processing - then you can see a little bit more what's happen during the flash procedure.

SVK errors by flashing CID is normal when your CID is from 2010 and/or the first half of 2011. It's one of the problem E-Sys has with CIDs (remember the problems with cdDeploy with corrupted CAFD in CID).

CU Oliver
__________________
BMW F30 330e Hybrid 2016 in tansanit blue, cohibabrown for every day (09/2019 G20 330e in tanasnit 2 blue, all in )
Jaguar XK8 Cabrio, 2006, black, 20" for the summer time
BMW M4 F83 Cabrio competition in black for the wife
Reply With Quote
  #49  
Old 01-24-2017, 03:15 AM
flashdash flashdash is offline
Registered User
Location: GB
 
Join Date: Jan 2017
Posts: 40
Mein Auto: 2010 bmw 535d m sport F10
Quote:
Originally Posted by milkyway View Post
Hello!

WDBI_CPS in HU_CIC means WriteDataByIdentifier_CodierPrüfstempel. E-Sys wasn't able to write the correct VIN into the Head Unit. Normally you will get those problems when your VO has a wrong VIN inside or anything else. It seems that E-Sys stopped the flash procedure during the cdDeploy (WDBI_CPS is an error for cdDeploy). Please mark the event box in folder logs in TAL processing - then you can see a little bit more what's happen during the flash procedure.

SVK errors by flashing CID is normal when your CID is from 2010 and/or the first half of 2011. It's one of the problem E-Sys has with CIDs (remember the problems with cdDeploy with corrupted CAFD in CID).

CU Oliver
Is there anything I can do to rectify this issue as my navigation isn't working, also before flashing I checked the vin and it matched

Sent from my SM-G935F using Tapatalk
Reply With Quote
  #50  
Old 01-24-2017, 03:21 AM
milkyway's Avatar
milkyway milkyway is offline
Officially Welcomed to the 'Fest
Location: OWL, Germany
 
Join Date: Jan 2013
Posts: 1,063
Mein Auto: F10 M5
Hello!

1.) check the FSCs inside the CIC
2.) attach the picture from the SVT_IST/SOLL calculation
3.) reflash the CIC with the existing TAL

CU Oliver
__________________
BMW F30 330e Hybrid 2016 in tansanit blue, cohibabrown for every day (09/2019 G20 330e in tanasnit 2 blue, all in )
Jaguar XK8 Cabrio, 2006, black, 20" for the summer time
BMW M4 F83 Cabrio competition in black for the wife
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:45 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.