2008 BMW 535i, E60 LCI - Fuel Pump Issue - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)

E60 / E61 (2004 - 2010)
BMW 5-Series E60 Sedan was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E61 wagon followed shortly there after. The E60/E61 5 series is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2020, 02:52 PM
ccce60 ccce60 is offline
Registered User
 
Join Date: Jan 2019
Posts: 5
Mein Auto:
2008 BMW 535i, E60 LCI - Fuel Pump Issue

If I let my e60 sit for 8+ hours after driving it, I can get back in and have no issues. However, if I drive it and come back less than an hour later, I always get a fuel pump error message on my iDrive screen. It says continued driving is ok but I need to have the car serviced.

Sometimes this message will go away while I am driving if my foot is not on the gas. If I start to press the gas again, the message comes right back.

It is peculiar. The Car doesn't take an abnormally long amount of time to start up but it's also not overly quick. I saw this could determine if it is the high pressure fuel pump.

I'm not sure what to do. It has done weird things where in the past if I floor it, an engine light comes on and the car starts to misfire. To correct this, I have had to change the spark plug and coil in whichever cylinder is misfiring. Aside from that, it runs fine. I just know not to floor it.

Please help. I can't figure out what the issue is. I can't tell if it is a fuel injector, a fuel pump, or the sensor. Any help or advice is greatly appreciated!

Thanks
Reply With Quote
  #2  
Old 03-24-2020, 07:38 PM
plus1111 plus1111 is offline
Officially Welcomed to the 'Fest
Location: ohio
 
Join Date: Jun 2014
Posts: 184
Mein Auto: 2008 535xi
You need to read the codes. It could be the HPFP but the low pressure pump in the tank or the low pressure sensor could also cause issues. Any misfiring?
__________________
Hobby mechanic doing my own work for 50 years or so.
We have a 2006 530xi Touring and a 2008 535xi sedan.
I can't really remember the last time I took a car to a repair service.
Reply With Quote
  #3  
Old 03-29-2020, 08:21 PM
ccce60 ccce60 is offline
Registered User
 
Join Date: Jan 2019
Posts: 5
Mein Auto:
Quote:
Originally Posted by plus1111 View Post
You need to read the codes. It could be the HPFP but the low pressure pump in the tank or the low pressure sensor could also cause issues. Any misfiring?

Hey. Thanks for the reply. See the attached. One pic shows my car info. And the other shows the current codes that has I was able to scan (last time I scanned my car was probably a month ago)

Please help with what you think it could be.

Thanks
Attached Thumbnails
Click image for larger version

Name:	1465D8C7-71EB-4B2A-85B4-C31BD342B636_1585538469791.png
Views:	13
Size:	126.2 KB
ID:	886877   Click image for larger version

Name:	BE614A4F-FFD6-44C6-AC1E-28D0D5E7FED5_1585538475969.png
Views:	15
Size:	105.9 KB
ID:	886879  
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 03-30-2020, 06:10 AM
scottalexander scottalexander is offline
Officially Welcomed to the 'Fest
Location: PA
 
Join Date: Oct 2017
Posts: 411
Mein Auto: 2010 bmw 528i
How many miles are on the car?

Has the fuel pump ever been replaced?
Reply With Quote
  #5  
Old 03-30-2020, 08:16 AM
ccce60 ccce60 is offline
Registered User
 
Join Date: Jan 2019
Posts: 5
Mein Auto:
Quote:
Originally Posted by scottalexander View Post
How many miles are on the car?

Has the fuel pump ever been replaced?
There is 130k on the car. ISTA shows kilometers instead of miles. I've only owned it since it had 114k miles on it. From what I saw on the car fax report, it doesn't say that the fuel pump was ever replaced.
Reply With Quote
  #6  
Old 03-30-2020, 10:03 AM
scottalexander scottalexander is offline
Officially Welcomed to the 'Fest
Location: PA
 
Join Date: Oct 2017
Posts: 411
Mein Auto: 2010 bmw 528i
If the fuel pump was not replaced, its fair to say the fuel filter was also not replaced.

After looking at your 2aaf fault code on the BMW fault code look up web site it says:

1.) Run plausibility check on signal from low-pressure sensor by comparing DME monitored data (BMW Tester) with actual measurement from pressure gauge
2.) If the pressure measurements for DME and pressure gauge match, replace the EKP

You've got ISTA. Do the fuel diagnostic check routine.

The past 3 people I've witnessed that have this iDrive message flash up, the fuel pump was malfunctioning. Their symptoms were as followed:


o the car cuts out every now and then and you have to start it back up
o INPA or ISTA are throwing fuel cut off misfire codes
o when the gas tank is at a quarter tank the car starts misfiring and it starts behaving very strange. Then when you fill the tank all the way up the problem goes away
o does the car start dying at half the tank? if this happens possibly have a bad fuel sender assembly which is on the driver side. Basically what that does is once the car reaches half a tank of gas it will start pushing all the fuel from the driver's side of the gas tank to the passenger side.
o Long crank when starting
o At high RPM the engine sputters
o Error message for fuel pump appears on iDrive
o A faulty fuel pump can cause poor engine performance and hard starting problems. When it fails completely, you may be left with an engine that doesn't start. If you suspect your fuel pump has failed, you can confirm the fuel pump has received the correct voltage when commanded ON by the fuel pump relay using a digital volt ohm-meter (DVOM)
o If the correct voltage is present, but the pump does not activate, it is likely faulty. Use the DVOM in conjunction with a wiring diagram to determine the correct terminals for testing.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.