Z4 help idle lunges and won't rev - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-04-2013, 03:16 PM
carolinadisney carolinadisney is offline
Registered User
Location: us
 
Join Date: Mar 2013
Posts: 2
Mein Auto: z4
help idle lunges and won't rev

Help, My 2003 z4 battery died. I charged it and started the car but it will only lunge in idle and engine won't rev at all. strong gas smell coming fron exhaust.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-05-2013, 09:51 AM
carolinadisney carolinadisney is offline
Registered User
Location: us
 
Join Date: Mar 2013
Posts: 2
Mein Auto: z4
Ok, I unplugged battery from the car and continued to charge it. Today I hooked it back up and the car ran fine except the service engine soon light is on. How do I wipe the codes so I can see if there really is something wrong or if this was just from the battery having a low charge?
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.