N63 Turbo Coolant Lines leaking, e70 5.0i MSport - Page 3 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #51  
Old 06-21-2017, 11:13 AM
Beachcomber Beachcomber is offline
Registered User
Location: New Jersey
 
Join Date: Jul 2015
Posts: 21
Mein Auto: 2012 x-5
Click image for larger version

Name:	177169.jpg
Views:	189
Size:	96.3 KB
ID:	601785
Reply With Quote
Sponsored Links
Advertisement
 
  #52  
Old 06-21-2017, 11:15 AM
BadBoyBeltran BadBoyBeltran is offline
Registered User
Location: Chicago
 
Join Date: Mar 2016
Posts: 93
Mein Auto: 2011 BMW 550i GT
N63 Turbo Coolant Lines leaking, e70 5.0i MSport

I think it depends on the engine. Which engine do you have?

Ya the right intake plenum has to come off if you want to check and change that T-Connector.

You should have 4 hoses. 2 from the main coolant line and 2 from the aux turbo cooler motor. (This is assuming we have the same engine)


Sent from my iPhone using Bimmerfest
__________________
2011 550i GT
2013 1199R
2011 RSV4 SE
Reply With Quote
  #53  
Old 06-21-2017, 11:18 AM
BadBoyBeltran BadBoyBeltran is offline
Registered User
Location: Chicago
 
Join Date: Mar 2016
Posts: 93
Mein Auto: 2011 BMW 550i GT
N63 Turbo Coolant Lines leaking, e70 5.0i MSport

Quote:
Originally Posted by Beachcomber View Post


Yes there are 4 lines. Two each coming from the 2 Item 7s. The aux turbo cooler is item 9 or 10.


Sent from my iPhone using Bimmerfest mobile app
__________________
2011 550i GT
2013 1199R
2011 RSV4 SE
Reply With Quote
Sponsored Links
Advertisement
 
  #54  
Old 06-21-2017, 02:38 PM
Beachcomber Beachcomber is offline
Registered User
Location: New Jersey
 
Join Date: Jul 2015
Posts: 21
Mein Auto: 2012 x-5
Got it thanks
Reply With Quote
  #55  
Old 06-23-2017, 05:41 PM
Beachcomber Beachcomber is offline
Registered User
Location: New Jersey
 
Join Date: Jul 2015
Posts: 21
Mein Auto: 2012 x-5
No longer replacing coolant lines. Just found out I need to replace both turbos due to wastegate rattle. Not surprising since I have 106K miles on truck. Dealer wanted 7K for replacing turbos including new coolant lines (not bad since the parts alone are close to 5K. I decided to trade in and buy another X-5. This time I wont hold past 100K warranty.
Reply With Quote
  #56  
Old 10-18-2017, 04:39 PM
Tgsmith4845 Tgsmith4845 is offline
Registered User
Location: CA
 
Join Date: May 2013
Posts: 2
Mein Auto: 2006 X5 4.8is
Quote:
Originally Posted by BadBoyBeltran View Post
Hey guys.

So I was still smelling some coolant (could have been left over from the old leak) when I came across a T connector that is full of white and yellow residue (this is a borrowed image from Google to show the location. I was not able to take a good photo since it was under the intake plenum).



Removed the right air box (from the front of the car) and the intake to the turbo and found this. 2 of 3 enlarged part of T connector have broken off inside the hoses (one of the legs that's broken is after I pulled the hoses off). As you can see, the other 2 legs are missing the enlarged part of the nipples. Oh ya, it's plastic and right under the hot turbos !!!



Got a brass T connector from Autozone and replaced it.

The T Connector is part of Hose 17127576363 (Item 7 of the photo below). The hoses are in terrible shape but I did not have extra 3/8" silicone hose laying around so I could not replace it yet. The sides of the T go to the engine heads and the main part of the T is connected to the hoses going to to right intercooler. I did not dig on how accessible the hoses to the heads are, but I will next weekend. I did not want to fiddle and start pulling stuff when I know I do not have hose to replace it.



More Photos from AMP:

https://www.google.com/amp/s/bmwtech...e-leaking/amp/

Also, my auxiliary turbo coolant pump was also bad so I replaced that. There is a recall on this (#11V-521 Service Bulletin 11 08 11) but it excludes my car. It is kinda weird on which ones are bad or are good since the recall for the F07 says anything through 2/11 are affected, but the manufacturing dates on the last 2 pumps overlap. I think it is based on the connector, but I will write a claim to BMWNA regardless.



It is Item 9.



It was a fairly easy job. Removed the small coolant reservoir (this is the one for the intercoolers), disconnected some hoses (all have quick disconnects aside from one, which goes to the aux turbo coolant pump). Took it for a Test Drive, got back home and turned off the engine, and the pump was purring which was music to my ears !!!




Sent from my iPhone using Bimmerfest mobile app
Hi badboy, how difficult was it to replace the turbo aux coolant pump? Mine (2013 X5 N63) is making quite a racket now after I shut off the engine, so I think it’s toast. It’s also throwing a “hot engine” fault on restart, which goes out after 15 seconds or so of normal eng8ne running. Time to replace the turbo aux pump. Did you get to it from above or below?

Thanks,
Tim
Reply With Quote
  #57  
Old 11-11-2019, 12:05 PM
[email protected] dtasja316@aol.c is offline
Registered User
Location: New Jersey
 
Join Date: Nov 2019
Posts: 2
Mein Auto: 2013 bmw 650xi Gran Coupe
2013 bmw 650i harness

What is that harness thats connected to the turbo on the right? and where does the harness come from? i just purchased a 2013 bmw 650i gran coupe, and that harness is missing, and i cant seem to find it so i can plug it back into the turbo.
Attached Thumbnails
Click image for larger version

Name:	Inkedturbo_LI.jpg
Views:	17
Size:	135.2 KB
ID:	871795  

Last edited by [email protected]; 11-11-2019 at 01:15 PM. Reason: want to attach a picture if possible
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:43 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.