Instrument cluster display issues - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-05-2020, 09:06 AM
njenkinson njenkinson is offline
Registered User
 
Join Date: Nov 2019
Posts: 4
Mein Auto:
Instrument cluster display issues

Iíve been the owner of my 2009 328i xDrive for a couple months now. I havenít been able to figure out this issue still. Any help is appreciated. So on the instrument cluster where you can set what it displays: mpg, mph, temperature, the time, oil level, etc. I also can not control the menus using the BC button. Could it just be a coding error? Do I need a new cluster?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-05-2020, 10:52 AM
Zeichen311's Avatar
Zeichen311 Zeichen311 is online now
Lost but making good time
Location: Here, there, or in transit
 
Join Date: Mar 2011
Posts: 5,212
Mein Auto: '11 335xi 4dr; '03 330Ci
Quote:
Originally Posted by njenkinson View Post
So on the instrument cluster where you can set what it displays: mpg, mph, temperature, the time, oil level, etc. I also can not control the menus using the BC button. Could it just be a coding error?
You wrote "also"--is there an additional problem? Might change the diagnosis.

If the only concern is that the BC control has no effect, my first suspect would be the steering column switch unit. Do all the other stalk-mounted controls operate properly? Turn signals, one-touch lane-change signal, high beams, flash-to-pass, pathway (follow-me-home) lights, ... ? Does the cruise control operate and respond to all commands (increase/decrease set speed, cancel, resume)? How about the windshield wiper controls?

AFAIK this is not a symptom of a coding problem.
__________________
2011 335xi Individual 6MT - Azurite Black Metallic / Oyster & Black / Anthracite Maple + all the good stuff
2003 330Ci Sport 5MT - Black Sapphire Metallic / Natural Brown / Myrtle + the important stuff (+ go-fast stuff)

BMW CCA
Reply With Quote
  #3  
Old 02-05-2020, 11:10 AM
njenkinson njenkinson is offline
Registered User
 
Join Date: Nov 2019
Posts: 4
Mein Auto:
well I just realized I never put my first issue, thank you for pointing that out. The screen that displays the mph, mpg, etc will just randomly cycle through like it's thinking on its own. I don't touch anything and it doesn't start doing it until about 10 minutes into driving. In regard to your question, all other stalk mounted controls DO work properly.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 02-10-2020, 03:10 PM
satyaban satyaban is offline
Officially Welcomed to the 'Fest
Location: Baltimore, Md USA
 
Join Date: Oct 2015
Posts: 258
Mein Auto: 2008 328xi
This is a shot in the dark but has the battery been replaced recently and does your car have a problem with the clock and date being incorrect or not there to be read?
Reply With Quote
  #5  
Old 02-10-2020, 04:52 PM
Mark963 Mark963 is offline
Officially Welcomed to the 'Fest
Location: Iowa
 
Join Date: May 2018
Posts: 132
Mein Auto: 2011 E90 328xi
Sorta sounds the button/wiring might be shorted and just occasionally opens up and it flips between the settings on it's own. Is there any chance that holding the button down makes it stop when it starts cycling on its own?
Reply With Quote
  #6  
Old 02-10-2020, 05:30 PM
njenkinson njenkinson is offline
Registered User
 
Join Date: Nov 2019
Posts: 4
Mein Auto:
Okay so I'm gonna answer both of you in this one, I am not sure about the battery being replaced. I haven't replaced it and I'm not sure when the previous owner last did. The clock and date will randomly change while I'm driving. It cycles through that too. To answer the other question, no. Holding down the BC button does not stop it from cycling. Thanks a ton guys
Reply With Quote
  #7  
Old 02-10-2020, 09:57 PM
satyaban satyaban is offline
Officially Welcomed to the 'Fest
Location: Baltimore, Md USA
 
Join Date: Oct 2015
Posts: 258
Mein Auto: 2008 328xi
One more ?

Does the clock malfunction affect both the clock in the dash as well as the radio dial? My clock stops sometimes and the date will not change as well. When my clock fails it goes more or less blank except for the colons and the date holds when it stopped. It seemed like it started happening after I bought a new battery and had it installed by professionals.
I hope you work it out I just keep on resetting though.

Last edited by satyaban; 02-10-2020 at 09:59 PM. Reason: Punctuation and grammar
Reply With Quote
  #8  
Old 02-11-2020, 08:58 AM
Jim328 Jim328 is offline
Officially Welcomed to the 'Fest
Location: Golden CO
 
Join Date: Apr 2019
Posts: 165
Mein Auto: 2008 328xi
I just replaced my battery.
The clock had forgotten the time twice over a month or 2.
The "welcome" lights stopped working.
And then I got an error message; CCID-415 (Increased battery discharge).

Bentley Manual says:
Increased battery discharge when stationary. Electrical (JBE) consumers may be temporarily switched off. It may be necessary to reset date and time. If fault occurs repeatedly, have problem checked by your BMW Service.

Installed new H8 AGM 95Ah battery, used Carly to let the car know.
No further issues for me.

This isn't quite what OP is experiencing, but these vehicles consume LOTS of power from the battery.

Satyaban,
"installed by professionals" - scary. hahahha
If they didn't "register" the replacement battery, it may not be getting properly charged.
Forgetting the date/time "seems" to be an early indicator of low voltage.

njenkinson,
You said "holding the BC button does not stop it from cycling".
Do you mean the button on the end of the stalk, or the up/down switch on the face of the stalk?
The up/down on the face is what (normally) cycles through the displays.
Next time it cycles, try the up/down button to see if that'll stop it.
That would make me lean toward something being amiss with that particular switch, although that seems odd.

I had a Range Rover; when the battery started to go, the first warnings would be transmission errors. What the heck??
Then every light on the dash would come on.
At no point did the RR ever say, "battery is failing".
Had to goto forums to find that out.
__________________
2008 328xi
BMW CCA
Reply With Quote
  #9  
Old 02-11-2020, 10:50 AM
njenkinson njenkinson is offline
Registered User
 
Join Date: Nov 2019
Posts: 4
Mein Auto:
Jim- I will definitely try holding the switch part next time it happens, and I'll look into getting a new battery and having it coded properly.
I haven't received any error codes and these are the only things that are being affected that I can see. I wish I could upload a video of this issue.
Satyban- it has affected both clocks in the vehicle, on the radio and on in instrument cluster.
Thanks everyone who is responding!

Last edited by njenkinson; 02-11-2020 at 10:52 AM.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.