E70 rough idle - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 07-11-2019, 08:00 PM
LeeroyBrown LeeroyBrown is offline
Registered User
Location: Wisconsin
 
Join Date: Mar 2018
Posts: 12
Mein Auto: 08 X5
E70 rough idle

In my 08 3.0si I recently started having weird startup issues and occasionally at idle the RPM's would dip down or jump. Idle is like 550 ish used to be closer to 650-725 when running good.

Codes are
P0015
P0016
P2A87
P2AA0
P2A9A

Parts new as of last year are camshaft position sensor, both Vanos sensors, All plugs and coils, CCV valve, intake seals, both Intake Manifold Flap Adjuster Units, I have also ran a smoke test to look for vacuum leaks.

Sometimes when it's hot I'll get a long crank time before it starts.
I'm leaning towards injector issues maybe? If I get new injectors do they have to be coded?

Last edited by LeeroyBrown; 07-11-2019 at 09:31 PM.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:04 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.