Valvetronic VVT EML Limp Home Issue Codes 285E 2865 - BMW e46 318i 2002 [FIXED!!!!!] - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > Bimmerfest Regional > Regional Forums > Australia

Australia

Reply
 
Thread Tools Display Modes
  #1  
Old 04-12-2016, 09:13 PM
Pat7 Pat7 is offline
Registered User
Location: Sydney, Australia
 
Join Date: Apr 2016
Posts: 3
Mein Auto: BMW e46 318i 2002
Valvetronic VVT EML Limp Home Issue Codes 285E 2865 - BMW e46 318i 2002 [FIXED!!!!!]

Hi Everyone

I just want to share an experience with you I had with my BMW, hopefully it can be of much help to you guys and fix your problem as this particular issue absolutely did my head in! Sorry for the long explanation as I thought being detailed would make understanding this a lot easier.

Basically what happened my car displayed this EML light on my dash, had know idea what it was and noticed a loss in power basically half acceleration, I pulled over and turned the car off and checked the owner’s manual and it said ‘Engine Management Light’ and to get the car checked! When I turned the car back on the light never came back and the car was back to normal for a few days.

Now for a few weeks this problem kept happening once every few days, very intermittent, and sometimes loss complete acceleration which was very dangerous must I say especially when you’re driving on the highway and having to quickly pull over, luckily I always had a chance to pull over to the side when this happened. The EML light then started to trigger within 5 minutes of starting the car from cold start, when I turned the car off and back on again it would disappear and not return all day.

Anyways I decided to get a friend’s OBDII reader to scan it for codes. I got 2 codes, P1043 - Internal VVT Control Module Error & P1062 - VVT Limp Home Request. I went to see a BMW Dealer which offered no help really, they said I would have to book in and they would have to diagnose and could take all day, very expensive this was going to be so I thought I’ll keep researching.

So my first step was to understand this EML & VVT – Valvetronic system, went on a lot of forums like this but couldn’t find any clear answer, a lot of people were referring to the valvetronic motor, Eccentric Shaft & the VVT ECU. So what I started to do was check and clean all connections relating to these with electrical contact cleaner, unplugged the eccentric shaft and checked to make sure no oil was leaking in, because the problem I had was so intermittent I was pretty sure the valvetronic motor and eccentric shaft were fine, so it must be the VVT ECU.

After more research I decided to spend $70 on Ebay and purchase my own BMW specific OBD reader and rescan the car as apparently the codes I had got were generic ones and not BMW specific, thankfully I did and got these 2 codes, 285E – Variable Valve Gear – Control Unit Internal Fault & 2865 – Variable Valve Gear – Power Limitation in Limp Home Mode.

I then understood that Valvetronic doesn’t actually work till the car gets to a certain running temperature from a cold start, when it does it transitions from Throttle Body which is used to start the car then runs off Valvetronic. Now knowing this info my EML light was triggering in this transition and putting the car in limp home mode everytime, it was obvious too as the car splatters and drops revs for a moment everytime.

After a quote from BMW for each of these things to replace I was blown away on how much they were, it was nearly $3000 to get a new Valvetronic Motor, Eccentric Shaft & VVT ECU plus labour! And they said they weren’t 100% if it would fix the problem. My advice is stay away from BMW.

Now in my head I was convinced that the Valvetronic Motor & Eccentric Shaft were in good working order so I turned towards the VVT ECU as my first step of action, I went on Ebay and luckily I found a lot of used Control Units for sale, all I had to do was pull my old one out and get the BMW part number off the back of it to match up. So I purchased a used one with the same part number for $125 which came off a very similar car to mine that was in good working order.

So after a week of anxiously waiting for this part to arrive I finally got it, I replaced my old VVT ECU with the new one, plugged in my OBD reader to live stream the Valvetronic system to see what was happening, noting also I wasn’t really sure if I had to re-program the car for this new ECU.

Moment of truth, I turned the car on and waited and waited for the transition and YES YES YES, EML did not trigger and car transitioned perfectly to Valvetronic, obviously no re-programming was required for the new Control Unit, just a straight swap over, now because I did have a day or two when I had no EML light trigger, I would only be 100% convinced the problem was fixed if it didn’t happen for a whole week which awesomely enough it didn’t, YAY!

So it’s been over a month now since I changed the VVT ECU and the car has been good, sorry again for the long detailed explanation, I felt like I had to share this experience with you guys as a lot of these forums helped me with this issue, I did take a gamble in the end and thankfully it paid off and fixed this stupid issue, anyways hope this all helps…

Cheers
Attached Thumbnails
Click image for larger version

Name:	IMG_1988.jpg
Views:	798
Size:	53.8 KB
ID:	558818   Click image for larger version

Name:	IMG_2094.jpg
Views:	564
Size:	129.7 KB
ID:	558819   Click image for larger version

Name:	IMG_2097.jpg
Views:	588
Size:	89.9 KB
ID:	558820  
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-30-2019, 05:32 AM
rustyx rustyx is offline
Registered User
Location: NL
 
Join Date: Mar 2013
Posts: 5
Mein Auto: E91
Congrats and thanks for sharing.

Do you have a write-up on how to replace the VVT control unit? Or at least where it's located

== EDIT == Oh I think I see it, it the right-side water box

Last edited by rustyx; 09-30-2019 at 06:13 AM.
Reply With Quote
  #3  
Old 09-30-2019, 06:11 PM
Pat7 Pat7 is offline
Registered User
Location: Sydney, Australia
 
Join Date: Apr 2016
Posts: 3
Mein Auto: BMW e46 318i 2002
Hi, I dont have a write up sorry, i'm not really sure either on your model but mine was located at the rear of the engine bay/passenger side in the corner area, next to the main fuse box as far as i can remember, i looked at your link though and that is definitely it, its held in by this bracket which you need to unscrew and then just disconnect the module while the car is off (I may have disconnected the battery though but i cant remember - not sure if this would actually matter). Replace that VVT module if you received those codes 285E & 2865, probably your first cheapest option, mine was plug and play, the VVT part numbers need to match up too dont forget. All the best
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > Bimmerfest Regional > Regional Forums > Australia
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.