Rear windshield washer fluid - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 04-18-2018, 07:32 PM
wilreyca wilreyca is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2008
Posts: 123
Mein Auto: 2001 330XI, 2007 X3
Rear windshield washer fluid

Hello,

I have a 2007 X3 on which the rear windshield washer fluid stopped working. The windshield wiper still works but not fluid comes out. Today, as troubleshooting I swapped the cables of the two pumps connected located at the reservoir. Since the front windshield fluid has being working, I was expecting that the rear one would start working and the front one would stop working. That didn't happened. What ended up happening its that by pressing lever to get the fluid in the rear, the fluid came in the front, and when I pulled the lever to get fluid in the front nothing came out.

Is my logic her wrong? shouldn't the fluid be coming from the rear if the cables of the two pumps are swapped?
__________________
01 330 XI | Green | Black | Cold Package | Premiun Sound |
07 X3 3.0 SI | Black Saphire | Terracotta | NAV | Premiun Package | Cold Package | Xenon |
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-18-2018, 07:46 PM
AlphaBetaX5's Avatar
AlphaBetaX5 AlphaBetaX5 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles CA
 
Join Date: Oct 2016
Posts: 850
Mein Auto: X5 e70 3.0i
You should swap the PUMPS, not cables!

Of course a broken pump will not work even if you try powering it up using the front cable.


Replace both pumps. They’re are cheap. Euro pumps on ebay or Amazon 2 for $20!





Sent from my iPhone using Tapatalk
Reply With Quote
  #3  
Old 04-19-2018, 11:41 AM
EnjoyingLife EnjoyingLife is offline
Officially Welcomed to the 'Fest
Location: Minnesota
 
Join Date: Oct 2017
Posts: 208
Mein Auto: 2008 X3
[QUOTE=AlphaBetaX5;12472718]You should swap the PUMPS, not cables!

Of course a broken pump will not work even if you try powering it up using the front cable.


Replace both pumps. They’re are cheap. Euro pumps on ebay or Amazon 2 for $20!


I TOTALLY agree with AlphaBetaX5, that switching cables will not do anything if the pump is bad and with how cheap the pumps are, it is easier to just replace.
__________________
2008 BMW X3 Sports Package,
Premium Package, Cold Weather Package.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 04-19-2018, 05:25 PM
dukedkt442 dukedkt442 is online now
Officially Welcomed to the 'Fest
Location: Hudson Valley/LI, NY; Treasure Coast, FL; OBX, NC.
 
Join Date: Feb 2013
Posts: 2,973
Mein Auto: X3, 442, S15, Silverado
They're generic pumps available at Autozone or Advance. You may have 3... mine does IIRC.
__________________
Reply With Quote
  #5  
Old 04-26-2018, 05:52 AM
BimmurBrothor's Avatar
BimmurBrothor BimmurBrothor is offline
BeeemerBro
Location: Savannah GA
 
Join Date: Jun 2017
Posts: 2,531
Mein Auto: X3 M54 150k
From my expirence the slightest kink in the tube/line will cause the flow to come to an end and appear that the pump has gone bad.
__________________
[FONT="Arial Black"]

Last edited by BimmurBrothor; 04-26-2018 at 05:54 AM.
Reply With Quote
  #6  
Old 04-26-2018, 01:44 PM
Yomama Yomama is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Sep 2012
Posts: 416
Mein Auto: 2006 X3 3.0I
You need to swap the pumps. The hoses are still connected to the rear or front. As everybody else has said, the pumps are cheap
Reply With Quote
  #7  
Old 04-26-2018, 03:23 PM
DangermouseX3 DangermouseX3 is offline
Officially Welcomed to the 'Fest
Location: Atlanta GA
 
Join Date: Aug 2013
Posts: 957
Mein Auto: 2007 X3, 2008 X3
In possibly related news, are your rear passenger carpets now damp?
__________________


07 X3 3.0Si - AT - Black with tan leatherette interior - 141k miles
08 X3 3.0Si - AT - Black with black leather interior - 121k miles
Reply With Quote
  #8  
Old 08-28-2019, 08:45 AM
RED_5 RED_5 is offline
Registered User
 
Join Date: Dec 2018
Posts: 10
Mein Auto:
My rear washer fluid recently stopped working as well.
Are these easy to replace and does someone have a link to a pump?
Reply With Quote
  #9  
Old 08-28-2019, 09:36 AM
Q4's Avatar
Q4 Q4 is offline
Officially Welcomed to the 'Fest
Location: Cincinnati
 
Join Date: Sep 2015
Posts: 892
Mein Auto: 2008 x3
https://smile.amazon.com/gp/aw/d/B00...b_b_asin_title

https://smile.amazon.com/gp/aw/d/B00...b_b_asin_title

https://smile.amazon.com/gp/aw/d/B00...b_b_asin_title

https://smile.amazon.com/gp/aw/d/B00...b_b_asin_title

You'll have to figure out which one you need.

One for windscreen
One for rear window
One for headlights if so equipped
__________________
Tim
Cincinnati

Reply With Quote
  #10  
Old 08-28-2019, 11:39 AM
RED_5 RED_5 is offline
Registered User
 
Join Date: Dec 2018
Posts: 10
Mein Auto:
Great, Thanks!
Reply With Quote
  #11  
Old 08-29-2019, 09:59 AM
Rustynuts Rustynuts is offline
Officially Welcomed to the 'Fest
Location: DC Area
 
Join Date: Apr 2009
Posts: 676
Mein Auto: 16 X1 M-Sport
One other tip. NEVER run any fluid like Rain X through your system. It can eat pumps somehow. Happened to me awhile ago.
Reply With Quote
  #12  
Old 08-30-2019, 08:20 PM
mitch500 mitch500 is offline
Officially Welcomed to the 'Fest
Location: esmonton canada
 
Join Date: Mar 2018
Posts: 141
Mein Auto: 1997 e36 m3 s54
I did the same with swapping connectors. I couldn't wrap my brain around what was happening. I ended up replacing both pumps and all was good. Pumps are dirt cheap
Reply With Quote
  #13  
Old 09-04-2019, 07:05 AM
BimmurBrothor's Avatar
BimmurBrothor BimmurBrothor is offline
BeeemerBro
Location: Savannah GA
 
Join Date: Jun 2017
Posts: 2,531
Mein Auto: X3 M54 150k
Let's hope you don't have an experience like this one I had...https://www.bimmerfest.com/forums/sh...php?p=12805375

Sent from my SM-G531H using Tapatalk
__________________
[FONT="Arial Black"]
Reply With Quote
  #14  
Old 09-04-2019, 07:42 PM
abscate abscate is online now
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: May 2014
Posts: 1,390
Mein Auto: 2006 BMW X3... VOLVO... V
You have to put rear washer fluid I'm the car rear reservoir and front washer fluid in the front. If you reverse this, the car sucks the fluid off the glass and it overflows
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:16 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.