$660 for a battery, WTF! - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series & 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion of BMW's 4th generation E65/E66 7 Series flagship. The E65 generated much controversy, due to its radical styling and iDrive user difficulties. Nonetheless, the E65 broke records to become the best-selling 7-series iteration ever, especially after its 2005 facelift.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-14-2012, 03:49 PM
samadkins29's Avatar
samadkins29 samadkins29 is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2010
Posts: 3,827
Mein Auto: 2011 535i
Exclamation $660 for a battery, WTF!

Hey guys, I figured I would post my issue/s before taking the car in to get ripped off..... I've done abit of searching on the forums. It looks like people recommend changing the battery for starters. But at the price I was quoted, I want to ask first. So your prolly wondering what my issues are?

My cars electronics shut off while driving, only for a split second. It doesnt happen all the time. The issue first occured last week. But it happened multiple times today. I keep getting random errors - ABS fault, then my power steering shut off, then it says transmission fault, my traction control hasnt been working very well... etc. If I turn off the car and start it later, everything is working fine. I feel like somthing is either shorting or not getting enough power. The car hasnt stalled and seems to drive fine in the split second that the electronics go bonkers. Last wednesday my car refused to start for a minute, I would put in the key and everything looked like it was just shorting out(turning on/off). That only happend once.

I'm abit confused as some days my car drives just fine. But this issue is concerning me. From other threads that I've found, it looks like the battery might be going bad? From the service records, the battery was last repalced in 10/2007 (68k miles). Which means its lasted 4.5 years. Which is odd since its now 4.5 years later.....

Thoughts?
P.S. sorry for any typos
__________________
2011 535i
2003 745li (Sold)


Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-14-2012, 04:15 PM
mikewerks's Avatar
mikewerks mikewerks is offline
Officially Welcomed to the 'Fest
Location: PNW
 
Join Date: Apr 2008
Posts: 298
Mein Auto: 02' 745i
Cant really comment on your drive ability issues although it does sound like battery or alternator. I can tell you 660 for a battery is a ripoff I replaced mine 2 months ago at the dealer for 500 incl install, reprogram and taxes. I just ordered a group 49 AGM battery(deka is the brand) from Autobarn.com for 179 shipped as I am going to use it in our SL600 come spring if spring comes.. Hope that helps
Reply With Quote
  #3  
Old 01-14-2012, 04:18 PM
samadkins29's Avatar
samadkins29 samadkins29 is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2010
Posts: 3,827
Mein Auto: 2011 535i
Yea the dealer gave me some BS "glass bottom" battery or somthing. Not sure how it got to $660($720 with tax). Your pluggin in two cables and doing a reprogram.
__________________
2011 535i
2003 745li (Sold)


Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-14-2012, 04:24 PM
manny187 manny187 is offline
Registered User
Location: vancouver
 
Join Date: Nov 2010
Posts: 46
Mein Auto: 2002 bmw 745i
just put in a new battery in my 2002 bmw 745i, costs me 301 with tax from the dealer
Reply With Quote
  #5  
Old 01-14-2012, 04:42 PM
Guest091814 Guest091814 is offline
Account closed at users request
 
Join Date: Jun 2010
Posts: 3,059
Mein Auto:
Thats is rip off but what do you expect from a Sdealer. I can't see how it's battery either if these things are happening while driving.
Reply With Quote
  #6  
Old 01-14-2012, 04:56 PM
samadkins29's Avatar
samadkins29 samadkins29 is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2010
Posts: 3,827
Mein Auto: 2011 535i
I just reseated the power cables. Ill see if that helps at all.
__________________
2011 535i
2003 745li (Sold)


Reply With Quote
  #7  
Old 01-14-2012, 05:56 PM
Boing745's Avatar
Boing745 Boing745 is offline
the cleanest1
Location: THE SOUTH
 
Join Date: Jun 2009
Posts: 2,632
Mein Auto: E66
i got mine from autozone like 2 years ago for under 300 and i never reprogrammed anything like everyone keeps saying and no issues.
__________________
Reply With Quote
  #8  
Old 01-14-2012, 06:14 PM
hd750Li's Avatar
hd750Li hd750Li is offline
Officially Welcomed to the 'Fest
Location: US
 
Join Date: Jul 2010
Posts: 624
Mein Auto: F02 750Li
Quote:
Originally Posted by mikewerks View Post
Cant really comment on your drive ability issues although it does sound like battery or alternator. I can tell you 660 for a battery is a ripoff I replaced mine 2 months ago at the dealer for 500 incl install, reprogram and taxes. I just ordered a group 49 AGM battery(deka is the brand) from Autobarn.com for 179 shipped as I am going to use it in our SL600 come spring if spring comes.. Hope that helps
+1 deka is the best.
Reply With Quote
  #9  
Old 01-14-2012, 06:16 PM
USALEXUSBMW750's Avatar
USALEXUSBMW750 USALEXUSBMW750 is offline
Little Odessa
Location: Bergen County, NJ
 
Join Date: Oct 2009
Posts: 1,275
Mein Auto: bmw
I remember that Boing, that is strange? maybe your car or battery was registered before,lol
Reply With Quote
  #10  
Old 01-14-2012, 06:47 PM
Roblee8908 Roblee8908 is offline
Registered User
Location: San Francisco
 
Join Date: Jan 2012
Posts: 39
Mein Auto: 2003 745i
Re-program? Is a re-program necessary for these cars? I ask because I have no idea.
Reply With Quote
  #11  
Old 01-14-2012, 08:52 PM
sirstopher's Avatar
sirstopher sirstopher is offline
bimmerfest Supporting Member
Location: Ok.
 
Join Date: Aug 2011
Posts: 1,092
Mein Auto: POS Honda
Just paid 230.00 at Indy for agm and program/ registered. It doesn't sound like the battery, sound more like the alternator. Check the voltage on the car with the obc, I also have replace my alternator 2 months ago. That was 1200.00 installed. Search the forums there are thousands of threads on this issue.

Sent from my PC36100 using Bimmer
__________________
97 740i e38 - SOLD
02 745i e65
03 Montero Limited

Reply With Quote
  #12  
Old 01-14-2012, 08:55 PM
pepe65's Avatar
pepe65 pepe65 is offline
750li 745i
Location: Greencastle Pennsylvania.
 
Join Date: Jul 2010
Posts: 519
Mein Auto: 745.750.x5.350z.ram1500v8
i went and put like a $60 battery in my car. been fine since last winter
__________________
Reply With Quote
  #13  
Old 01-14-2012, 08:59 PM
jenkx jenkx is offline
jenkx
Location: Los Angeles
 
Join Date: Nov 2011
Posts: 712
Mein Auto: BMW 745i
I'm not so sure the battery is your problem. However if you do need a new battery consider this:

http://www.autozone.com/autozone/par...9459_351749_0_


I purchased it from Autozone, installed it myself and haven't had a singe issue. I haven't had it registered, I didn't know anything about registering it till long after I installed it. I may get around to registering it one day
__________________
Roll'n in my 04'

Reply With Quote
  #14  
Old 01-14-2012, 09:20 PM
GregHolla8 GregHolla8 is offline
Registered User
Location: Nyc
 
Join Date: Feb 2011
Posts: 95
Mein Auto: 06 BMW 750LI
Will the agm blue top optima batteries work in this situation
Reply With Quote
  #15  
Old 01-14-2012, 11:06 PM
Roblee8908 Roblee8908 is offline
Registered User
Location: San Francisco
 
Join Date: Jan 2012
Posts: 39
Mein Auto: 2003 745i
Quote:
Originally Posted by jenkx View Post
I'm not so sure the battery is your problem. However if you do need a new battery consider this:

http://www.autozone.com/autozone/par...9459_351749_0_


I purchased it from Autozone, installed it myself and haven't had a singe issue. I haven't had it registered, I didn't know anything about registering it till long after I installed it. I may get around to registering it one day
registering it? WHAT is this?! re-program, register? AHHHH! can somebody explain why?!
Reply With Quote
  #16  
Old 01-15-2012, 01:03 AM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 539
Mein Auto: 2013 BMW 750 LiX
I just went thru everything you said in the description. I thought it might be the battery. Everything was going off and flickering when i tried to start the car. Then the steering wheel wouldn't come out. I replaced the battery with a BMW battery and didn't program it, 299+tax. went in fine. As long as the cca on the battery is 850 or higher no programing is needed.
Reply With Quote
  #17  
Old 01-15-2012, 05:57 AM
MOPAULY's Avatar
MOPAULY MOPAULY is offline
Officially Welcomed to the 'Fest
Location: Spring Mount, PA
 
Join Date: Sep 2010
Posts: 1,689
Mein Auto: Many things
Quote:
Originally Posted by Roblee8908 View Post
registering it? WHAT is this?! re-program, register? AHHHH! can somebody explain why?!
The battery needs to be registered to the car with INPA
__________________
Reply With Quote
  #18  
Old 01-15-2012, 09:17 AM
samadkins29's Avatar
samadkins29 samadkins29 is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2010
Posts: 3,827
Mein Auto: 2011 535i
Quote:
Originally Posted by Emeer18 View Post
I just went thru everything you said in the description. I thought it might be the battery. Everything was going off and flickering when i tried to start the car. Then the steering wheel wouldn't come out. I replaced the battery with a BMW battery and didn't program it, 299+tax. went in fine. As long as the cca on the battery is 850 or higher no programing is needed.
So did the battery fix your issues?

Quote:
Originally Posted by jenkx View Post
I'm not so sure the battery is your problem. However if you do need a new battery consider this:

http://www.autozone.com/autozone/par...9459_351749_0_


I purchased it from Autozone, installed it myself and haven't had a singe issue. I haven't had it registered, I didn't know anything about registering it till long after I installed it. I may get around to registering it one day
Ah, good find. "Glass mat" is what the dealer was jabbering on about. What do you guys think of Interstate batteries? They have a 900cca battery.

Quote:
Originally Posted by pepe65 View Post
i went and put like a $60 battery in my car. been fine since last winter
Really? I would reccomend you change that. $60 sounds waaay to cheap.

Quote:
Originally Posted by sirstopher View Post
Just paid 230.00 at Indy for agm and program/ registered. It doesn't sound like the battery, sound more like the alternator. Check the voltage on the car with the obc, I also have replace my alternator 2 months ago. That was 1200.00 installed. Search the forums there are thousands of threads on this issue.

Sent from my PC36100 using Bimmer
Will do. I was going to take it into a local shop monday morning to have them do a power check.
__________________
2011 535i
2003 745li (Sold)


Reply With Quote
  #19  
Old 01-15-2012, 10:10 AM
sirstopher's Avatar
sirstopher sirstopher is offline
bimmerfest Supporting Member
Location: Ok.
 
Join Date: Aug 2011
Posts: 1,092
Mein Auto: POS Honda
Quote:
Originally Posted by samadkins29 View Post
So did the battery fix your issues?



Ah, good find. "Glass mat" is what the dealer was jabbering on about. What do you guys think of Interstate batteries? They have a 900cca battery.



Really? I would reccomend you change that. $60 sounds waaay to cheap.



Will do. I was going to take it into a local shop monday morning to have them do a power check.
The car has the ability to so it, you need to open up the obc to check it.

Sent from my PC36100 using Bimmer
__________________
97 740i e38 - SOLD
02 745i e65
03 Montero Limited

Reply With Quote
  #20  
Old 01-15-2012, 10:29 AM
badeye badeye is offline
Registered User
Location: tacoma,wa
 
Join Date: Jan 2012
Posts: 17
Mein Auto: 2004 745LI
just got the car thursday,drove it back from scottdale,runs great only had 36500 miles on it,now got the phone working,need some help with,and sat radio
Reply With Quote
  #21  
Old 01-15-2012, 01:25 PM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 539
Mein Auto: 2013 BMW 750 LiX
Quote:
Originally Posted by samadkins29 View Post
So did the battery fix your issues
Yes it did solve the problem. i havent had a problem yet. You can make this simple. Goto your local autozone and have them test your alternator and battery. As long as your alternator is putting out 12.5volts at idle/500rpms i wouldnt be concerned about the alt. if your battery has less then a 12 volt charge when the engines not running, i'd say it was the battery. I went to 3 near by autozones just to see if any of them would say it wasnt the battery or anything different. They said the battery was loosing its ability to charge, going bad. I paid bmw for a new battery and didnt program it. I made sure i charged the battery before installation. Charge it at 2ohm trickle. These agm batteries are fancy lol
__________________
Reply With Quote
  #22  
Old 01-16-2012, 01:56 PM
Guest091814 Guest091814 is offline
Account closed at users request
 
Join Date: Jun 2010
Posts: 3,059
Mein Auto:
Quote:
Originally Posted by pepe65 View Post
i went and put like a $60 battery in my car. been fine since last winter
WTF LOL
Reply With Quote
  #23  
Old 01-16-2012, 04:39 PM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,904
Mein Auto: 750I
About registering the battery....not registering the battery will just shorten it's life. The car charges the battery differently when it's new versus when it's older. Basically for those who haven't registered your battery the car still thinks it is charging your old battery which may lead to over charging which may ultimately kill your battery. Any AGM type 49 battery with at least 120 mins reserve and 850+ CCA should be fine.

It could take one year, 2 years or more to see the effects of not registering your battery. A properly registered battery should last 5 years + without any issues.
__________________
Reply With Quote
  #24  
Old 01-16-2012, 05:13 PM
mikewerks's Avatar
mikewerks mikewerks is offline
Officially Welcomed to the 'Fest
Location: PNW
 
Join Date: Apr 2008
Posts: 298
Mein Auto: 02' 745i
In conclusion-- Register the battery, why take a chance.
Reply With Quote
  #25  
Old 01-16-2012, 05:15 PM
samadkins29's Avatar
samadkins29 samadkins29 is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2010
Posts: 3,827
Mein Auto: 2011 535i
Just a lose Neg (-) connection on the battery. I tightened it up and everything has been fine since. ........
__________________
2011 535i
2003 745li (Sold)


Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series & 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:48 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.