2003 Z4 help. - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-21-2012, 05:25 PM
Anomic1 Anomic1 is offline
Registered User
Location: Moreno Valley
 
Join Date: Feb 2012
Posts: 20
Mein Auto: 2003 BMW Z4 2.5i roadster
Unhappy 2003 Z4 help.

whats up everyone. well this weekend i made the stupid mistake of putting my lunch box with ice water in trunk. the water ended up spilling and getting into battery area. i didnt notice until my radio died speakers started to pop, then died completely. i dried and cleaned the area, but do to my dumbass mistake still dead....luckily its the only problem ive had...my question is...what is most likely damaged or what do i need to replace in order to get sounds back on? would appreciate any feedback thanks.
Attached Thumbnails
Click image for larger version

Name:	IMAG0380.jpg
Views:	114
Size:	85.3 KB
ID:	326564   Click image for larger version

Name:	IMAG0379.jpg
Views:	117
Size:	112.6 KB
ID:	326565   Click image for larger version

Name:	IMAG0378.jpg
Views:	120
Size:	106.9 KB
ID:	326566   Click image for larger version

Name:	IMAG0377.jpg
Views:	110
Size:	94.0 KB
ID:	326567   Click image for larger version

Name:	IMAG0376.jpg
Views:	118
Size:	104.2 KB
ID:	326568  


Last edited by Anomic1; 05-25-2012 at 05:14 PM.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-21-2012, 08:05 PM
BU Z4 BU Z4 is offline
JUVENTUS
Location: Dallas
 
Join Date: Jun 2008
Posts: 24
Mein Auto: Z
Amplifier died
Reply With Quote
  #3  
Old 05-22-2012, 04:02 AM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 641
Mein Auto: BMW Z4 3.0
You fried your Amp. It is the flat black box in the battery area. Check your fuse's. Might of just blown a fuse if your are lucky. Good luck !
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 05-23-2012, 05:10 PM
Anomic1 Anomic1 is offline
Registered User
Location: Moreno Valley
 
Join Date: Feb 2012
Posts: 20
Mein Auto: 2003 BMW Z4 2.5i roadster
thanks guys
Reply With Quote
  #5  
Old 08-12-2012, 12:13 PM
crosboe crosboe is offline
Registered User
Location: Massachusetts
 
Join Date: Aug 2012
Posts: 4
Mein Auto: BMW Z4
Same problem ;/

Hey, same exact thing happened to me except it was some cleaning soap that spilled in my trunk. I really think the battery compartment should have a snap on plastic lid that at least semi protects it...none the less it was still my fault. Everything in the car works find but speakers popped for a bit then died when I realized about the spill.

Did you make any progress fixing it up? Was it just a fuse, or did you have to replace the part, and were the speakers ok after? Thanks a bunch.
Reply With Quote
  #6  
Old 08-13-2012, 08:11 AM
Trapper Trapper is offline
I'd rather by driving
Location: Sudbury
 
Join Date: Jun 2012
Posts: 112
Mein Auto: 2003 Z4 2.5 Titanium Silv
I just replaced the amp in my 03 Z4. I got a used one from A1euromotors in Florida. Just e-mail them your amp number to see if they have a replacment on hand. The cheapest solution i found.


E-mail [email protected]
Reply With Quote
  #7  
Old 08-13-2012, 08:55 AM
Anomic1 Anomic1 is offline
Registered User
Location: Moreno Valley
 
Join Date: Feb 2012
Posts: 20
Mein Auto: 2003 BMW Z4 2.5i roadster
Hey sorry for the late reply crosboe. I didn't resolve my amp issue yet. I got so fustrated I gave up for the moment, but need to do something about it asap! I hate my sounds rightnow...my speakers sound horrible volume can only go so high, no bass and sounds horrible!....do you know if the amp I have installed on 03 not 04 has a fuse? I've seen diffrent years with fuses on outside of amp,but there isn't one on the outside of this one..I haven't replaced because its too damn expensive for a stock amp. I was hoping to upgrade with custom harness,but that fustrated me further.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:25 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.