02 325i random CEL and rough idle - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > General BMW Questions

General BMW Questions
Use this forum to ask general question about the BMW ownership and keep up on the latest BMW news. Direct all model specific questions to model specific forums below.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-13-2019, 07:39 PM
alexgmzz alexgmzz is offline
Registered User
 
Join Date: Nov 2019
Posts: 18
Mein Auto:
02 325i random CEL and rough idle

Hi all. I have an 02 325i. It had really bad idle and misfires. I replaced spark plugs, cleaned throttle body, ran sea foam through intake, swapped coils to see if misfires changed but didn't so seems could are good and it ran much better. However, it still had rough idle and CEL P0171. It ended up having a few vacuum leaks, I got those fixed. It now runs smooth BUT every now and again I'll get a rough idle at a stand still or while driving and CEL comes on. I check codes and I get the same P0171 among others. All related to misfires. Anyone know how it could run smooth for 2 days then suddenly have a P0171 with rough idle then 10 minutes later run smooth again??
Attached Thumbnails
Click image for larger version

Name:	810503CA-2126-4DB0-8722-37A600F8AD11_1573698863970.jpg
Views:	5
Size:	32.4 KB
ID:	872069   Click image for larger version

Name:	48C0E836-AA5D-4734-8377-437D6735237B_1573698890843.jpg
Views:	5
Size:	43.0 KB
ID:	872071   Click image for larger version

Name:	07621CB3-B825-45D2-8187-A6AAF68DE72E_1573698919060.jpg
Views:	6
Size:	43.9 KB
ID:	872073   Click image for larger version

Name:	13013D45-EB4D-4BA9-B593-61A29E71A548_1573698950935.jpg
Views:	5
Size:	45.9 KB
ID:	872075   Click image for larger version

Name:	74BEA3AA-5A75-4AC3-BEFE-A0814C9793C9_1573698981959.jpg
Views:	4
Size:	45.6 KB
ID:	872077  

Click image for larger version

Name:	0D653A87-69A2-47BA-BA75-0EFDC398A624_1573699013474.jpg
Views:	4
Size:	45.0 KB
ID:	872079   Click image for larger version

Name:	2A7F6077-1BDF-482D-99F4-ADE128BA9639_1573699040026.jpg
Views:	5
Size:	46.2 KB
ID:	872081  
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2019, 07:50 PM
alexgmzz alexgmzz is offline
Registered User
 
Join Date: Nov 2019
Posts: 18
Mein Auto:
Forgot to mention I did a DIY smoke test to find vacuums - I may have missed one but still don't understand how it could run fine for several days then suddenly start sputtering. I also replaced the DISA O ring which was almost gone so definitely had a vacuum leak at DISA among others I found on brake booster hose.
Reply With Quote
  #3  
Old 11-14-2019, 06:20 AM
marcozandrini marcozandrini is offline
Officially Welcomed to the 'Fest
Location: Virginia
 
Join Date: Feb 2014
Posts: 5,253
Mein Auto: 2018 M240i
The only way to find all of the vacuum leaks is to professionally smoke test the intake. Find a reputable indie shop that specializes in bimmers at www.bimrs.org.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > General BMW Questions
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.