Z4 2.0i cold start problem - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-12-2018, 09:15 AM
mirkoz4 mirkoz4 is offline
Registered User
 
Join Date: May 2018
Posts: 2
Mein Auto:
Z4 2.0i cold start problem

Hello, I'm Mirko from Italy. I have a BMW z4 e85 Facelift, 2.0i, N46 engine. There's a problem on cold start. The engine starts very well but then drops down to 200rpm and then resumes. The car oscillates a lot. When the engine heats up, even if I start the engine after 3 hours it starts without problems. So reading the ecu errors i see camshaft sensor A error, so i changed both sensors with oem. No more errors and the problem is still there. After checked any air leak, cleaned maf, cleaned throttle valve, changed seals. Vanos solenoids are new and valvetronic motor have been changed from BMW service last year. Spark plugs new. Some days ago i tried to disconnect a vanos solenoid connector and cold start problem disappeared. Then reconnected, cold start problem. Disconnected valvetronic sensor, problem disappeared. I used the car for some days with engine light on. No more cold start problems. In the end, i see there is an oil leak the back valve cover gasket and in a spark plug seat. Since if the valvetronic is switched off, the throttle valve starts working and the engine works well, can the gasket leak cause this problem? Sorry for my english. I hope someone can help me. Thank you very much.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-18-2018, 07:37 AM
mirkoz4 mirkoz4 is offline
Registered User
 
Join Date: May 2018
Posts: 2
Mein Auto:
nobody knows anything?
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:25 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.