N55 JB4/MHD issues - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-28-2019, 12:18 PM
New_guy New_guy is offline
Registered User
Location: Port Saint Lucie, FL
 
Join Date: Apr 2017
Posts: 70
Mein Auto: 2012 BMW 335i MSport
N55 JB4/MHD issues

2012 E92 N55 335I, Intercooler, Catless Downpipes, CAI, Charge pipe, JB4/MHD Backend flash.

So I've been having issues for a while, where while I cruise the car would suddenly jerk.. I would get codes that disappear from the JB4 such as; 2FAD, 2EFE, 2F04,0000. Did some searching and it said those were miss fires.( the JB4 would not save the codes, it would erase them immediately). Took it to my local Bimmer mechanic who hooked up his code reader and it kept telling him I have a software issue. Now I did notice the issues started after I got the MHD Backend Flash (I got it for the burble tune which sounds great). I'm wondering if anyone has had a similar issue, and if there is a way to fix it without having to remove the MHD or the JB4. I know I should have a backup file on the MHD but lets pretend I don't.... What would I have to do ???

Side note: I had to get the DME unlocked before getting the MHD flash as I have a 2012 N55. Its also automatic and only gave me the "jerk" while I drove it in auto, but once I switched to Sport/Manual it would'nt happen. I am also not getting any boost.. at all.... The car was checked and I did have some hoses from the intercooler which were loose, but they have been adjusted and fastened appropriately.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-28-2019, 02:16 PM
Yukoner Yukoner is offline
Officially Welcomed to the 'Fest
Location: Whitehorse, YT
 
Join Date: May 2017
Posts: 1,765
Mein Auto: 2011 328i x-drive
Did the car run perfectly fine BEFORE you did JB4 / MHD ?
__________________


Not even sure if -40 degrees is cold anymore ?
Reply With Quote
  #3  
Old 08-28-2019, 04:54 PM
New_guy New_guy is offline
Registered User
Location: Port Saint Lucie, FL
 
Join Date: Apr 2017
Posts: 70
Mein Auto: 2012 BMW 335i MSport
It ran perfect before I did the MHD, then a few months later it started jerking. I'm wondering if I remove the MHD and reinstall it, if it will help.
__________________
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 08-29-2019, 06:49 AM
rdkind62's Avatar
rdkind62 rdkind62 is offline
Officially Welcomed to the 'Fest
Location: Falcon, CO.
 
Join Date: Jan 2008
Posts: 2,547
Mein Auto: '16 Z4, '17 Mustang
As a professional troubleshooter kind of guy, I would recommend putting things back to original and then adding one thing at a time with drive time in between each addition to see it the trouble returns. One thing I am sure of because it happened to me was that new plugs are almost a must when beginning to do engine mods. My car only had 26K miles on it when I started on mine and immediately began throwing codes for misfires until I replaced the plugs.
__________________

2016 Z4 in Estoril Blue.
Reply With Quote
  #5  
Old 08-29-2019, 07:43 AM
New_guy New_guy is offline
Registered User
Location: Port Saint Lucie, FL
 
Join Date: Apr 2017
Posts: 70
Mein Auto: 2012 BMW 335i MSport
Quote:
Originally Posted by rdkind62 View Post
As a professional troubleshooter kind of guy, I would recommend putting things back to original and then adding one thing at a time with drive time in between each addition to see it the trouble returns. One thing I am sure of because it happened to me was that new plugs are almost a must when beginning to do engine mods. My car only had 26K miles on it when I started on mine and immediately began throwing codes for misfires until I replaced the plugs.
yeah, when I first did the MHD back end flash I immediately changed the sparks and coils. I'm just hoping that when I remove the MHD and JB4, I don't have issues since I have all those mods done to the car.
Reply With Quote
  #6  
Old 09-13-2019, 06:06 AM
raceit17 raceit17 is offline
Registered User
Location: Bloomington, IN
 
Join Date: Jul 2017
Posts: 14
Mein Auto: 335i xdrive
I had my 2011 335i x drive N55 E92 jerk on me a lot when I was taking off, turns out it the clamp came loose on the boost and I also replaced my O2 sensor. Car runs great now. I'm also Running the JB4
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:50 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.