Driver's side control buttons not working - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2005, 07:50 AM
jchx5 jchx5 is offline
 
Join Date: Jan 2005
Posts: 12
Mein Auto:
Driver's side control buttons not working

Hi,

This morning while driving to work, all my driver's side control buttons stop working. This includes the windows, side mirrors, and even the door lock. I didn't have time to check it further. Could this be simply a fuse burned out? Or a visit to dealer is unavoidable?

Thanks in advance.

JCHX5
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-04-2005, 09:37 AM
UCrewX5's Avatar
UCrewX5 UCrewX5 is offline
Member of the club
Location: Grosse Ile, MI
 
Join Date: Sep 2004
Posts: 1,280
Mein Auto: BMW X5
Quote:
Originally Posted by jchx5
Hi,

This morning while driving to work, all my driver's side control buttons stop working. This includes the windows, side mirrors, and even the door lock. I didn't have time to check it further. Could this be simply a fuse burned out? Or a visit to dealer is unavoidable?

Thanks in advance.

JCHX5
The control panel just pops out. Try pulling it out and make sure that the harness is still properly connected. You may also try disconnecting and reconnecting the harness.
__________________
  #3  
Old 01-04-2005, 10:00 AM
jchx5 jchx5 is offline
 
Join Date: Jan 2005
Posts: 12
Mein Auto:
Quote:
Originally Posted by UCrewX5
The control panel just pops out. Try pulling it out and make sure that the harness is still properly connected. You may also try disconnecting and reconnecting the harness.
Thanks Jeff. I will try that tonight. Do I need any tool to pop it out?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-04-2005, 10:22 AM
UCrewX5's Avatar
UCrewX5 UCrewX5 is offline
Member of the club
Location: Grosse Ile, MI
 
Join Date: Sep 2004
Posts: 1,280
Mein Auto: BMW X5
Quote:
Originally Posted by jchx5
Thanks Jeff. I will try that tonight. Do I need any tool to pop it out?
The only thing you should need is a small flat-blade screwdriver (or similar) to pop it up and pull it out.
__________________
  #5  
Old 01-04-2005, 12:09 PM
IFlyX5's Avatar
IFlyX5 IFlyX5 is offline
Officially Welcomed to the 'Fest
Location: Somewhere
 
Join Date: Aug 2003
Posts: 525
Mein Auto: '15 535i MSport
Quote:
Originally Posted by jchx5
Hi,

This morning while driving to work, all my driver's side control buttons stop working. This includes the windows, side mirrors, and even the door lock. I didn't have time to check it further. Could this be simply a fuse burned out? Or a visit to dealer is unavoidable?

Thanks in advance.

JCHX5
Does the control on the passenger's side (or rear passengers' sides) still work?
If not, I would check the fuse first. The fuse is located in the fuse block inside the glove compartment above front passenger's seat.
__________________
2015 535i MSport Space Gray/Black Nappa | Driver Assistance | Premium | HK Sound | Heated Front Seats
Reply With Quote
  #6  
Old 01-04-2005, 01:07 PM
jchx5 jchx5 is offline
 
Join Date: Jan 2005
Posts: 12
Mein Auto:
Quote:
Originally Posted by IFlyX5
Does the control on the passenger's side (or rear passengers' sides) still work?
If not, I would check the fuse first. The fuse is located in the fuse block inside the glove compartment above front passenger's seat.
Hi Peter,

I cannot control neither the passenger's side nor the rear windows through the driver's control panel anymore, but their own window control buttons work fine. Does this mean the fuse isn't the problem here?

Thanks a lot.

JCH

Last edited by jchx5; 01-04-2005 at 01:12 PM.
Reply With Quote
  #7  
Old 01-04-2005, 01:24 PM
IFlyX5's Avatar
IFlyX5 IFlyX5 is offline
Officially Welcomed to the 'Fest
Location: Somewhere
 
Join Date: Aug 2003
Posts: 525
Mein Auto: '15 535i MSport
Quote:
Originally Posted by jchx5
Hi Peter,

I cannot control neither the passenger's side nor the rear windows through the driver's control panel anymore, but their own window control buttons work fine. Does this mean the fuse isn't the problem here?

Thanks a lot.

JCH
JCH - It's probably not the fuse then. It could be a bad window control module on the driver's door. You may want to refer to TripleX5's article on retrofitting the auto-folding mirrors on x5world.net (link here: http://www.x5world.com/foldingmirror.htm), under the "Removing the window control module" section. This section shows you how to remove the window control panel.

One thing I'd like to add is that when you re-install the window control module, get some felt adhesive tape (from Michael's or Jo-Ann Fabrics) and line it around the edge of the module before inserting it back into the door. This helps minimizing any rattles or creaks. It helped with mine when I had to remove the door the last time.

Good luck, JCH.
__________________
2015 535i MSport Space Gray/Black Nappa | Driver Assistance | Premium | HK Sound | Heated Front Seats
Reply With Quote
  #8  
Old 01-04-2005, 02:05 PM
gr8wall gr8wall is offline
 
Join Date: Oct 2003
Posts: 24
Mein Auto:
Quote:
Originally Posted by jchx5
Hi Peter,

I cannot control neither the passenger's side nor the rear windows through the driver's control panel anymore, but their own window control buttons work fine. Does this mean the fuse isn't the problem here?

Thanks a lot.

JCH

JCH,

I would definitely check the fuse first, as IFlyX5 has mentioned above - inside the glove box, because the same thing happened to me a few weeks ago. Same symptoms as you have described. I don't recall the exact location of the fuse but it is a 30 amp (green) fuse located in the middle on the top row. Take a look at the fuse layout below the fuse holder. Also, there should be a spare fuse.

Let me know if you have any problems locating it. I'll take a glance at it when I get home. Hope this helps and good luck with it!
Reply With Quote
  #9  
Old 01-04-2005, 06:16 PM
jchx5 jchx5 is offline
 
Join Date: Jan 2005
Posts: 12
Mein Auto:
Hi,

You guys are the best. It turns out that one of the fuses, located as gr8wall mentioned, is burned out. Once I replaced it, the problem is gone.

However, the window on driver's side is now having problem closing. It goes up very slow and stop in the middle. It only close all the way up if I help it with hand. Is this the symptom of the well-known window regulator problem? I am thinking this might be what caused the fuse to burn out.

My X5's production date is 07/2001. Do I have to pay for the window regulator or am I still covered?

Thanks again.

JCHX5

Last edited by jchx5; 01-04-2005 at 06:27 PM.
Reply With Quote
  #10  
Old 01-04-2005, 06:18 PM
x55exy x55exy is offline
 
Join Date: Dec 2004
Posts: 85
Mein Auto:
Quote:
Originally Posted by gr8wall
JCH,

I would definitely check the fuse first, as IFlyX5 has mentioned above - inside the glove box, because the same thing happened to me a few weeks ago. Same symptoms as you have described. I don't recall the exact location of the fuse but it is a 30 amp (green) fuse located in the middle on the top row. Take a look at the fuse layout below the fuse holder. Also, there should be a spare fuse.

Let me know if you have any problems locating it. I'll take a glance at it when I get home. Hope this helps and good luck with it!
i swear the fuse box was in the boot on the drivers side. tell me if i am wrong cauase it is like that with the uk x5
Reply With Quote
  #11  
Old 01-04-2005, 06:28 PM
UCrewX5's Avatar
UCrewX5 UCrewX5 is offline
Member of the club
Location: Grosse Ile, MI
 
Join Date: Sep 2004
Posts: 1,280
Mein Auto: BMW X5
Quote:
Originally Posted by jchx5
Hi,

You guys are the best. It turns out that one of the fuses, located as gr8wall mentioned, is burned out. Once I replaced it, the problem is gone.

However, the window on driver's side is now having problem closing. It goes up very slow and stop in the middle. It only close all the way up if I help it with hand. Is this the symptom of the well-known "Faulty window control arm" problem? I am thinking this might be what caused the fuse to burn out.

My X5's production date is 07/2001. Do I have to pay for the window control arm or am I still covered?

Thanks again.

JCHX5
The warranty isn't based on the production date, it's based on when the vehicle went into service (ie. when it was first titled) and/or the miles on the vehicle. If you aren't certain, contact your dealer and they can tell you if you are still under warranty or not.

If the warranty has expired, changing out the window regulator unit is not all that difficult as a DIY.
__________________
  #12  
Old 01-04-2005, 06:37 PM
IFlyX5's Avatar
IFlyX5 IFlyX5 is offline
Officially Welcomed to the 'Fest
Location: Somewhere
 
Join Date: Aug 2003
Posts: 525
Mein Auto: '15 535i MSport
Quote:
Originally Posted by x55exy
i swear the fuse box was in the boot on the drivers side. tell me if i am wrong cauase it is like that with the uk x5
That's the 2nd fuse box. There are at least 2 in the X5 that I know of. One is in the glove compartment, the other is in the trunk (boot). However, none will allow you to watch TV while driving.
__________________
2015 535i MSport Space Gray/Black Nappa | Driver Assistance | Premium | HK Sound | Heated Front Seats
Reply With Quote
  #13  
Old 01-04-2005, 07:27 PM
UCrewX5's Avatar
UCrewX5 UCrewX5 is offline
Member of the club
Location: Grosse Ile, MI
 
Join Date: Sep 2004
Posts: 1,280
Mein Auto: BMW X5
Quote:
Originally Posted by IFlyX5
However, none will allow you to watch TV while driving.
__________________
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
E65 V12 debuts nate General BMW Questions 22 06-09-2016 12:44 AM
A purist review of SMG II nate General BMW Questions 30 03-25-2013 05:47 PM
This Is The Official Hijack Thread... Sabrina Off-Topic 146 05-21-2009 06:38 PM
BMW ConnectedDrive: ChrisTO General BMW Questions 12 11-08-2005 06:41 AM


All times are GMT -7. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.