525i running and idling rough - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-13-2018, 01:42 PM
LambChops LambChops is offline
Registered User
Location: Pennsylvania
 
Join Date: Jan 2014
Posts: 5
Mein Auto: 1998 BMW 528i
525i running and idling rough

Hey ya'll, I just want to get an opinion.

I have had my 2003 525i for about 4 years now, and it is awesome, but now it is running really rough and idling VERY poorly. Came to a point where I actually stalled in the road at a light (its also an automatic). I got the error codes and one that stuck out is the code P0313. So I was thinking, "alright so my injectors aren't getting the correct amount of fuel. I'll first try the fuel filter. Thats pretty common." After I replaced it, it still had trouble. I lost a good amount of horsepower and I was about to get new injectors and fuel pump, but then I looked at the other codes, and they read P0171, P0174, P1083, P1085 and P1620. This opens up many other causes for my problems. The biggest problem could be a vacuum leak, because I don't think both my Oxygen Sensors would go bad at the same time. So any thoughts? I am getting it diagnosed on Wednesday, but I am still trying to find out as much info I can.

Thanks!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-13-2018, 03:06 PM
mattmar1's Avatar
mattmar1 mattmar1 is offline
Wingnut
Location: Louisiana
 
Join Date: Dec 2014
Posts: 3,153
Mein Auto: 1999 5281 5 sp msport
to start. itd help if you define each code at the start so we dont have to look em all up.
youve most likely got a vacuum leak, and a bad thermostat to boot (the 1620 code)
yes inadequate fuel delivery can cause lean codes, the way to test for that is with a fuel pressure gauge, measuring pressure on the injector rail ( should read 50 psi or so)
but id look first at a vac leak, a common issue, its covered well on this site if you do a search for it.
a smoke test is a good way to pinpoint vac leaks.
__________________
99 528i 5sp sport


be alert...the world needs more lerts
Reply With Quote
Reply

See More Related BMW Stories

Tags
e39, error, fuel, idle, misfire, stall


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:41 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.